aboutsummaryrefslogtreecommitdiff
path: root/audio/cheesecutter
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2021-01-21 19:40:27 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2021-01-21 19:40:27 +0000
commit1112f73b20b07c6831a670361ac254c09dea8a7a (patch)
tree04c721eef09c37efe82bf309ddd0c94240b948f9 /audio/cheesecutter
parentb6d631fe6cdeee2f541834666cbeeefb111069c8 (diff)
downloadports-1112f73b20b07c6831a670361ac254c09dea8a7a.tar.gz
ports-1112f73b20b07c6831a670361ac254c09dea8a7a.zip
Add cheesecutter 2.9.b.3.25, tracker for composing music for the C64 SID
chip.
Notes
Notes: svn path=/head/; revision=562237
Diffstat (limited to 'audio/cheesecutter')
-rw-r--r--audio/cheesecutter/Makefile39
-rw-r--r--audio/cheesecutter/distinfo3
-rw-r--r--audio/cheesecutter/files/patch-Makefile.ldc25
-rw-r--r--audio/cheesecutter/files/patch-src_main.d13
-rw-r--r--audio/cheesecutter/pkg-descr5
-rw-r--r--audio/cheesecutter/pkg-plist22
6 files changed, 107 insertions, 0 deletions
diff --git a/audio/cheesecutter/Makefile b/audio/cheesecutter/Makefile
new file mode 100644
index 000000000000..d677f2ccefab
--- /dev/null
+++ b/audio/cheesecutter/Makefile
@@ -0,0 +1,39 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cheesecutter
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.9-beta-3-25
+DISTVERSIONSUFFIX= -gdbe9a9d
+CATEGORIES= audio
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Tracker for composing music for the C64 SID chip
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+BUILD_DEPENDS= acme:devel/acme \
+ ldc2:lang/ldc
+
+USES= desktop-file-utils gmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= ehaupt
+GH_PROJECT= CheeseCutter
+
+MAKEFILE= Makefile.ldc
+MAKE_ENV+= EXAMPLESDIR=${EXAMPLESDIR}
+
+OPTIONS_DEFINE= EXAMPLES
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${MANPREFIX}/share/man/fr/man1 ${STAGEDIR}${DESKTOPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/arch/fd/ccutter.desktop ${STAGEDIR}${DESKTOPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/icons/cc96.png ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+.for f in ccutter ct2util
+ ${INSTALL_MAN} ${WRKSRC}/doc/${f}.1 ${STAGEDIR}${MANPREFIX}/share/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/${f}.fr.1 ${STAGEDIR}${MANPREFIX}/share/man/fr/man1
+.endfor
+
+.include <bsd.port.mk>
diff --git a/audio/cheesecutter/distinfo b/audio/cheesecutter/distinfo
new file mode 100644
index 000000000000..609f3a3fb474
--- /dev/null
+++ b/audio/cheesecutter/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1611248944
+SHA256 (ehaupt-CheeseCutter-v2.9-beta-3-25-gdbe9a9d_GH0.tar.gz) = cd4fe2dc508e674fd01f2f464f0fb86b61a2c0dd052c3707e84609b037be2806
+SIZE (ehaupt-CheeseCutter-v2.9-beta-3-25-gdbe9a9d_GH0.tar.gz) = 407983
diff --git a/audio/cheesecutter/files/patch-Makefile.ldc b/audio/cheesecutter/files/patch-Makefile.ldc
new file mode 100644
index 000000000000..2c3ddca6aaa5
--- /dev/null
+++ b/audio/cheesecutter/files/patch-Makefile.ldc
@@ -0,0 +1,25 @@
+--- Makefile.ldc.orig 2021-01-21 17:07:49 UTC
++++ Makefile.ldc
+@@ -1,5 +1,7 @@
+ # make install DESTDIR=/home/yamo/devel/cc2/snap/parts/ccutter/install
+
++PREFIX?=/usr
++EXAMPLESDIR?=/usr/share/examples/ccutter
+ LIBS=-L-ldl -L-lstdc++
+ COMFLAGS=-O2
+ VERSION=$(shell cat Version)
+@@ -38,10 +40,10 @@ c64: $(C64OBJS)
+ install: all
+ strip ccutter$(EXE)
+ strip ct2util$(EXE)
+- cp ccutter$(EXE) $(DESTDIR)
+- cp ct2util$(EXE) $(DESTDIR)
+- mkdir $(DESTDIR)/example_tunes
+- cp -r tunes/* $(DESTDIR)/example_tunes
++ cp ccutter$(EXE) $(DESTDIR)$(PREFIX)/bin
++ cp ct2util$(EXE) $(DESTDIR)$(PREFIX)/bin
++ mkdir -p $(DESTDIR)/$(EXAMPLESDIR)/example_tunes
++ cp -r tunes/* $(DESTDIR)/$(EXAMPLESDIR)/example_tunes
+
+ # release version with additional optimizations
+ release: DFLAGS += -frelease -fno-bounds-check
diff --git a/audio/cheesecutter/files/patch-src_main.d b/audio/cheesecutter/files/patch-src_main.d
new file mode 100644
index 000000000000..c87f886073ef
--- /dev/null
+++ b/audio/cheesecutter/files/patch-src_main.d
@@ -0,0 +1,13 @@
+--- src/main.d.orig 2020-12-25 15:36:31 UTC
++++ src/main.d
+@@ -23,6 +23,10 @@ version(linux) {
+ const DIR_SEPARATOR = '/';
+ }
+
++version(FreeBSD) {
++ const DIR_SEPARATOR = '/';
++}
++
+ version(OSX) {
+ const DIR_SEPARATOR = '/';
+ }
diff --git a/audio/cheesecutter/pkg-descr b/audio/cheesecutter/pkg-descr
new file mode 100644
index 000000000000..970ffbafb1a6
--- /dev/null
+++ b/audio/cheesecutter/pkg-descr
@@ -0,0 +1,5 @@
+CheeseCutter is a tracker for composing music for the SID chip. It uses
+the reSID engine for SID emulation. The packed files can be played on a
+real C64.
+
+WWW: https://github.com/theyamo/CheeseCutter
diff --git a/audio/cheesecutter/pkg-plist b/audio/cheesecutter/pkg-plist
new file mode 100644
index 000000000000..f55877ee31e4
--- /dev/null
+++ b/audio/cheesecutter/pkg-plist
@@ -0,0 +1,22 @@
+bin/ccutter
+bin/ct2util
+share/applications/ccutter.desktop
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_tunes/abaddon-starfish.ct
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_tunes/abaddon-swingcat.ct
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_tunes/abaddon-trouble.ct
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_tunes/drvector-ftrcrck.ct
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_tunes/drvector-ftrcwby.ct
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_tunes/guyshavitt-dustandrust.ct
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_tunes/mch-cheesecatsgroove.ct
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_tunes/scarzix-KnightsAndDames.ct
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_tunes/scarzix-cheese-around-the-clock.ct
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_tunes/scarzix-visualbrothers.ct
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_tunes/spider_jerusalem-KaeseKacker.ct
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_tunes/tempest-soyoudied.ct
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_tunes/vent-arkijuusto.ct
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_tunes/wisdom-Adrift.ct
+share/man/fr/man1/ccutter.fr.1.gz
+share/man/fr/man1/ct2util.fr.1.gz
+share/man/man1/ccutter.1.gz
+share/man/man1/ct2util.1.gz
+share/pixmaps/cheesecutter.png