aboutsummaryrefslogtreecommitdiff
path: root/audio/chromaprint
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2017-01-06 14:24:00 +0000
committerJason E. Hale <jhale@FreeBSD.org>2017-01-06 14:24:00 +0000
commit409995bd9e2d1e60fbb1b44b4e814e7427decb4d (patch)
treecadd1aac5f51e6976742f350546692d8a7d2c30f /audio/chromaprint
parent27bdaeabe6c43eb6fb99fce14f9abaec160d0caa (diff)
downloadports-409995bd9e2d1e60fbb1b44b4e814e7427decb4d.tar.gz
ports-409995bd9e2d1e60fbb1b44b4e814e7427decb4d.zip
Update audio/chromaprint to 1.4.2
- Chromaprint itself is now licensed MIT, but it still includes LGPL21 code - Add DOXYGEN option to build and install API docs - Add TEST option to build regression tests - API has changed, so some dependent ports needed to be patched (mostly taken from their respective upstream repositories) Changes: https://github.com/acoustid/chromaprint/blob/v1.4.2/NEWS.txt
Notes
Notes: svn path=/head/; revision=430708
Diffstat (limited to 'audio/chromaprint')
-rw-r--r--audio/chromaprint/Makefile37
-rw-r--r--audio/chromaprint/distinfo5
-rw-r--r--audio/chromaprint/files/patch-tests_CMakeLists.txt14
-rw-r--r--audio/chromaprint/pkg-plist2
4 files changed, 48 insertions, 10 deletions
diff --git a/audio/chromaprint/Makefile b/audio/chromaprint/Makefile
index e6a99eadba67..f23e45f59672 100644
--- a/audio/chromaprint/Makefile
+++ b/audio/chromaprint/Makefile
@@ -1,22 +1,45 @@
# $FreeBSD$
PORTNAME= chromaprint
-PORTVERSION= 1.3.1
-PORTREVISION= 1
+PORTVERSION= 1.4.2
CATEGORIES= audio
-MASTER_SITES= http://bitbucket.org/acoustid/${PORTNAME}/downloads/
+MASTER_SITES= https://github.com/acoustid/${PORTNAME}/releases/download/v${PORTVERSION}/ \
+ https://bitbucket.org/acoustid/${PORTNAME}/downloads/
MAINTAINER= jhale@FreeBSD.org
COMMENT= AcoustID audio fingerprinting library
-LICENSE= LGPL21
+LICENSE= LGPL21 MIT
+LICENSE_COMB= multi
+LICENSE_FILE_MIT= ${WRKSRC}/LICENSE.md
LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
-USES= cmake:outsource pathfix
+USES= cmake:outsource compiler:c++11-lib pathfix
USE_LDCONFIG= yes
-CMAKE_ARGS= -DBUILD_EXAMPLES:BOOL=ON \
- -DWITH_AVFFT:BOOL=ON \
+CMAKE_ARGS= -DBUILD_TOOLS:BOOL=true \
+ -DFFT_LIB:STRING=avfft
+
+OPTIONS_DEFINE= DOXYGEN TEST
+
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
+ dot:graphics/graphviz
+DOXYGEN_PORTDOCS= *
+# PORTDOCS macro won't work if NOPORTDOCS is defined or if DOCS is disabled
+DOXYGEN_IMPLIES= DOCS
+.undef NOPORTDOCS
+
+TEST_BUILD_DEPENDS= ${NONEXISTENT}:devel/googletest:patch
+TEST_CMAKE_BOOL= BUILD_TESTS
+TEST_CMAKE_ON= -DGTEST_ROOT:PATH=`${MAKE} -C ${PORTSDIR}/devel/googletest -VWRKSRC`
+TEST_TARGET= check
+
+do-build-DOXYGEN-on:
+ @(cd ${BUILD_WRKSRC}; ${DO_MAKE_BUILD} docs)
+
+do-install-DOXYGEN-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${INSTALL_WRKSRC}/doc; ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/audio/chromaprint/distinfo b/audio/chromaprint/distinfo
index c1ec6f17af6d..2ca5ad0aed93 100644
--- a/audio/chromaprint/distinfo
+++ b/audio/chromaprint/distinfo
@@ -1,2 +1,3 @@
-SHA256 (chromaprint-1.3.1.tar.gz) = 8f95a011e6fe3a75281520daa9376b7f028300e20a5be9af08ef9c851d4bb581
-SIZE (chromaprint-1.3.1.tar.gz) = 538251
+TIMESTAMP = 1483658531
+SHA256 (chromaprint-1.4.2.tar.gz) = 989609a7e841dd75b34ee793bd1d049ce99a8f0d444b3cea39d57c3e5d26b4d4
+SIZE (chromaprint-1.4.2.tar.gz) = 613367
diff --git a/audio/chromaprint/files/patch-tests_CMakeLists.txt b/audio/chromaprint/files/patch-tests_CMakeLists.txt
new file mode 100644
index 000000000000..a34c06840c6b
--- /dev/null
+++ b/audio/chromaprint/files/patch-tests_CMakeLists.txt
@@ -0,0 +1,14 @@
+--- tests/CMakeLists.txt.orig 2016-12-23 11:50:27 UTC
++++ tests/CMakeLists.txt
+@@ -36,6 +36,11 @@ set(SRCS
+ if(BUILD_TOOLS)
+ set(SRCS ${SRCS} ../src/audio/ffmpeg_audio_reader_test.cpp)
+ link_libraries(fpcalc_libs)
++ include_directories(
++ ${FFMPEG_LIBAVCODEC_INCLUDE_DIRS}
++ ${FFMPEG_LIBAVFORMAT_INCLUDE_DIRS}
++ ${FFMPEG_LIBAVUTIL_INCLUDE_DIRS}
++ )
+ endif()
+
+ add_executable(all_tests ${SRCS} $<TARGET_OBJECTS:chromaprint_objs>)
diff --git a/audio/chromaprint/pkg-plist b/audio/chromaprint/pkg-plist
index 42e50b1d7cbc..473cb2c2821d 100644
--- a/audio/chromaprint/pkg-plist
+++ b/audio/chromaprint/pkg-plist
@@ -2,5 +2,5 @@ bin/fpcalc
include/chromaprint.h
lib/libchromaprint.so
lib/libchromaprint.so.1
-lib/libchromaprint.so.1.3.0
+lib/libchromaprint.so.1.4.2
libdata/pkgconfig/libchromaprint.pc