aboutsummaryrefslogtreecommitdiff
path: root/audio/clementine-player
diff options
context:
space:
mode:
authorSean Bruno <sbruno@FreeBSD.org>2019-01-03 21:43:57 +0000
committerSean Bruno <sbruno@FreeBSD.org>2019-01-03 21:43:57 +0000
commitbb8cd08fc9bba16e4a7975a0d27846e4acf45a3c (patch)
treef07d121c530011c9d2a70563ad009671f4ac933c /audio/clementine-player
parent9aa798af483b432e19a9d336fc8a51633b873537 (diff)
downloadports-bb8cd08fc9bba16e4a7975a0d27846e4acf45a3c.tar.gz
ports-bb8cd08fc9bba16e4a7975a0d27846e4acf45a3c.zip
audio/clementine-player: Jump to qt5
- regenerate some of the patch files for this new branch - cleanup and try to adjust Makefile audio/libechonest: Jump to qt5 - clementine-player is the only port that I could find that has an explicit dependency on libechonest. Commit this update so there is no window for build failures. Test built on 13-CURRENT, 12-STABLE, 11-STABLE across i386 and amd64. Run-time tested on 13-CURRENT, amd64. PR: 234534 226529 Submitted by: greg@unrelenting.technology
Notes
Notes: svn path=/head/; revision=489228
Diffstat (limited to 'audio/clementine-player')
-rw-r--r--audio/clementine-player/Makefile45
-rw-r--r--audio/clementine-player/distinfo6
-rw-r--r--audio/clementine-player/files/patch-3rdparty_libprojectm_MilkdropPresetFactory_Parser.cpp (renamed from audio/clementine-player/files/patch-3rdParty_libprojectm_MilkdropPresetFactory_Parser.cpp)14
-rw-r--r--audio/clementine-player/files/patch-3rdparty_libprojectm_Renderer_VideoEcho.cpp (renamed from audio/clementine-player/files/patch-3rdParty_libprojectm_Renderer_VideoEcho.cpp)6
-rw-r--r--audio/clementine-player/files/patch-CMakeLists.txt4
-rw-r--r--audio/clementine-player/files/patch-dist_clementine.desktop4
-rw-r--r--audio/clementine-player/files/patch-src_CMakeLists.txt12
-rw-r--r--audio/clementine-player/pkg-plist10
8 files changed, 50 insertions, 51 deletions
diff --git a/audio/clementine-player/Makefile b/audio/clementine-player/Makefile
index 3472eb1908a0..7e5c6f7d5aa6 100644
--- a/audio/clementine-player/Makefile
+++ b/audio/clementine-player/Makefile
@@ -2,64 +2,61 @@
# $FreeBSD$
PORTNAME= clementine
-DISTVERSIONPREFIX= v
-DISTVERSION= 1.3.1-441
-DISTVERSIONSUFFIX= -gc01b7bc
-PORTREVISION= 7
+DISTVERSION= 1.3.1.g20190103
CATEGORIES= audio
PKGNAMESUFFIX= -player
+MASTER_SITES= GH
+
MAINTAINER= sbruno@FreeBSD.org
COMMENT= Cross-platform music player based on Amarok 1.4
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-DEPRECATED= Qt4 has been EOL since december 2015
-EXPIRATION_DATE= 2019-03-15
-
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
LIB_DEPENDS= libtag.so:audio/taglib \
libchromaprint.so:audio/chromaprint \
libprotobuf.so:devel/protobuf \
- libqca.so:devel/qca@qt4 \
- libqjson.so:devel/qjson@qt4 \
+ libqca-qt5.so:devel/qca@qt5 \
+ libqjson-qt5.so:devel/qjson@qt5 \
libfftw3.so:math/fftw3 \
- libechonest.so:audio/libechonest \
+ libechonest5.so:audio/libechonest \
libcryptopp.so:security/cryptopp
BROKEN_powerpc64= fails to compile: tagreader.cpp: undefined reference to TagLib::String::String
USE_GITHUB= yes
-GH_ACCOUNT= ${PORTNAME}${PKGNAMESUFFIX}
-GH_PROJECT= Clementine
+GH_TUPLE= clementine-player:Clementine:4ff370c
USES= cmake \
compiler:c++11-lib \
desktop-file-utils \
gettext-tools \
pkgconfig \
- qt:4 sqlite
+ qt:5 \
+ sqlite \
+ gl
+
USE_CXXSTD= c++11
USE_GL= gl glew glu
USE_XORG= x11
-CONFLICTS_BUILD= qt-3.*
-USE_QT= corelib \
+USE_QT= buildtools \
+ concurrent \
+ core \
dbus \
gui \
imageformats \
- qmake_build \
linguist_build \
- moc_build \
network \
opengl \
- qtestlib \
- rcc_build \
+ qmake_build \
+ testlib \
sql \
- uic_build \
- webkit \
+ widgets \
+ x11extras \
xml
USE_GSTREAMER1= cdparanoia \
@@ -70,6 +67,7 @@ USE_GSTREAMER1= cdparanoia \
lame \
mpg123 \
neon \
+ opus \
shout2 \
soup \
taglib \
@@ -86,6 +84,7 @@ CMAKE_ARGS+= -DCMAKE_LIBRARY_PATH:PATH="${LOCALBASE}/lib:${PREFIX}/lib" \
-DENABLE_DBUS=ON \
-DENABLE_SPOTIFY_BLOB=OFF
+OPTIONS_SUB= yes
OPTIONS_DEFINE= AMAZON \
AUDIOCD \
BOX \
@@ -103,7 +102,6 @@ OPTIONS_DEFINE= AMAZON \
VISUALISATION \
WIIMOTEDEV
-OPTIONS_SUB= yes
AMAZON_DESC= Amazon Drive support
AUDIOCD_DESC= Devices: Audio CD support
@@ -158,6 +156,7 @@ DROPBOX_BUILD_DEPENDS= sparsehash>=2.0.2:devel/sparsehash
DROPBOX_CMAKE_ON= -DENABLE_DROPBOX=ON
DROPBOX_CMAKE_OFF= -DENABLE_DROPBOX=OFF
+GIO_USES= gnome
GIO_USE= GNOME=glib20
GIO_CMAKE_ON= -DENABLE_GIO=ON
GIO_CMAKE_OFF= -DENABLE_GIO=OFF
@@ -173,7 +172,7 @@ GPOD_LIB_DEPENDS= libgpod.so:audio/libgpod \
GPOD_CMAKE_ON= -DENABLE_LIBGPOD=ON
GPOD_CMAKE_OFF= -DENABLE_LIBGPOD=OFF
-LASTFM_LIB_DEPENDS= liblastfm.so:audio/liblastfm
+LASTFM_LIB_DEPENDS= liblastfm5.so:audio/liblastfm-qt5
LASTFM_CMAKE_ON= -DENABLE_LIBLASTFM=ON
LASTFM_CMAKE_OFF= -DENABLE_LIBLASTFM=OFF
diff --git a/audio/clementine-player/distinfo b/audio/clementine-player/distinfo
index ed0082c62a89..d5672a300a5a 100644
--- a/audio/clementine-player/distinfo
+++ b/audio/clementine-player/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1527263085
-SHA256 (clementine-player-Clementine-v1.3.1-441-gc01b7bc_GH0.tar.gz) = 78082a523dc21b6ddf17fd7bd3ab7734634bce93dacdc1a50efb4dda4e346be6
-SIZE (clementine-player-Clementine-v1.3.1-441-gc01b7bc_GH0.tar.gz) = 8468459
+TIMESTAMP = 1546525193
+SHA256 (clementine-player-Clementine-1.3.1.g20190103-4ff370c_GH0.tar.gz) = 3eeabfce6db7bb02db8387bf287352b819d0e8fb3534574bc4f1cb04f8a4e4e4
+SIZE (clementine-player-Clementine-1.3.1.g20190103-4ff370c_GH0.tar.gz) = 8522595
diff --git a/audio/clementine-player/files/patch-3rdParty_libprojectm_MilkdropPresetFactory_Parser.cpp b/audio/clementine-player/files/patch-3rdparty_libprojectm_MilkdropPresetFactory_Parser.cpp
index 275354eb42f0..77e133b440db 100644
--- a/audio/clementine-player/files/patch-3rdParty_libprojectm_MilkdropPresetFactory_Parser.cpp
+++ b/audio/clementine-player/files/patch-3rdparty_libprojectm_MilkdropPresetFactory_Parser.cpp
@@ -1,6 +1,6 @@
---- 3rdparty/libprojectm/MilkdropPresetFactory/Parser.cpp.orig 2018-01-31 22:06:57.261592000 +0000
-+++ 3rdparty/libprojectm/MilkdropPresetFactory/Parser.cpp 2018-01-31 22:07:38.081299000 +0000
-@@ -1373,7 +1373,7 @@
+--- 3rdparty/libprojectm/MilkdropPresetFactory/Parser.cpp.orig 2018-12-05 17:16:34 UTC
++++ 3rdparty/libprojectm/MilkdropPresetFactory/Parser.cpp
+@@ -1373,7 +1373,7 @@ PerFrameEqn * Parser::parse_implicit_per_frame_eqn(std
PerFrameEqn * per_frame_eqn;
GenExpr * gen_expr;
@@ -9,7 +9,7 @@
return NULL;
if (param_string == NULL)
return NULL;
-@@ -1528,7 +1528,7 @@
+@@ -1528,7 +1528,7 @@ InitCond * Parser::parse_per_frame_init_eqn(std::istre
if (preset == NULL)
return NULL;
@@ -18,7 +18,7 @@
return NULL;
if ((token = parseToken(fs, name)) != tEq)
-@@ -1842,7 +1842,7 @@
+@@ -1842,7 +1842,7 @@ int Parser::parse_shapecode(char * token, std::istream
/* Null argument checks */
if (preset == NULL)
return PROJECTM_FAILURE;
@@ -27,7 +27,7 @@
return PROJECTM_FAILURE;
if (token == NULL)
return PROJECTM_FAILURE;
-@@ -2133,7 +2133,7 @@
+@@ -2133,7 +2133,7 @@ int Parser::parse_wave(char * token, std::istream & f
if (token == NULL)
return PROJECTM_FAILURE;
@@ -36,7 +36,7 @@
return PROJECTM_FAILURE;
if (preset == NULL)
return PROJECTM_FAILURE;
-@@ -2315,7 +2315,7 @@
+@@ -2315,7 +2315,7 @@ int Parser::parse_shape(char * token, std::istream &
if (token == NULL)
return PROJECTM_FAILURE;
diff --git a/audio/clementine-player/files/patch-3rdParty_libprojectm_Renderer_VideoEcho.cpp b/audio/clementine-player/files/patch-3rdparty_libprojectm_Renderer_VideoEcho.cpp
index b3736399b9e8..fad407e595b2 100644
--- a/audio/clementine-player/files/patch-3rdParty_libprojectm_Renderer_VideoEcho.cpp
+++ b/audio/clementine-player/files/patch-3rdparty_libprojectm_Renderer_VideoEcho.cpp
@@ -1,6 +1,6 @@
---- 3rdparty/libprojectm/Renderer/VideoEcho.cpp.orig 2018-01-31 22:10:05.891427000 +0000
-+++ 3rdparty/libprojectm/Renderer/VideoEcho.cpp 2018-01-31 22:14:31.332885000 +0000
-@@ -77,10 +77,10 @@
+--- 3rdparty/libprojectm/Renderer/VideoEcho.cpp.orig 2018-12-05 17:16:34 UTC
++++ 3rdparty/libprojectm/Renderer/VideoEcho.cpp
+@@ -77,10 +77,10 @@ void VideoEcho::Draw(RenderContext &context)
default: flipx=1;flipy=1; break;
}
diff --git a/audio/clementine-player/files/patch-CMakeLists.txt b/audio/clementine-player/files/patch-CMakeLists.txt
index b9fb4e784e62..82533264b805 100644
--- a/audio/clementine-player/files/patch-CMakeLists.txt
+++ b/audio/clementine-player/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2018-08-17 05:31:45 UTC
+--- CMakeLists.txt.orig 2018-12-05 17:16:34 UTC
+++ CMakeLists.txt
-@@ -59,7 +59,7 @@ find_library(PROTOBUF_STATIC_LIBRARY libprotobuf.a lib
+@@ -58,7 +58,7 @@ find_library(PROTOBUF_STATIC_LIBRARY libprotobuf.a lib
pkg_check_modules(CDIO libcdio)
pkg_check_modules(CHROMAPRINT REQUIRED libchromaprint)
diff --git a/audio/clementine-player/files/patch-dist_clementine.desktop b/audio/clementine-player/files/patch-dist_clementine.desktop
index b1cb3319eb8e..702487a7c0c0 100644
--- a/audio/clementine-player/files/patch-dist_clementine.desktop
+++ b/audio/clementine-player/files/patch-dist_clementine.desktop
@@ -1,6 +1,6 @@
---- dist/clementine.desktop.orig 2016-04-19 15:08:35 UTC
+--- dist/clementine.desktop.orig 2018-12-05 17:16:34 UTC
+++ dist/clementine.desktop
-@@ -26,8 +26,8 @@ Comment[sr]=Репродукује муÐ
+@@ -31,8 +31,8 @@ Comment[sr]=Репродукује музику и las
Comment[sr@ijekavian]=Репродукује музику и last.fm токове
Comment[sr@ijekavianlatin]=Reprodukuje muziku i last.fm tokove
Comment[sr@latin]=Reprodukuje muziku i last.fm tokove
diff --git a/audio/clementine-player/files/patch-src_CMakeLists.txt b/audio/clementine-player/files/patch-src_CMakeLists.txt
index 593d4c1efd93..388ec62a5327 100644
--- a/audio/clementine-player/files/patch-src_CMakeLists.txt
+++ b/audio/clementine-player/files/patch-src_CMakeLists.txt
@@ -1,18 +1,18 @@
---- src/CMakeLists.txt.orig 2018-05-23 13:23:53 UTC
+--- src/CMakeLists.txt.orig 2018-12-05 17:16:34 UTC
+++ src/CMakeLists.txt
-@@ -1295,6 +1295,7 @@ if(HAVE_BREAKPAD)
- endif(HAVE_BREAKPAD)
+@@ -1319,6 +1319,7 @@ if(HAVE_SPOTIFY)
+ endif(HAVE_SPOTIFY)
if(HAVE_SPOTIFY_DOWNLOADER)
+ add_definitions(${CRYPTOPP_CFLAGS_OTHER})
target_link_libraries(clementine_lib
${CRYPTOPP_LIBRARIES}
)
-@@ -1380,6 +1381,7 @@ add_executable(clementine
+@@ -1407,6 +1408,7 @@ add_executable(clementine
- if (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
+ if (FREEBSD)
target_link_libraries(clementine execinfo)
+ set_target_properties(clementine PROPERTIES OUTPUT_NAME clementine-player)
- endif (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
+ endif (FREEBSD)
target_link_libraries(clementine
diff --git a/audio/clementine-player/pkg-plist b/audio/clementine-player/pkg-plist
index f1bdabd7507e..59ef76b646bb 100644
--- a/audio/clementine-player/pkg-plist
+++ b/audio/clementine-player/pkg-plist
@@ -1,14 +1,14 @@
bin/clementine-player
bin/clementine-tagreader
-share/appdata/clementine.appdata.xml
share/applications/clementine.desktop
share/icons/hicolor/128x128/apps/clementine.png
share/icons/hicolor/64x64/apps/clementine.png
share/icons/hicolor/scalable/apps/clementine.svg
-share/kde4/services/clementine-feed.protocol
-share/kde4/services/clementine-itms.protocol
-share/kde4/services/clementine-itpc.protocol
-share/kde4/services/clementine-zune.protocol
+share/kservices5/clementine-feed.protocol
+share/kservices5/clementine-itms.protocol
+share/kservices5/clementine-itpc.protocol
+share/kservices5/clementine-zune.protocol
+share/metainfo/clementine.appdata.xml
%%VISUALISATION%%%%DATADIR%%/projectm-presets/Aderrasi - Agitator.milk
%%VISUALISATION%%%%DATADIR%%/projectm-presets/Aderrasi - Aimless (Gravity Directive Mix).milk
%%VISUALISATION%%%%DATADIR%%/projectm-presets/Aderrasi - Aimless (Spirogravity Mix).milk