aboutsummaryrefslogtreecommitdiff
path: root/audio/clementine-player
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2018-08-24 17:22:01 +0000
committerJason E. Hale <jhale@FreeBSD.org>2018-08-24 17:22:01 +0000
commitedf512ca2e5e5a59e84993103663d499dc54600d (patch)
tree755180fd4810fbf33aa78186166afc94eafc7a8e /audio/clementine-player
parentd0dff0b145c82c7f6acffe2125012004f4d4d6cb (diff)
downloadports-edf512ca2e5e5a59e84993103663d499dc54600d.tar.gz
ports-edf512ca2e5e5a59e84993103663d499dc54600d.zip
Update security/cryptopp to 7.0.0
We now install a pkgconfig file which will allow ports to check whether cryptopp was built with assembly instructions enabled or not. There are a few functions that will be undefined if built without assembly and -DCRYPTOPP_DISABLE_ASM needs to be passed to the compiler in that case to avoid build failures. This is not new, but the pkgconf file should make it easier to determine if the flag is needed or not. Fix several ports due to API changes and to use the new pkgconf file to determine cryptopp location and build flags. Special cases below. deskutils/cdcat - Use cryptopp shared library instead of static, detect with pkgconf devel/xeus - Fix dependencies and remove header-only libraries from RUN_DEPENDS - Rework to use the cryptopp pkgconf file - net/cppzmq CMake files were fixed in r477649, remove hacks for that as they were seemingly causing devel/xeus-cling to link to cryptopp unnecessarily - Remove C++17 code from cryptopp checks for compatibility devel/xeus-cling - Fix dependencies - Remove hacks for previously broken cppzmq CMake files and no longer needed cryptopp dependency Changes: https://www.cryptopp.com/#news PR: 230579 (original patch, not used) Submitted by: yuri
Notes
Notes: svn path=/head/; revision=477967
Diffstat (limited to 'audio/clementine-player')
-rw-r--r--audio/clementine-player/Makefile13
-rw-r--r--audio/clementine-player/files/patch-CMakeLists.txt11
-rw-r--r--audio/clementine-player/files/patch-src_CMakeLists.txt12
3 files changed, 23 insertions, 13 deletions
diff --git a/audio/clementine-player/Makefile b/audio/clementine-player/Makefile
index 7670ec33bde4..800c7759aeff 100644
--- a/audio/clementine-player/Makefile
+++ b/audio/clementine-player/Makefile
@@ -5,7 +5,7 @@ PORTNAME= clementine
DISTVERSIONPREFIX= v
DISTVERSION= 1.3.1-441
DISTVERSIONSUFFIX= -gc01b7bc
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
PKGNAMESUFFIX= -player
@@ -80,16 +80,7 @@ CFLAGS+= -Wno-inconsistent-missing-override \
CMAKE_ARGS+= -DCMAKE_LIBRARY_PATH:PATH="${LOCALBASE}/lib:${PREFIX}/lib" \
-DENABLE_DBUS=ON \
- -DENABLE_SPOTIFY_BLOB=OFF \
- -DCRYPTOPP_LIBS=${LOCALBASE}/lib/libcryptopp.so \
- -DCRYPTOPP_INCLUDEDIR=${LOCALBASE}/include/cryptopp \
- -DCRYPTOPP_LIBDIR=${LOCALBASE}/lib \
- -DCRYPTOPP_LDFLAGS=-lcryptopp \
- -DCRYPTOPP_LIBRARIES=cryptopp \
- -DCRYPTOPP_LIBRARY_DIRS=${LOCALBASE}/lib \
- -DCRYPTOPP_cryptopp_INCLUDEDIR=${LOCALBASE}/include/cryptopp \
- -DCRYPTOPP_cryptopp_LIBDIR=${LOCALBASE}/lib \
- -DCRYPTOPP_FOUND=1
+ -DENABLE_SPOTIFY_BLOB=OFF
OPTIONS_DEFINE= AMAZON \
AUDIOCD \
diff --git a/audio/clementine-player/files/patch-CMakeLists.txt b/audio/clementine-player/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..b9fb4e784e62
--- /dev/null
+++ b/audio/clementine-player/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2018-08-17 05:31:45 UTC
++++ CMakeLists.txt
+@@ -59,7 +59,7 @@ find_library(PROTOBUF_STATIC_LIBRARY libprotobuf.a lib
+
+ pkg_check_modules(CDIO libcdio)
+ pkg_check_modules(CHROMAPRINT REQUIRED libchromaprint)
+-pkg_search_module(CRYPTOPP cryptopp libcrypto++)
++pkg_check_modules(CRYPTOPP libcryptopp)
+ pkg_check_modules(GIO gio-2.0)
+ pkg_check_modules(GLIB REQUIRED glib-2.0)
+ pkg_check_modules(GOBJECT REQUIRED gobject-2.0)
diff --git a/audio/clementine-player/files/patch-src_CMakeLists.txt b/audio/clementine-player/files/patch-src_CMakeLists.txt
index 29b3484d2131..593d4c1efd93 100644
--- a/audio/clementine-player/files/patch-src_CMakeLists.txt
+++ b/audio/clementine-player/files/patch-src_CMakeLists.txt
@@ -1,6 +1,14 @@
---- src/CMakeLists.txt.orig 2016-04-19 15:08:35 UTC
+--- src/CMakeLists.txt.orig 2018-05-23 13:23:53 UTC
+++ src/CMakeLists.txt
-@@ -1388,6 +1388,7 @@ add_executable(clementine
+@@ -1295,6 +1295,7 @@ if(HAVE_BREAKPAD)
+ endif(HAVE_BREAKPAD)
+
+ if(HAVE_SPOTIFY_DOWNLOADER)
++ add_definitions(${CRYPTOPP_CFLAGS_OTHER})
+ target_link_libraries(clementine_lib
+ ${CRYPTOPP_LIBRARIES}
+ )
+@@ -1380,6 +1381,7 @@ add_executable(clementine
if (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
target_link_libraries(clementine execinfo)