aboutsummaryrefslogtreecommitdiff
path: root/audio/cmp3
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-01-16 15:13:25 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-01-16 15:13:25 +0000
commit07ebd91bcbf5dde6ccc6548f1e1319726340f3a5 (patch)
tree0e8c6f488e7012e7c90987e1ade261e0c68265b7 /audio/cmp3
parente06a4c1b083ec3ad87157ca9960ceaad8de8a744 (diff)
downloadports-07ebd91bcbf5dde6ccc6548f1e1319726340f3a5.tar.gz
ports-07ebd91bcbf5dde6ccc6548f1e1319726340f3a5.zip
Fix for respecting HOME properly
PR: 24352 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=37247
Diffstat (limited to 'audio/cmp3')
-rw-r--r--audio/cmp3/Makefile1
-rw-r--r--audio/cmp3/files/patch-aa14
-rw-r--r--audio/cmp3/files/patch-ae22
3 files changed, 32 insertions, 5 deletions
diff --git a/audio/cmp3/Makefile b/audio/cmp3/Makefile
index f7de93b95e1b..04cc79b471f8 100644
--- a/audio/cmp3/Makefile
+++ b/audio/cmp3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cmp3
PORTVERSION= 2.0.p5
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.personal.psu.edu/users/n/k/nkk104/cmp3/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/pre/}
diff --git a/audio/cmp3/files/patch-aa b/audio/cmp3/files/patch-aa
index 82156cfd384a..f3a63603e257 100644
--- a/audio/cmp3/files/patch-aa
+++ b/audio/cmp3/files/patch-aa
@@ -1,6 +1,6 @@
--- Makefile.orig Fri Mar 17 10:35:33 2000
-+++ Makefile Sat Dec 23 10:34:05 2000
-@@ -3,19 +3,19 @@
++++ Makefile Fri Jan 12 03:02:20 2001
+@@ -3,22 +3,22 @@
#
# initial_directory is now set in the config file
mpg123_location := "mpg123"
@@ -11,7 +11,7 @@
# Location of config file - Please edit this file before installing
#
-config_file := "$(HOME)/.cmp3rc"
-+config_file := "$$\(HOME)/.cmp3rc"
++#config_file := "$(HOME)/.cmp3rc"
#
# Uncomment and set if desired
@@ -19,10 +19,14 @@
## An ass repository is a nice thing to have. See README
-ass_repository := "$(HOME)/.cmp3ass"
-+ass_repository := "$$\(HOME)/.cmp3ass"
++#ass_repository := "$(HOME)/.cmp3ass"
## Define this for bufferring or add other parameters to mpg123
- mpg123_params := -b 320
+-mpg123_params := -b 320
++#mpg123_params := -b 320
+
+ # You need debugging info? Uncomment this and check /tmp/cmp3log
+ #debugging := 1
@@ -38,8 +38,8 @@
# stands. Change the code to do something else you want it to do...
#PARAMS +=-DMY_CD
diff --git a/audio/cmp3/files/patch-ae b/audio/cmp3/files/patch-ae
new file mode 100644
index 000000000000..a97c5c17af3f
--- /dev/null
+++ b/audio/cmp3/files/patch-ae
@@ -0,0 +1,22 @@
+--- cmp3main.c.orig Fri Mar 17 08:40:00 2000
++++ cmp3main.c Fri Jan 12 02:16:41 2001
+@@ -33,13 +33,18 @@
+ int lastleftline = 0;
+ int lastrightline = 0;
+ char *init_dir = NULL;
++ char *home_dir = NULL;
++ char cmp3_config[4096];
+
+ if (argc > 1)
+ docmdline(argc, argv);
+ shm_init();
+
+ cmp3rc = ini_create();
+- if (ini_load(cmp3rc, CMP3_CONFIG) == INI_FAIL)
++ home_dir = getenv("HOME");
++ strcpy (cmp3_config, home_dir);
++ strcat (cmp3_config, "/.cmp3rc");
++ if (ini_load(cmp3rc, cmp3_config) == INI_FAIL)
+ {
+ ini_destroy(cmp3rc);
+ cmp3rc = NULL;