aboutsummaryrefslogtreecommitdiff
path: root/audio/cmp3
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>2000-03-08 00:18:36 +0000
committerChris Piazza <cpiazza@FreeBSD.org>2000-03-08 00:18:36 +0000
commita4d68e48d777205406dc7b8683ca8b055652dab0 (patch)
treef5db043be364b46b95592d7384fe3690ceba0ac5 /audio/cmp3
parent9b513ad584a9d25466af83ebd2e1c2c46d0c40b9 (diff)
downloadports-a4d68e48d777205406dc7b8683ca8b055652dab0.tar.gz
ports-a4d68e48d777205406dc7b8683ca8b055652dab0.zip
Update to 2.0pre4
Notes
Notes: svn path=/head/; revision=26628
Diffstat (limited to 'audio/cmp3')
-rw-r--r--audio/cmp3/Makefile18
-rw-r--r--audio/cmp3/distinfo2
-rw-r--r--audio/cmp3/files/patch-aa49
-rw-r--r--audio/cmp3/files/patch-ab15
-rw-r--r--audio/cmp3/files/patch-ad15
-rw-r--r--audio/cmp3/pkg-plist2
6 files changed, 42 insertions, 59 deletions
diff --git a/audio/cmp3/Makefile b/audio/cmp3/Makefile
index cb867e664748..e5f61bdffea0 100644
--- a/audio/cmp3/Makefile
+++ b/audio/cmp3/Makefile
@@ -1,13 +1,13 @@
# New ports collection makefile for: cmp3
-# Version required: 2.0pre3
+# Version required: 2.0pre4
# Date created: 10 April 1999
# Whom: Chris Piazza <cpiazza@FreeBSD.org>
#
# $FreeBSD$
#
-DISTNAME= cmp3-2.0pre3
-PKGNAME= cmp3-2.0p3
+DISTNAME= cmp3-2.0pre4
+PKGNAME= cmp3-2.0p4
CATEGORIES= audio
MASTER_SITES= http://www.personal.psu.edu/users/n/k/nkk104/cmp3/
@@ -20,16 +20,4 @@ USE_GMAKE= yes
WRKSRC= ${WRKDIR}/cmp3
PKGMESSAGE= ${WRKSRC}/MESSAGE
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/cmp3 ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/rnmp3 ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/cmp3
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/cmp3
-.endif
-
-post-install:
- @${SED} 's,PREFIX,${PREFIX},' ${PKGDIR}/MESSAGE > ${WRKSRC}/MESSAGE
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/audio/cmp3/distinfo b/audio/cmp3/distinfo
index eeeb537cf8ed..4b705e792df9 100644
--- a/audio/cmp3/distinfo
+++ b/audio/cmp3/distinfo
@@ -1 +1 @@
-MD5 (cmp3-2.0pre3.tar.gz) = 028354f2d513dff7019db28bee25d570
+MD5 (cmp3-2.0pre4.tar.gz) = 8d13ba6fa3e0b7b903b4d5fa122a94ab
diff --git a/audio/cmp3/files/patch-aa b/audio/cmp3/files/patch-aa
index 9cfefa4bf8aa..e6d6faeeb4e6 100644
--- a/audio/cmp3/files/patch-aa
+++ b/audio/cmp3/files/patch-aa
@@ -1,44 +1,35 @@
---- Makefile.orig Sat Apr 10 12:40:57 1999
-+++ Makefile Sat Apr 10 23:26:31 1999
-@@ -1,7 +1,7 @@
+--- Makefile.orig Tue Mar 7 14:21:48 2000
++++ Makefile Tue Mar 7 14:23:36 2000
+@@ -3,7 +3,7 @@
#
- # Set these variables
+ initial_directory := "/mp3"
+ mpg123_location := "mpg123"
+-install_directory := "$(HOME)/bin"
++install_directory := "$(PREFIX)/bin"
+
#
--INIT_DIR="/mp3"
-+INIT_DIR="$(PREFIX)/share/mp3"
- MPG123_LOC="mpg123"
- #INSTALL_DIR=/usr/local/bin
- INSTALL_DIR=$(HOME)/bin
-@@ -11,7 +11,7 @@
+ # Location of config file (YOU create this file by yourself, see README)
+@@ -15,7 +15,7 @@
#
## An ass repository is a nice thing to have. See README
--ASSREPOSITORY="$(HOME)/.cmp3ass"
-+#ASSREPOSITORY="$(HOME)/.cmp3ass"
+-ass_repository := "$(HOME)/.cmp3ass"
++#ass_repository := "$(HOME)/.cmp3ass"
## Define this for bufferring or add other parameters to mpg123
- #EXEC_PARAMS=-DEXEC_PARAMS="\"-b\",\"320\""
-@@ -30,8 +30,9 @@
+ mpg123_params := -b 320
+@@ -34,8 +34,8 @@
# stands. Change the code to do something else you want it to do...
#PARAMS +=-DMY_CD
LIBS= -lncurses
--CFLAGS= -Wall -O2 -g
+-CFLAGS= -Wall -g -O2
-CC= gcc
-+CFLAGS?= -O2
+CFLAGS+= -Wall
+CC?= gcc
- OBJS= llist.o cmp3fileio.o cmp3manager.o cmp3curses.o cmp3llist.o \
- cmp3main.o cmp3listfiles.o cmp3playlist.o
-
-@@ -43,7 +44,6 @@
- endif
-
- all: rnmp3 cmp3
-- @echo -e "\n\nCmp3 is ready! Please read the README before proceeding.\n"
+ OBJS= llist.o cmp3common.o cmp3fileio.o cmp3manager.o cmp3curses.o \
+ cmp3llist.o cmp3main.o cmp3listfiles.o cmp3playlist.o cmp3volume.o \
+ cmp3general.o
+@@ -91,4 +91,4 @@
- clean:
- rm -f *.o *~ DEADJOE core cmp3 rnmp3
-@@ -75,4 +75,4 @@
- fi;
- endif
+ include .depend
diff --git a/audio/cmp3/files/patch-ab b/audio/cmp3/files/patch-ab
index 3c277718cd2b..42d75ffcd2cf 100644
--- a/audio/cmp3/files/patch-ab
+++ b/audio/cmp3/files/patch-ab
@@ -1,20 +1,11 @@
---- cmp3.h.orig Sat Apr 10 21:49:16 1999
-+++ cmp3.h Sat Apr 10 21:54:51 1999
+--- cmp3.h.orig Tue Mar 7 14:25:06 2000
++++ cmp3.h Tue Mar 7 14:25:12 2000
@@ -1,7 +1,7 @@
#ifndef _CMP3_H
#define _CMP3_H
-#include<curses.h>
-+#include<ncurses.h>
++#include <ncurses.h>
#ifndef NCURSES_VERSION
#error "This program requires ncurses to function"
-@@ -15,7 +15,7 @@
- #include<sys/wait.h>
- #include<sys/ioctl.h>
- #include<sys/stat.h>
--#include<sys/soundcard.h>
-+#include<machine/soundcard.h>
- #include<fcntl.h>
- #include<stdio.h>
- #include<stdlib.h>
diff --git a/audio/cmp3/files/patch-ad b/audio/cmp3/files/patch-ad
new file mode 100644
index 000000000000..7f5a6b83d844
--- /dev/null
+++ b/audio/cmp3/files/patch-ad
@@ -0,0 +1,15 @@
+--- cmp3volume.c.orig Tue Mar 7 14:26:13 2000
++++ cmp3volume.c Tue Mar 7 14:26:22 2000
+@@ -3,7 +3,7 @@
+ */
+
+ #include "cmp3funcs.h"
+-#include<sys/soundcard.h>
++#include <machine/soundcard.h>
+
+ static int mixernum, /* ID number for the mixer */
+ vol; /* Current volume level */
+@@ -89,4 +89,4 @@
+ return;
+ }
+
diff --git a/audio/cmp3/pkg-plist b/audio/cmp3/pkg-plist
index 625397f8db54..d259215ab3e1 100644
--- a/audio/cmp3/pkg-plist
+++ b/audio/cmp3/pkg-plist
@@ -1,4 +1,2 @@
bin/cmp3
bin/rnmp3
-share/doc/cmp3/README
-@dirrm share/doc/cmp3