aboutsummaryrefslogtreecommitdiff
path: root/audio/cmus
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2005-10-14 16:09:23 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2005-10-14 16:09:23 +0000
commit1e8811471afdfbff28dcae2196a1bdd7042d1f7b (patch)
treec7aa148e4c205c771a367ab3898e0d3f472c923b /audio/cmus
parent8e147a6c50e85546ce1fdc90d3717bd9e90a2c68 (diff)
downloadports-1e8811471afdfbff28dcae2196a1bdd7042d1f7b.tar.gz
ports-1e8811471afdfbff28dcae2196a1bdd7042d1f7b.zip
Notes
Diffstat (limited to 'audio/cmus')
-rw-r--r--audio/cmus/Makefile75
-rw-r--r--audio/cmus/distinfo2
-rw-r--r--audio/cmus/pkg-descr19
-rw-r--r--audio/cmus/pkg-plist11
4 files changed, 107 insertions, 0 deletions
diff --git a/audio/cmus/Makefile b/audio/cmus/Makefile
new file mode 100644
index 000000000000..18ccbd92a5f9
--- /dev/null
+++ b/audio/cmus/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: cmus
+# Date created: 14 October 2005
+# Whom: Adam Weinberger
+#
+# $FreeBSD$
+#
+
+PORTNAME= cmus
+PORTVERSION= 1.6.0
+CATEGORIES= audio
+MASTER_SITES= http://onion.dynserv.net/~timo/files/
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Console-based music player with really cool features
+
+BUILD_DEPENDS+= bash:${PORTSDIR}/shells/bash
+LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac \
+ mad:${PORTSDIR}/audio/libmad
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_ICONV= yes
+HAS_CONFIGURE= yes
+USE_REINPLACE= yes
+CONFIGURE_ARGS+=--prefix=${PREFIX}
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/lib/libvorbisfile.so) || defined(BATCH)
+WITH_VORBIS= yes
+.endif
+.if exists(${LOCALBASE}/lib/libmodplug.so) || defined(BATCH)
+WITH_MODPLUG= yes
+.endif
+.if exists(${LOCALBASE}/lib/libartsc.so)
+WITH_ARTS= yes
+.endif
+
+.if defined(WITH_VORBIS)
+LIB_DEPENDS+= vorbisfile:${PORTSDIR}/audio/libvorbis
+PLIST_SUB+= VORBIS=""
+.else
+PLIST_SUB+= VORBIS="@comment "
+PREMSG+= Define WITH_VORBIS=yes to enable OGG/Vorbis support.\n
+.endif
+
+.if defined(WITH_MODPLUG)
+LIB_DEPENDS+= modplug:${PORTSDIR}/audio/libmodplug
+PLIST_SUB+= MODPLUG=""
+.else
+PLIST_SUB+= MODPLUG="@comment "
+PREMSG+= Define WITH_MODPLUG=yes to enable module music files.\n
+.endif
+
+.if defined(WITH_ARTS)
+LIB_DEPENDS+= artsc:${PORTSDIR}/audio/arts
+PLIST_SUB+= ARTS=""
+.else
+PLIST_SUB+= ARTS="@comment "
+PREMSG+= Define WITH_ARTS=yes to enable arts output support.\n
+.endif
+
+pre-everything::
+ @${ECHO_CMD}
+ @${PRINTF} "${PREMSG}"
+ @${ECHO_CMD}
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e \
+ "s|/bin/bash|${LOCALBASE}/bin/bash|; \
+ s|-lncursesw|-lncurses|g"
+
+.include <bsd.port.post.mk>
diff --git a/audio/cmus/distinfo b/audio/cmus/distinfo
new file mode 100644
index 000000000000..5db322eedb29
--- /dev/null
+++ b/audio/cmus/distinfo
@@ -0,0 +1,2 @@
+MD5 (cmus-1.6.0.tar.bz2) = b8e5accbaacedfbdb6858e5f6b28f560
+SIZE (cmus-1.6.0.tar.bz2) = 136782
diff --git a/audio/cmus/pkg-descr b/audio/cmus/pkg-descr
new file mode 100644
index 000000000000..00527c5edfdc
--- /dev/null
+++ b/audio/cmus/pkg-descr
@@ -0,0 +1,19 @@
+CMus is a small and fast music player using the ncurses library.
+CMus has vi-style command interface, e.g. searching using '/' or
+'?' and adding files to playlist ':add ~/foo.ogg'.
+
+ * Plays FLAC, OGG, MP3, WAV, modules
+ * MP3 and Ogg streaming (Shoutcast/Icecast)
+ * WinAmp / XMMS keys "zxcvb"
+ * Can be controlled via UNIX socket
+ * Customizable colors
+ * Nice vi-style interface with tabulator expansion
+ * Background playlist loading
+ * Track metadata database makes adding files to playlist very fast.
+ * Album/artist modes. Playing within one album or artist.
+ * Powerful playlist filters
+ * Can run external commands for the currently selected files
+ * Directory browser
+ * Supports 256 colors
+
+WWW: http://onion.dynserv.net/~timo/index.php?page=Projects/cmus
diff --git a/audio/cmus/pkg-plist b/audio/cmus/pkg-plist
new file mode 100644
index 000000000000..127fdc275dbb
--- /dev/null
+++ b/audio/cmus/pkg-plist
@@ -0,0 +1,11 @@
+bin/cmus
+bin/cmus-remote
+lib/cmus/ip/flac.so
+lib/cmus/ip/mad.so
+%%MODPLUG%%lib/cmus/ip/modplug.so
+%%VORBIS%%lib/cmus/ip/vorbis.so
+lib/cmus/ip/wav.so
+%%ARTS%%lib/cmus/op/arts.so
+lib/cmus/op/oss.so
+%%DATADIR%%/doc/cmus.html
+%%DATADIR%%/example/cmus-status-display