aboutsummaryrefslogtreecommitdiff
path: root/audio/cpige
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2012-08-12 09:36:30 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2012-08-12 09:36:30 +0000
commit2cb75bd68f0433e003af2ab4dbc5f0cd23d8e114 (patch)
tree376aa922b6129215b642ec393e5ac83d92bfb3a3 /audio/cpige
parente6a5ae7d9aed8a7ca8a38cabb9082634892aa508 (diff)
downloadports-2cb75bd68f0433e003af2ab4dbc5f0cd23d8e114.tar.gz
ports-2cb75bd68f0433e003af2ab4dbc5f0cd23d8e114.zip
- fix looking up the host name addresses on 64 bits platforms
(use in_addr_t instead of long and check it against INADDR_NONE) - adjust MASTERSITES and WWW Please note that the project is dead upstream. PR: 165481 Submitted by: Howard Goldstein
Notes
Notes: svn path=/head/; revision=302431
Diffstat (limited to 'audio/cpige')
-rw-r--r--audio/cpige/Makefile5
-rw-r--r--audio/cpige/files/patch-mynet.c20
-rw-r--r--audio/cpige/pkg-descr2
3 files changed, 24 insertions, 3 deletions
diff --git a/audio/cpige/Makefile b/audio/cpige/Makefile
index c9685215e360..b200ac78f53a 100644
--- a/audio/cpige/Makefile
+++ b/audio/cpige/Makefile
@@ -7,9 +7,10 @@
PORTNAME= cpige
DISTVERSION= 1.5
+PORTREVISION= 1
CATEGORIES= audio
-MASTER_SITES= http://ed.zehome.com/cpige/ \
- http://T32.TecNik93.com/FreeBSD/ports/sources/cpige/
+MASTER_SITES= http://old.ed.zehome.com/cpige/ \
+ http://T32.TecNik93.com/FreeBSD/ports/cpige/sources/
MAINTAINER= itetcu@FreeBSD.org
COMMENT= Icecast/Shoutcast stream ripper
diff --git a/audio/cpige/files/patch-mynet.c b/audio/cpige/files/patch-mynet.c
new file mode 100644
index 000000000000..d7a8b6f8a952
--- /dev/null
+++ b/audio/cpige/files/patch-mynet.c
@@ -0,0 +1,20 @@
+--- ./mynet.c.orig 2006-08-20 17:51:17.000000000 +0300
++++ ./mynet.c 2012-08-12 12:29:05.000000000 +0300
+@@ -86,7 +86,7 @@
+ {
+ struct sockaddr_in serverSockAddr;
+ struct hostent *serverHostEnt;
+- long hostAddr;
++ in_addr_t hostAddr;
+
+ #if WIN32
+ int res;
+@@ -105,7 +105,7 @@
+ hostAddr = inet_addr(servername);
+
+ /* If it is an ip address */
+- if ((long) hostAddr != (long)-1)
++ if ( hostAddr != INADDR_NONE )
+ memcpy(&serverSockAddr.sin_addr, &hostAddr, sizeof(hostAddr));
+ else {
+ serverHostEnt = gethostbyname(servername);
diff --git a/audio/cpige/pkg-descr b/audio/cpige/pkg-descr
index 70a95f8c0e80..03da9ba37a75 100644
--- a/audio/cpige/pkg-descr
+++ b/audio/cpige/pkg-descr
@@ -2,4 +2,4 @@ cPige records an audio stream, separating into individual
"Artist - Track.mp3" files. It can also record on an
hour-by-hour basis.
-WWW: http://ed.zehome.com/?page=cpige-en
+WWW: http://old.ed.zehome.com/?page=cpige