aboutsummaryrefslogtreecommitdiff
path: root/audio/csound6/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-07 15:53:49 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-07 15:53:49 +0000
commit6a0ad9ba4f1c610a8ee11ccfa4a6317e2851b73d (patch)
tree0804110c91c58260d655fda16627b42c79e0a9c5 /audio/csound6/Makefile
parent5f3038b5286b07b635fadfa05617690349c8eb26 (diff)
downloadports-6a0ad9ba4f1c610a8ee11ccfa4a6317e2851b73d.tar.gz
ports-6a0ad9ba4f1c610a8ee11ccfa4a6317e2851b73d.zip
Notes
Diffstat (limited to 'audio/csound6/Makefile')
-rw-r--r--audio/csound6/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/audio/csound6/Makefile b/audio/csound6/Makefile
index a3775942faf5..ddd4836bfdc7 100644
--- a/audio/csound6/Makefile
+++ b/audio/csound6/Makefile
@@ -12,7 +12,8 @@ DIST_SUBDIR= csound
MAINTAINER= ports@FreeBSD.org
COMMENT= Sound synthesizer
-LICENSE= LGPL21
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= boost-libs>0:${PORTSDIR}/devel/boost-libs \
swig>2:${PORTSDIR}/devel/swig20 \
@@ -21,7 +22,7 @@ BUILD_DEPENDS= boost-libs>0:${PORTSDIR}/devel/boost-libs \
LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
libsndfile.so:${PORTSDIR}/audio/libsndfile
-USES= bison cmake python:2
+USES= bison cmake localbase python:2
CMAKE_ARGS= -DBUILD_CSOUNDVST:BOOL=OFF \
-DBUILD_JAVA_INTERFACE:BOOL=OFF \
-DBUILD_P5GLOVE_OPCODES:BOOL=OFF \
@@ -33,9 +34,6 @@ CMAKE_ARGS= -DBUILD_CSOUNDVST:BOOL=OFF \
USE_LDCONFIG= yes
SSP_UNSAFE= yes
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
SUB_FILES= pkg-message
CONFLICTS= csound-5.*