aboutsummaryrefslogtreecommitdiff
path: root/audio/csound
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-02-18 01:59:10 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-02-18 01:59:10 +0000
commit33a271d1ad94356c302e3258dd1afe37c5f2ed4c (patch)
tree10e6a69d4991a902184e8970dd855de571948f2d /audio/csound
parentc66719d37bd15a014199d5285af22d7f6cb651f5 (diff)
downloadports-33a271d1ad94356c302e3258dd1afe37c5f2ed4c.tar.gz
ports-33a271d1ad94356c302e3258dd1afe37c5f2ed4c.zip
audio/csound: Update 6.14.0 -> 6.15.0
Notes
Notes: svn path=/head/; revision=565857
Diffstat (limited to 'audio/csound')
-rw-r--r--audio/csound/Makefile53
-rw-r--r--audio/csound/distinfo8
-rw-r--r--audio/csound/files/patch-InOut_CMakeLists.txt13
-rw-r--r--audio/csound/pkg-plist19
4 files changed, 57 insertions, 36 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index ef1244d64c85..d710197f44ef 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -2,13 +2,9 @@
# $FreeBSD$
PORTNAME= csound
-DISTVERSION= 6.14.0
-PORTREVISION= 3
+DISTVERSION= 6.15.0
CATEGORIES= audio lang
-PATCH_SITES= https://github.com/csound/csound/commit/
-PATCHFILES= c444e8f752c3acc31d364b901204e09eae2e791e.patch:-p1
-
MAINTAINER= yuri@FreeBSD.org
COMMENT= Sound synthesizer
@@ -21,7 +17,7 @@ BUILD_DEPENDS= boost-libs>0:devel/boost-libs \
LIB_DEPENDS= libsamplerate.so:audio/libsamplerate \
libsndfile.so:audio/libsndfile
-USES= alias bison cmake compiler:c++11-lib eigen:3 localbase ncurses python
+USES= alias bison cmake compiler:c++11-lib eigen:3 localbase ncurses python:build # is python needed: https://github.com/csound/csound/issues/1437 ?
USE_GITHUB= yes
USE_LDCONFIG= yes
@@ -39,18 +35,23 @@ LDFLAGS+= -lexecinfo
SUB_FILES= pkg-message
OPTIONS_DEFINE= CURL FLTK HDF5 NLS OPENMP PORTAUDIO PULSEAUDIO
-OPTIONS_GROUP= PLUGINS
-OPTIONS_GROUP_PLUGINS= BUCHLA CHUA DSSI EXCITER FAUST FLUIDSYNTH IMAGE JACK LUA LINALG OSC P5GLOVE PADSYNTH PLATEREV PVSGENDY SCANSYN SELECT SERIAL STACK STK WIIMOTE # Opcodes/CMakeLists.txt, Opcodes/stk/CMakeLists.txt
+OPTIONS_GROUP= OPCODES # list is in Opcodes/CMakeLists.txt
+OPTIONS_GROUP_OPCODES= BUCHLA CHUA COUNTER DSSI EXCITER FAUST FLUIDSYNTH IMAGE JACK LUA LINALG MP3OUT OSC P5GLOVE PADSYNTH PLATEREV PVSGENDY PYTHON SCANSYN SELECT SERIAL STACK STK VST4CS WIIMOTE # Opcodes/CMakeLists.txt, Opcodes/stk/CMakeLists.txt
OPTIONS_DEFAULT= FLTK OPENMP
-OPTIONS_DEFAULT+= BUCHLA CHUA DSSI EXCITER FAUST IMAGE JACK LINALG OSC P5GLOVE PADSYNTH PLATEREV SCANSYN SELECT SERIAL STACK STK # for PLUGINS
+OPTIONS_DEFAULT+= BUCHLA CHUA DSSI EXCITER FAUST IMAGE JACK LINALG OSC P5GLOVE PADSYNTH PLATEREV SCANSYN SELECT SERIAL STACK STK # for OPCODES
OPTIONS_SUB= yes
+OPCODES_DESC= Build/install opcodes
+
BUCHLA_DESC= Build the Buchla filter opcode
BUCHLA_CMAKE_BOOL= BUILD_BUCHLA_OPCODES
CHUA_DESC= Build the chua opcodes
CHUA_CMAKE_BOOL= BUILD_CHUA_OPCODES
+COUNTER_DESC= Build the serial opcode
+COUNTER_CMAKE_BOOL= BUILD_COUNTER_OPCODES
+
CURL_CMAKE_BOOL= USE_CURL # see https://github.com/csound/csound/issues/1067
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
@@ -75,10 +76,8 @@ FLTK_CMAKE_OFF= -DBUILD_CSOUND_AC:BOOL=OFF \
FAUST_DESC= Build the Faust opcodes
FAUST_USES= ssl
-FAUST_LLVM_VERSION= 60
-FAUST_BUILD_DEPENDS= faust>0:audio/faust
-FAUST_RUN_DEPENDS= faust>0:audio/faust \
- llvm${FAUST_LLVM_VERSION}>0:devel/llvm${FAUST_LLVM_VERSION}
+FAUST_LLVM_VERSION= 11 # should be the same as in audio/faust
+FAUST_LIB_DEPENDS= libfaust.so:audio/faust
FAUST_CMAKE_BOOL= BUILD_FAUST_OPCODES
FAUST_CMAKE_ON= -DFAUST_LLVM_VERSION:STRING=${FAUST_LLVM_VERSION}
@@ -87,7 +86,7 @@ FLUIDSYNTH_LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth
FLUIDSYNTH_CMAKE_BOOL= BUILD_FLUID_OPCODES
FLUIDSYNTH_BROKEN= FluidSynth 2.x is broken upstream: https://github.com/csound/csound/issues/1078#issuecomment-441459803
-HDF5_DESC= Build HDF5 read/write opcodes
+HDF5_DESC= Build HDF5 read/write plugin
HDF5_LIB_DEPENDS= libhdf5.so:science/hdf5 \
libsz.so:science/szip
HDF5_CMAKE_BOOL= BUILD_HDF5_OPCODES
@@ -100,18 +99,21 @@ LINALG_DESC= Build the linear algebra opcodes
LINALG_CMAKE_BOOL= BUILD_LINEAR_ALGEBRA_OPCODES
LINALG_CXXFLAGS= -DGMM_VERSION=x # workaround based on https://github.com/csound/csound/issues/1069#issuecomment-439648756
-LUA_DESC= Build Lua Interface and opcodes
+LUA_DESC= Build Lua Interface and module
LUA_LIB_DEPENDS= libluajit-5.1.so:lang/luajit
-LUA_CMAKE_OFF= -DBUILD_CSOUND_AC_LUA_INTERFACE:BOOL=OFF \
- -DBUILD_LUA_INTERFACE:BOOL=OFF \
- -DBUILD_LUA_OPCODES:BOOL=OFF
+LUA_CMAKE_BOOL= BUILD_CSOUND_AC_LUA_INTERFACE BUILD_LUA_INTERFACE BUILD_LUA_OPCODES
+
NLS_USES= gettext
NLS_CMAKE_OFF= -DGETTEXT_MSGFMT_EXECUTABLE:FILEPATH="" \
-DGETTEXT_MSGMERGE_EXECUTABLE:FILEPATH="" \
-DLIBINTL_LIBRARY:FILEPATH="" \
-DUSE_GETTEXT:BOOL=OFF
+
OPENMP_CMAKE_BOOL= USE_OPEN_MP
+MP3OUT_DESC= Build MP3OUT opcodes
+MP3OUT_CMAKE_BOOL= BUILD_MP3OUT_OPCODE
+
OSC_DESC= Build OSC opcodes
OSC_LIB_DEPENDS= liblo.so:audio/liblo
OSC_CMAKE_BOOL= BUILD_OSC_OPCODES
@@ -140,6 +142,10 @@ PLATEREV_CMAKE_BOOL= BUILD_PLATEREV_OPCODES
PVSGENDY_DESC= Build the pvsgendy opcode
PVSGENDY_CMAKE_BOOL= BUILD_PVSGENDY_OPCODE
+PYTHON_DESC= Build the Python opcodes
+PYTHON_USES= python
+PYTHON_CMAKE_BOOL= BUILD_PYTHON_OPCODES
+
SCANSYN_DESC= Build the select opcodes
SCANSYN_CMAKE_BOOL= BUILD_SCANSYN_OPCODES
@@ -156,6 +162,9 @@ STK_DESC= Build the stk opcodes
STK_CMAKE_BOOL= BUILD_STK_OPCODES
STK_LIB_DEPENDS= libstk.so:audio/stk
+VST4CS_DESC= Build the vst4cs opcodes
+VST4CS_CMAKE_BOOL= BUILD_VST4CS_OPCODES
+
WIIMOTE_DESC= Build the Wiimote opcodes
WIIMOTE_CMAKE_BOOL= BUILD_WIIMOTE_OPCODES
WIIMOTE_BROKEN= Need to port wiiuse: https://github.com/rpavlik/wiiuse
@@ -168,9 +177,6 @@ BROKEN_FreeBSD_11= libcsound64.so.6.0: undefined reference to `__atomic_store_8'
post-patch:
@${REINPLACE_CMD} -e \
- 's|/usr/local|${LOCALBASE}|' \
- ${WRKSRC}/InOut/CMakeLists.txt
- @${REINPLACE_CMD} -e \
's|/usr/include/Python2.7|${PYTHON_INCLUDEDIR}| ; \
s|/usr/local|${LOCALBASE}| ; \
/linuxjoystick/s|^|#| ; \
@@ -182,11 +188,6 @@ post-patch:
@${REINPLACE_CMD} -e \
's| mixer)| csmixer)|' \
${WRKSRC}/util/CMakeLists.txt
-.for i in Engine/auxfd.c H/prototyp.h OOps/diskin2.c OOps/dumpf.c \
- Opcodes/partials.c Top/csound.c
- @${REINPLACE_CMD} -e \
- 's|\([[:blank:]]fd\)\(close\)|\1__\2|' ${WRKSRC}/${i}
-.endfor
post-install:
@${LN} -sf libcsnd6.so.6.0 ${STAGEDIR}${PREFIX}/lib/libcsnd6.so.6
diff --git a/audio/csound/distinfo b/audio/csound/distinfo
index 4f01d2bafad6..6a2efba28ce2 100644
--- a/audio/csound/distinfo
+++ b/audio/csound/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1598638243
-SHA256 (csound-csound-6.14.0_GH0.tar.gz) = bef349c5304b2d3431ef417933b4c9e9469c0a408a4fa4a98acf0070af360a22
-SIZE (csound-csound-6.14.0_GH0.tar.gz) = 26812543
-SHA256 (c444e8f752c3acc31d364b901204e09eae2e791e.patch) = 7314a10797e51cb291c488581f833b23eafe4af556b37c6b20573c2f0f5af0d0
-SIZE (c444e8f752c3acc31d364b901204e09eae2e791e.patch) = 621
+TIMESTAMP = 1613608252
+SHA256 (csound-csound-6.15.0_GH0.tar.gz) = d47ed0fb70c752cb06ee2655ee9f010d8d1e369fc73d09d2ac2bc1b3060bf724
+SIZE (csound-csound-6.15.0_GH0.tar.gz) = 31879171
diff --git a/audio/csound/files/patch-InOut_CMakeLists.txt b/audio/csound/files/patch-InOut_CMakeLists.txt
new file mode 100644
index 000000000000..ff41c4822e4e
--- /dev/null
+++ b/audio/csound/files/patch-InOut_CMakeLists.txt
@@ -0,0 +1,13 @@
+- https://github.com/csound/csound/issues/1438
+
+--- InOut/CMakeLists.txt.orig 2021-02-18 01:47:49 UTC
++++ InOut/CMakeLists.txt
+@@ -15,7 +15,7 @@ option(USE_AUDIOUNIT "Build the CoreAudio AudioUnit I/
+ option(USE_FLTK "Use FLTK for graphs and widget opcodes" ON)
+ option(BUILD_VIRTUAL_KEYBOARD "Build Virtual MIDI keyboard" ON)
+
+-list(APPEND CMAKE_REQUIRED_INCLUDES "/usr/local/include")
++list(APPEND CMAKE_REQUIRED_INCLUDES "${CMAKE_INSTALL_PREFIX}/include")
+
+ # FIND LIBRARIES AND HEADERS
+
diff --git a/audio/csound/pkg-plist b/audio/csound/pkg-plist
index 7d6670611385..41289ad2dae2 100644
--- a/audio/csound/pkg-plist
+++ b/audio/csound/pkg-plist
@@ -69,6 +69,7 @@ lib/csound/plugins64-6.0/libbeosc.so
lib/csound/plugins64-6.0/libcellular.so
%%CHUA%%lib/csound/plugins64-6.0/libchua.so
lib/csound/plugins64-6.0/libcontrol.so
+%%COUNTER%%lib/csound/plugins64-6.0/libcounter.so
lib/csound/plugins64-6.0/libcs_date.so
lib/csound/plugins64-6.0/libdoppler.so
%%DSSI%%lib/csound/plugins64-6.0/libdssi4cs.so
@@ -94,7 +95,7 @@ lib/csound/plugins64-6.0/libmixer.so
%%PADSYNTH%%lib/csound/plugins64-6.0/libpadsynth.so
%%PLATEREV%%lib/csound/plugins64-6.0/libplaterev.so
lib/csound/plugins64-6.0/libpvsops.so
-lib/csound/plugins64-6.0/libpy.so
+%%PYTHON%%lib/csound/plugins64-6.0/libpy.so
lib/csound/plugins64-6.0/libquadbezier.so
%%JACK%%lib/csound/plugins64-6.0/librtjack.so
%%PORTAUDIO%%lib/csound/plugins64-6.0/librtpa.so
@@ -106,6 +107,7 @@ lib/csound/plugins64-6.0/libscugens.so
lib/csound/plugins64-6.0/libsignalflowgraph.so
%%STACK%%lib/csound/plugins64-6.0/libstackops.so
lib/csound/plugins64-6.0/libstdutil.so
+lib/csound/plugins64-6.0/libsterrain.so
%%STK%%lib/csound/plugins64-6.0/libstkops.so
lib/csound/plugins64-6.0/libsystem_call.so
lib/csound/plugins64-6.0/liburandom.so
@@ -118,10 +120,9 @@ lib/libcsnd6.so.6.0
lib/libcsound64.so
lib/libcsound64.so.6
lib/libcsound64.so.6.0
-%%LUA%%lib/luaCsnd6.so
-%%PYTHON_SITELIBDIR%%/_csnd6.so
-%%PYTHON_SITELIBDIR%%/csnd6.py
-%%PYTHON_SITELIBDIR%%/ctcsound.py
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/_csnd6.so
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/csnd6.py
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/ctcsound.py
share/cmake/Csound/FindCsound.cmake
%%NLS%%share/locale/de/LC_MESSAGES/csound6.mo
%%NLS%%share/locale/en_US/LC_MESSAGES/csound6.mo
@@ -130,3 +131,11 @@ share/cmake/Csound/FindCsound.cmake
%%NLS%%share/locale/fr/LC_MESSAGES/csound6.mo
%%NLS%%share/locale/it/LC_MESSAGES/csound6.mo
%%NLS%%share/locale/ru/LC_MESSAGES/csound6.mo
+share/samples/README
+share/samples/hrtf-44100-left.dat
+share/samples/hrtf-44100-right.dat
+share/samples/hrtf-48000-left.dat
+share/samples/hrtf-48000-right.dat
+share/samples/hrtf-96000-left.dat
+share/samples/hrtf-96000-right.dat
+share/samples/sf_GMbank.sf2