aboutsummaryrefslogtreecommitdiff
path: root/audio/csound
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-11-17 22:00:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-11-17 22:00:06 +0000
commit69b5e3a416917be3b495a04952f1e3f72764722b (patch)
treeda90ade9826cb9e808876852604120765e4ba6d5 /audio/csound
parent7a6434f97ee43f5d56dfde4b0e75cdd25a645096 (diff)
downloadports-69b5e3a416917be3b495a04952f1e3f72764722b.tar.gz
ports-69b5e3a416917be3b495a04952f1e3f72764722b.zip
audio/csound: Fix the LINALG option using the workaround suggested by the upstream
Notes
Notes: svn path=/head/; revision=485204
Diffstat (limited to 'audio/csound')
-rw-r--r--audio/csound/Makefile4
-rw-r--r--audio/csound/pkg-plist1
2 files changed, 3 insertions, 2 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index 9d7f3b9fd853..b7e702681a34 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -36,7 +36,7 @@ OPTIONS_DEFINE= CURL FLTK HDF5 NLS OPENMP PORTAUDIO PULSEAUDIO
OPTIONS_GROUP= PLUGINS
OPTIONS_GROUP_PLUGINS= BUCHLA CHUA DSSI EXCITER FAUST FLUIDSYNTH IMAGE JACK LUA LINALG OSC P5GLOVE PADSYNTH PLATEREV PVSGENDY SCANSYN SELECT SERIAL STACK STK WIIMOTE # Opcodes/CMakeLists.txt, Opcodes/stk/CMakeLists.txt
OPTIONS_DEFAULT= FLTK OPENMP
-OPTIONS_DEFAULT+= BUCHLA CHUA DSSI EXCITER FAUST FLUIDSYNTH IMAGE JACK OSC P5GLOVE PADSYNTH PLATEREV SCANSYN SELECT SERIAL STACK STK # for PLUGINS
+OPTIONS_DEFAULT+= BUCHLA CHUA DSSI EXCITER FAUST FLUIDSYNTH IMAGE JACK LINALG OSC P5GLOVE PADSYNTH PLATEREV SCANSYN SELECT SERIAL STACK STK # for PLUGINS
OPTIONS_SUB= yes
BUCHLA_DESC= Build the Buchla filter opcode
@@ -90,7 +90,7 @@ JACK_CMAKE_BOOL= BUILD_JACK_OPCODES USE_JACK
LINALG_DESC= Build the linear algebra opcodes
LINALG_CMAKE_BOOL= BUILD_LINEAR_ALGEBRA_OPCODES
-LINALG_BROKEN= see https://github.com/csound/csound/issues/1069
+LINALG_CXXFLAGS= -DGMM_VERSION=x # workaround based on https://github.com/csound/csound/issues/1069#issuecomment-439648756
LUA_DESC= Build Lua Interface and opcodes
LUA_LIB_DEPENDS= libluajit-5.1.so:lang/luajit
diff --git a/audio/csound/pkg-plist b/audio/csound/pkg-plist
index ce437a000083..e4bf91d00e15 100644
--- a/audio/csound/pkg-plist
+++ b/audio/csound/pkg-plist
@@ -85,6 +85,7 @@ lib/csound/plugins64-6.0/libipmidi.so
%%JACK%%lib/csound/plugins64-6.0/libjackTransport.so
%%JACK%%lib/csound/plugins64-6.0/libjacko.so
%%HDF5%%lib/csound/plugins64-6.0/libhdf5ops.so
+%%LINALG%%lib/csound/plugins64-6.0/liblinear_algebra.so
lib/csound/plugins64-6.0/libliveconv.so
lib/csound/plugins64-6.0/libmixer.so
%%OSC%%lib/csound/plugins64-6.0/libosc.so