aboutsummaryrefslogtreecommitdiff
path: root/audio/csound
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-06 15:52:57 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-06 15:52:57 +0000
commita2163dda7eb6adb622616d3541dc01d1e4ebd931 (patch)
treeeefc4770c7b7c20967c038a1d5d97e445943a27c /audio/csound
parent747c0e2492bb3b5da558adf825b1e89032ba84be (diff)
downloadports-a2163dda7eb6adb622616d3541dc01d1e4ebd931.tar.gz
ports-a2163dda7eb6adb622616d3541dc01d1e4ebd931.zip
- Fix build on 11.x
- Switch to options helpers
Notes
Notes: svn path=/head/; revision=400939
Diffstat (limited to 'audio/csound')
-rw-r--r--audio/csound/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index 972d6092d995..117500bebf38 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -176,14 +176,19 @@ post-patch:
/jackEnvironment/s|'asound'|''|" ${WRKSRC}/SConstruct
@${REINPLACE_CMD} -e "s|linux/if.h|sys/types.h|" \
${WRKSRC}/OOps/remote.c
+ @${REINPLACE_CMD} -e "/Str/!s|fdclose|my_fdclose|" \
+ ${WRKSRC}/OOps/*.c \
+ ${WRKSRC}/Top/csound.c \
+ ${WRKSRC}/Engine/auxfd.c \
+ ${WRKSRC}/H/prototyp.h
post-install:
${LN} -sf libcsound64.so.5 ${STAGEDIR}${PREFIX}/lib/libcsound64.so
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKDIR}/html && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
-.endif
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/* ${STAGEDIR}${PREFIX}/lib/*.so* \
${STAGEDIR}${PREFIX}/lib/csound/plugins64/*.so
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKDIR}/html && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+
.include <bsd.port.mk>