aboutsummaryrefslogtreecommitdiff
path: root/audio/csound
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-01-12 07:54:29 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-01-12 07:54:29 +0000
commitd5640cca10d941e3ba548b9c8a4c2aa252ef2810 (patch)
tree91eeb0228fa9f72a312e14feac0723457c212457 /audio/csound
parent00e9e549a3b9b7a1a6f6b5323887363ed6b1135b (diff)
downloadports-d5640cca10d941e3ba548b9c8a4c2aa252ef2810.tar.gz
ports-d5640cca10d941e3ba548b9c8a4c2aa252ef2810.zip
audio/csound: Update 6.12.2-83 -> 6.13.0-244
Reviewed by: portscout
Notes
Notes: svn path=/head/; revision=522765
Diffstat (limited to 'audio/csound')
-rw-r--r--audio/csound/Makefile5
-rw-r--r--audio/csound/distinfo6
-rw-r--r--audio/csound/files/patch-CMakeLists.txt57
-rw-r--r--audio/csound/files/patch-OOps_pffft.c22
-rw-r--r--audio/csound/files/patch-Top_csound.c19
-rw-r--r--audio/csound/pkg-plist2
6 files changed, 21 insertions, 90 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index 80e01451db70..6840dbb20567 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= csound
-DISTVERSION= 6.12.2-83
-DISTVERSIONSUFFIX= -gdf2edd269
-PORTREVISION= 9
+DISTVERSION= 6.13.0-244
+DISTVERSIONSUFFIX= -gcc9851add
CATEGORIES= audio lang
MAINTAINER= yuri@FreeBSD.org
diff --git a/audio/csound/distinfo b/audio/csound/distinfo
index 3eb7e3409847..8803d078e057 100644
--- a/audio/csound/distinfo
+++ b/audio/csound/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1544642888
-SHA256 (csound-csound-6.12.2-83-gdf2edd269_GH0.tar.gz) = e14038c44fd954bea0fcb34af994757ca5f4fe75f99c80a1e8df867d5b9e7eee
-SIZE (csound-csound-6.12.2-83-gdf2edd269_GH0.tar.gz) = 26295519
+TIMESTAMP = 1578814881
+SHA256 (csound-csound-6.13.0-244-gcc9851add_GH0.tar.gz) = 5b5047b5046c189cb5b83e0f04f31ccf519a134656ee9d1747a18954f23d4dc7
+SIZE (csound-csound-6.13.0-244-gcc9851add_GH0.tar.gz) = 26816492
diff --git a/audio/csound/files/patch-CMakeLists.txt b/audio/csound/files/patch-CMakeLists.txt
index d5bade0b4f47..a2bcb434e5ba 100644
--- a/audio/csound/files/patch-CMakeLists.txt
+++ b/audio/csound/files/patch-CMakeLists.txt
@@ -1,27 +1,7 @@
---- CMakeLists.txt.orig 2018-12-12 19:23:43 UTC
+--- CMakeLists.txt.orig 2020-01-11 09:18:32 UTC
+++ CMakeLists.txt
-@@ -164,8 +164,8 @@ endif()
-
- # set -Werror if in Debug configuration
- if(NOT MSVC AND NOT WASM)
--set(CMAKE_CXX_FLAGS_RELEASE "-O3 ")
--set(CMAKE_C_FLAGS_RELEASE "-O3 ")
-+#set(CMAKE_CXX_FLAGS_RELEASE "-O3 ")
-+#set(CMAKE_C_FLAGS_RELEASE "-O3 ")
- if(${CMAKE_BUILD_TYPE} MATCHES "Debug")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Werror -Wno-missing-field-initializers")
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Werror -Wno-missing-field-initializers")
-@@ -206,7 +206,7 @@ execute_process (
- OUTPUT_VARIABLE PYTHON_USER_SITE_PACKAGES
- )
-
--SET(PYTHON_MODULE_INSTALL_DIR ${PYTHON_USER_SITE_PACKAGES} CACHE PATH "Python module install dir")
-+#SET(PYTHON_MODULE_INSTALL_DIR ${PYTHON_USER_SITE_PACKAGES} CACHE PATH "Python module install dir")
-
- set(JAVA_MODULE_INSTALL_DIR ${LIBRARY_INSTALL_DIR} CACHE PATH "Java module install dir")
- set(LUA_MODULE_INSTALL_DIR ${LIBRARY_INSTALL_DIR} CACHE PATH "Lua module install dir")
-@@ -378,7 +378,7 @@ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -stdlib=libc+
- set_target_properties(${CSOUNDLIB} PROPERTIES CXX_COMPILE_FLAGS "-std=c++11")
+@@ -291,7 +291,7 @@ if(APPLE)
+ set_target_properties(${CSOUNDLIB} PROPERTIES CXX_COMPILE_FLAGS "-std=c++11")
endif()
-if(CMAKE_SYSTEM_NAME MATCHES "Linux")
@@ -29,31 +9,21 @@
set(LINUX YES)
else()
set(LINUX NO)
-@@ -527,9 +527,11 @@ find_package(FLTK )
+@@ -438,9 +438,11 @@ find_package(FLTK)
# LIST_REPLACE(FLTK_LIBRARIES 2 "fltk_images_SHARED")
# endif()
#endif()
--find_package(FAUST)
++if (BUILD_FAUST_OPCODES)
+ find_package(FAUST)
-find_package(Java)
-find_package(JNI)
-+if (BUILD_FAUST_OPCODES)
-+ find_package(FAUST)
+endif()
+#find_package(Java)
+#find_package(JNI)
- find_package(LIBLO)
- find_package(LUAJIT)
find_package(MUSICXML)
-@@ -540,7 +542,7 @@ find_package(MUSICXML)
+ find_package(VSTSDK2X)
- find_package(PORTSMF)
- find_package(PythonLibs 2.7)
--if(NOT STK_LOCAL)
-+if(BUILD_STK_OPCODES AND NOT STK_LOCAL)
- find_package(STK)
- endif()
- find_package(SWIG)
-@@ -1251,11 +1253,11 @@ if(USE_CURL AND CURL_FOUND)
+@@ -1182,11 +1184,11 @@ if(USE_CURL AND CURL_FOUND)
endif()
# Linux does not have a separate libintl, it is part of libc
@@ -67,14 +37,3 @@
list(APPEND libcsound_LIBS ${LIBINTL_LIBRARY})
endif()
list(APPEND libcsound_CFLAGS -DGNU_GETTEXT)
-@@ -1275,8 +1277,8 @@ endif()
-
- if(LINUX)
- message(STATUS "Building on Linux.")
-- add_definitions(-DLINUX -DPIPES -DNO_FLTK_THREADS -D_GNU_SOURCE -DHAVE_SOCKETS)
-- list(APPEND libcsound_LIBS m dl)
-+ add_definitions(-DLINUX -DPIPES -DNO_FLTK_THREADS -DHAVE_SOCKETS)
-+ list(APPEND libcsound_LIBS m)
-
- find_library(LIBRT_LIBRARY rt)
-
diff --git a/audio/csound/files/patch-OOps_pffft.c b/audio/csound/files/patch-OOps_pffft.c
index 101639a99992..ae619dcb8d7c 100644
--- a/audio/csound/files/patch-OOps_pffft.c
+++ b/audio/csound/files/patch-OOps_pffft.c
@@ -1,4 +1,4 @@
---- OOps/pffft.c.orig 2019-03-05 17:24:02 UTC
+--- OOps/pffft.c.orig 2019-07-12 21:54:19 UTC
+++ OOps/pffft.c
@@ -63,6 +63,9 @@
#include <stdio.h>
@@ -10,23 +10,3 @@
/* detect compiler flavour */
#if defined(_MSC_VER)
-@@ -114,8 +117,8 @@ inline v4sf ld_ps1(const float *p) { v4sf v=vec_lde(0,
- # define LD_PS1(p) ld_ps1(&p)
- # define INTERLEAVE2(in1, in2, out1, out2) { v4sf tmp__ = vec_mergeh(in1, in2); out2 = vec_mergel(in1, in2); out1 = tmp__; }
- # define UNINTERLEAVE2(in1, in2, out1, out2) { \
-- vector unsigned char vperm1 = (vector unsigned char)(0,1,2,3,8,9,10,11,16,17,18,19,24,25,26,27); \
-- vector unsigned char vperm2 = (vector unsigned char)(4,5,6,7,12,13,14,15,20,21,22,23,28,29,30,31); \
-+ vector unsigned char vperm1 = (vector unsigned char){0,1,2,3,8,9,10,11,16,17,18,19,24,25,26,27}; \
-+ vector unsigned char vperm2 = (vector unsigned char){4,5,6,7,12,13,14,15,20,21,22,23,28,29,30,31}; \
- v4sf tmp__ = vec_perm(in1, in2, vperm1); out2 = vec_perm(in1, in2, vperm2); out1 = tmp__; \
- }
- # define VTRANSPOSE4(x0,x1,x2,x3) { \
-@@ -128,7 +131,7 @@ inline v4sf ld_ps1(const float *p) { v4sf v=vec_lde(0,
- x2 = vec_mergeh(y1, y3); \
- x3 = vec_mergel(y1, y3); \
- }
--# define VSWAPHL(a,b) vec_perm(a,b, (vector unsigned char)(16,17,18,19,20,21,22,23,8,9,10,11,12,13,14,15))
-+# define VSWAPHL(a,b) vec_perm(a,b, (vector unsigned char){16,17,18,19,20,21,22,23,8,9,10,11,12,13,14,15})
- # define VALIGNED(ptr) ((((uintptr_t)(ptr)) & 0xF) == 0)
-
- /*
diff --git a/audio/csound/files/patch-Top_csound.c b/audio/csound/files/patch-Top_csound.c
index e5b3f6e4fd2a..6b64ca04d37b 100644
--- a/audio/csound/files/patch-Top_csound.c
+++ b/audio/csound/files/patch-Top_csound.c
@@ -1,6 +1,6 @@
---- Top/csound.c.orig 2018-11-07 14:05:23 UTC
+--- Top/csound.c.orig 2020-01-11 09:18:32 UTC
+++ Top/csound.c
-@@ -60,10 +60,14 @@
+@@ -61,10 +61,14 @@
//#include "cs_par_dispatch.h"
#include "find_opcode.h"
@@ -16,16 +16,7 @@
#include "csound_standard_types.h"
#include "csdebug.h"
-@@ -405,7 +409,7 @@ static const CSOUND cenviron_ = {
- rewriteheader,
- csoundLoadSoundFile,
- fdrecord,
-- fdclose,
-+ fd__close,
- csoundCreateFileHandle,
- csoundGetFileName,
- csoundFileClose,
-@@ -3755,7 +3759,7 @@ void csoundNotifyFileOpened(CSOUND* csou
+@@ -3773,7 +3777,7 @@ void csoundNotifyFileOpened(CSOUND* csound, const char
/* ------------------------------------ */
#if defined(HAVE_RDTSC)
@@ -34,7 +25,7 @@
#undef HAVE_RDTSC
#endif
#endif
-@@ -3768,6 +3772,13 @@ static double timeResolutionSeconds = -1
+@@ -3786,6 +3790,13 @@ static double timeResolutionSeconds = -1.0;
static int getTimeResolution(void)
{
#if defined(HAVE_RDTSC)
@@ -48,7 +39,7 @@
FILE *f;
char buf[256];
-@@ -3803,9 +3814,14 @@ static int getTimeResolution(void)
+@@ -3821,9 +3832,14 @@ static int getTimeResolution(void)
}
}
fclose(f);
diff --git a/audio/csound/pkg-plist b/audio/csound/pkg-plist
index e4bf91d00e15..7d6670611385 100644
--- a/audio/csound/pkg-plist
+++ b/audio/csound/pkg-plist
@@ -49,6 +49,7 @@ include/csound/csound_threaded.hpp
include/csound/csound_type_system.h
include/csound/cwindow.h
include/csound/filebuilding.h
+include/csound/find_opcode.h
include/csound/float-version.h
include/csound/interlocks.h
include/csound/modload.h
@@ -80,6 +81,7 @@ lib/csound/plugins64-6.0/libfractalnoise.so
lib/csound/plugins64-6.0/libframebuffer.so
lib/csound/plugins64-6.0/libftsamplebank.so
lib/csound/plugins64-6.0/libgetftargs.so
+lib/csound/plugins64-6.0/libgtf.so
%%IMAGE%%lib/csound/plugins64-6.0/libimage.so
lib/csound/plugins64-6.0/libipmidi.so
%%JACK%%lib/csound/plugins64-6.0/libjackTransport.so