aboutsummaryrefslogtreecommitdiff
path: root/audio/csoundqt/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-01-14 08:51:55 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-01-14 08:51:55 +0000
commit58df1fa043fcec69c63adf29c31c932095497dd3 (patch)
treed6f5725ad35b25da3f404432cebd04439241a51b /audio/csoundqt/Makefile
parentb887315bd89910c0d1423e176ad50e5c53ac39fb (diff)
downloadports-58df1fa043fcec69c63adf29c31c932095497dd3.tar.gz
ports-58df1fa043fcec69c63adf29c31c932095497dd3.zip
audio/csoundqt: Update 0.9.5 -> 0.9.7-rc1-4
Reported by: portscout
Notes
Notes: svn path=/head/; revision=522996
Diffstat (limited to 'audio/csoundqt/Makefile')
-rw-r--r--audio/csoundqt/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/audio/csoundqt/Makefile b/audio/csoundqt/Makefile
index 83578c625ddb..aaa53cb67bf4 100644
--- a/audio/csoundqt/Makefile
+++ b/audio/csoundqt/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= CsoundQt
-DISTVERSION= 0.9.5
-PORTREVISION= 3
+DISTVERSION= 0.9.7-rc1-4
+DISTVERSIONSUFFIX= -g81e704f2
CATEGORIES= audio
MAINTAINER= yuri@FreeBSD.org
@@ -15,24 +15,17 @@ LIB_DEPENDS= libcsound64.so:audio/csound
USES= compiler:c++11-lib desktop-file-utils gl gmake qmake qt:5 shared-mime-info
USE_GITHUB= yes
-USE_QT= concurrent core declarative gui network printsupport widgets xml buildtools_build
+USE_QT= concurrent core declarative gui network printsupport webchannel webkit widgets xml buildtools_build
USE_GL= gl
QMAKE_ARGS= CONFIG+="CSOUND_API_INCLUDE_DIR=${LOCALBASE}/include/csound CSOUND_LIBRARY_DIR=${LOCALBASE}/lib build64" \
INSTALL_DIR=${PREFIX} SHARE_DIR=${PREFIX}/share \
qcs.pro
-PLIST_FILES= bin/${PORTNAME}-d-cs6 \
- bin/csoundqt \
- share/applications/${PORTNAME}.desktop \
- share/icons/hicolor/128x128/mimetypes/csound.png \
- share/icons/hicolor/scalable/apps/qtcs.svg \
- share/mime/packages/x-csound-csd.xml \
- share/mime/packages/x-csound-orc.xml \
- share/mime/packages/x-csound-sco.xml
-
OPTIONS_DEFINE= EXAMPLES
+DATADIR= ${PREFIX}/share/${PORTNAME:tl}
+
PORTEXAMPLES= *
post-patch:
@@ -40,7 +33,6 @@ post-patch:
post-install:
@${MV} ${STAGEDIR}${DATADIR}/Examples ${STAGEDIR}${EXAMPLESDIR}
- @${RMDIR} ${STAGEDIR}${DATADIR}
@${STRIP_CMD} ${STAGEDIR}${LOCALBASE}/bin/${PORTNAME}-d-cs6
.include <bsd.port.mk>