aboutsummaryrefslogtreecommitdiff
path: root/audio/darkice/Makefile
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-08-12 21:01:56 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-08-12 21:01:56 +0000
commit6a9c7630b6c43bb40f8a334b6db678c01180d43e (patch)
tree26fef27ac9732b7b465d7f28ff0310a119075d81 /audio/darkice/Makefile
parent567e2719bf728c45e35d7c3f95903993a20ef136 (diff)
downloadports-6a9c7630b6c43bb40f8a334b6db678c01180d43e.tar.gz
ports-6a9c7630b6c43bb40f8a334b6db678c01180d43e.zip
Notes
Diffstat (limited to 'audio/darkice/Makefile')
-rw-r--r--audio/darkice/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/audio/darkice/Makefile b/audio/darkice/Makefile
index ce398e0b2407..050ac285734c 100644
--- a/audio/darkice/Makefile
+++ b/audio/darkice/Makefile
@@ -7,22 +7,32 @@
#
PORTNAME= darkice
-PORTVERSION= 0.8
-PORTREVISION= 1
+PORTVERSION= 0.10.1
CATEGORIES= audio net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= mp3lame:${PORTSDIR}/audio/lame-devel \
+LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
vorbis.2:${PORTSDIR}/audio/libvorbis
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-lame-prefix=${LOCALBASE} \
--with-vorbis-prefix=${LOCALBASE}
MAN1= darkice.1
MAN5= darkice.cfg.5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+CXXFLAGS:= ${CXXFLAGS:N-O*}
+.endif
+
+# alternatively:
+#
+#USE_GCC= 3.1
+
+.include <bsd.port.post.mk>