aboutsummaryrefslogtreecommitdiff
path: root/audio/darkice
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-07-22 15:18:53 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-07-22 15:18:53 +0000
commit4d2a3b15bfa4433613d3ec0838c6ba8cde9ed226 (patch)
treefbad17e59955b4ec29a367c5c43e27aea4d26ae0 /audio/darkice
parent8b1bc550c2d02581560cdca4b7cdfb4b36a142c5 (diff)
downloadports-4d2a3b15bfa4433613d3ec0838c6ba8cde9ed226.tar.gz
ports-4d2a3b15bfa4433613d3ec0838c6ba8cde9ed226.zip
- Update to 1.2
PR: 180692 Submitted by: oorts fury
Notes
Notes: svn path=/head/; revision=323460
Diffstat (limited to 'audio/darkice')
-rw-r--r--audio/darkice/Makefile49
-rw-r--r--audio/darkice/distinfo4
-rw-r--r--audio/darkice/files/patch-Makefile.in17
-rw-r--r--audio/darkice/files/patch-configure.in15
-rw-r--r--audio/darkice/files/patch-man-Makefile.in10
5 files changed, 47 insertions, 48 deletions
diff --git a/audio/darkice/Makefile b/audio/darkice/Makefile
index aa9b6fdfee32..93fd43b74408 100644
--- a/audio/darkice/Makefile
+++ b/audio/darkice/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= darkice
-PORTVERSION= 1.1
-PORTREVISION?= 2
+PORTVERSION= 1.2
+PORTREVISION?= 0
CATEGORIES= audio net
MASTER_SITES= GOOGLE_CODE
@@ -12,19 +12,18 @@ COMMENT= IceCast, IceCast2, and ShoutCast live audio streamer
LICENSE= GPLv3
-OPTIONS_DEFINE= JACK
+OPTIONS_DEFINE= JACK PULSEAUDIO
OPTIONS_MULTI= CODEC
-OPTIONS_MULTI_CODEC= VORBIS LAME TWOLAME FAAC AACPLUS
+OPTIONS_MULTI_CODEC= VORBIS OPUS LAME TWOLAME FAAC AACPLUS
OPTIONS_DEFAULT= VORBIS
+OPUS_DESC= Ogg Opus audio codec support
AACPLUS_DESC= AAC HEv2 and libsamplerate support
-USE_AUTOTOOLS= aclocal autoconf
-AUTOMAKE_ARGS= --add-missing
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= aclocal automake autoconf
+ACLOCAL_ARGS= # none
+AUTOMAKE_ARGS= --add-missing --copy --foreign
CONFIGURE_ENV= ac_cv_prog_acx_pthread_config=no
-CPPFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
CONFIGURE_ARGS= --without-alsa
SUB_FILES= pkg-message
@@ -35,6 +34,20 @@ MAN5= darkice.cfg.5
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MJACK}
+LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
+CONFIGURE_ARGS+= --with-jack-prefix=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --without-jack
+.endif
+
+.if ${PORT_OPTIONS:MPULSEAUDIO}
+LIB_DEPENDS+= pulse-simple:${PORTSDIR}/audio/pulseaudio
+CONFIGURE_ARGS+= --with-pulseaudio-prefix=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --without-pulseaudio
+.endif
+
.if ${PORT_OPTIONS:MVORBIS}
LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+= --with-vorbis-prefix=${LOCALBASE}
@@ -42,6 +55,13 @@ CONFIGURE_ARGS+= --with-vorbis-prefix=${LOCALBASE}
CONFIGURE_ARGS+= --without-vorbis
.endif
+.if ${PORT_OPTIONS:MOPUS}
+LIB_DEPENDS+= opus:${PORTSDIR}/audio/opus
+CONFIGURE_ARGS+= --with-opus-prefix=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --without-opus
+.endif
+
.if ${PORT_OPTIONS:MLAME}
LIB_DEPENDS+= mp3lame:${PORTSDIR}/audio/lame
CONFIGURE_ARGS+= --with-lame-prefix=${LOCALBASE}
@@ -63,13 +83,6 @@ CONFIGURE_ARGS+= --with-faac-prefix=${LOCALBASE}
CONFIGURE_ARGS+= --without-faac
.endif
-.if ${PORT_OPTIONS:MJACK}
-LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
-CONFIGURE_ARGS+= --with-jack-prefix=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --without-jack
-.endif
-
.if ${PORT_OPTIONS:MAACPLUS}
LIB_DEPENDS+= aacplus:${PORTSDIR}/audio/libaacplus \
samplerate:${PORTSDIR}/audio/libsamplerate
@@ -80,9 +93,7 @@ CONFIGURE_ARGS+= --without-aacplus --without-samplerate
.endif
post-patch:
- @${REINPLACE_CMD} -e '/test/s|==|=|g'\
- -e 's/sbr_main.h/libaacplus\/sbr_main.h/' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-O2 -pedantic||g' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|-O2 -pedantic||g' ${WRKSRC}/src/Makefile.am
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
diff --git a/audio/darkice/distinfo b/audio/darkice/distinfo
index ed974f3567eb..50945e139e5e 100644
--- a/audio/darkice/distinfo
+++ b/audio/darkice/distinfo
@@ -1,2 +1,2 @@
-SHA256 (darkice-1.1.tar.gz) = 170342cb4dbb0b44a62e37d0db1515fa7799c410fc4995bf8f32aaa6614f5f79
-SIZE (darkice-1.1.tar.gz) = 344568
+SHA256 (darkice-1.2.tar.gz) = b3fba9be2d9c72f36b0659cd9ce0652c8f973b5c6498407f093da9a364fdb254
+SIZE (darkice-1.2.tar.gz) = 357026
diff --git a/audio/darkice/files/patch-Makefile.in b/audio/darkice/files/patch-Makefile.in
deleted file mode 100644
index e3744abd9d8a..000000000000
--- a/audio/darkice/files/patch-Makefile.in
+++ /dev/null
@@ -1,17 +0,0 @@
---- Makefile.in.orig 2011-10-31 13:06:11.000000000 +0000
-+++ Makefile.in 2013-07-03 19:20:38.000000000 +0000
-@@ -266,4 +266,4 @@
- *$$dep*) \
-- echo ' cd $(srcdir) && $(AUTOMAKE) --gnu'; \
-- $(am__cd) $(srcdir) && $(AUTOMAKE) --gnu \
-+ echo ' cd $(srcdir) && $(AUTOMAKE) --add-missing --gnu'; \
-+ $(am__cd) $(srcdir) && $(AUTOMAKE) --add-missing --gnu \
- && exit 0; \
-@@ -272,5 +272,5 @@
- done; \
-- echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu Makefile'; \
-+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --add-missing --gnu Makefile'; \
- $(am__cd) $(top_srcdir) && \
-- $(AUTOMAKE) --gnu Makefile
-+ $(AUTOMAKE) --add-missing --gnu Makefile
- .PRECIOUS: Makefile
diff --git a/audio/darkice/files/patch-configure.in b/audio/darkice/files/patch-configure.in
new file mode 100644
index 000000000000..ea65ade6897e
--- /dev/null
+++ b/audio/darkice/files/patch-configure.in
@@ -0,0 +1,15 @@
+--- configure.in.orig
++++ configure.in
+@@ -260,10 +260,11 @@
+ dnl-----------------------------------------------------------------------------
+ if test "x${LAME_LDFLAGS}" = "x" \
+ -a "x${VORBIS_LDFLAGS}" = "x" \
++ -a "x${OPUS_LDFLAGS}" = "x" \
+ -a "x${FAAC_LDFLAGS}" = "x" \
+ -a "x${AACPLUS_LDFLAGS}" = "x" \
+ -a "x${TWOLAME_LDFLAGS}" = "x"; then
+- AC_MSG_ERROR([neither lame, Ogg Vorbis, faac, aac+ nor twolame configured])
++ AC_MSG_ERROR([neither lame, Ogg Vorbis, Ogg Opus, faac, aac+ nor twolame configured])
+ fi
+
+
diff --git a/audio/darkice/files/patch-man-Makefile.in b/audio/darkice/files/patch-man-Makefile.in
deleted file mode 100644
index dc41ca3ad85e..000000000000
--- a/audio/darkice/files/patch-man-Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- man/Makefile.in.orig 2011-10-31 13:06:11.000000000 +0000
-+++ man/Makefile.in 2013-07-03 19:17:05.000000000 +0000
-@@ -212,5 +212,5 @@
- done; \
-- echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu man/Makefile'; \
-+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --add-missing --gnu man/Makefile'; \
- $(am__cd) $(top_srcdir) && \
-- $(AUTOMAKE) --gnu man/Makefile
-+ $(AUTOMAKE) --add-missing --gnu man/Makefile
- .PRECIOUS: Makefile