aboutsummaryrefslogtreecommitdiff
path: root/audio/darkice
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-07-09 15:41:24 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-07-09 15:41:24 +0000
commitd691c9d0e17ffc1210b44a2dd5922409d28cea6b (patch)
tree8bc9521372deafd2d60ca5d9a02502b01ca265ed /audio/darkice
parent815386e7b9819c6f5c24b6f4d5c4daf65d10e2ad (diff)
downloadports-d691c9d0e17ffc1210b44a2dd5922409d28cea6b.tar.gz
ports-d691c9d0e17ffc1210b44a2dd5922409d28cea6b.zip
audio/darkice: Update to 1.4
Notes
Notes: svn path=/head/; revision=541756
Diffstat (limited to 'audio/darkice')
-rw-r--r--audio/darkice/Makefile11
-rw-r--r--audio/darkice/distinfo6
-rw-r--r--audio/darkice/files/patch-darkice.cfg35
-rw-r--r--audio/darkice/files/patch-src_FaacEncoder.cpp13
-rw-r--r--audio/darkice/files/pkg-message.in2
5 files changed, 44 insertions, 23 deletions
diff --git a/audio/darkice/Makefile b/audio/darkice/Makefile
index c1823a6523bf..b585f386d4a9 100644
--- a/audio/darkice/Makefile
+++ b/audio/darkice/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= darkice
-PORTVERSION= 1.3
-PORTREVISION= 2
+PORTVERSION= 1.4
CATEGORIES= audio net
-MASTER_SITES= SF
+MASTER_SITES= https://github.com/rafael2k/darkice/releases/download/v${PORTVERSION}/
MAINTAINER= ports@FreeBSD.org
COMMENT= IceCast, IceCast2, and ShoutCast live audio streamer
@@ -14,17 +13,17 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
USES= pkgconfig
+USE_RC_SUBR= ${PORTNAME}
GNU_CONFIGURE= yes
-CONFIGURE_ENV= ac_cv_prog_acx_pthread_config=no
CONFIGURE_ARGS= --without-alsa
+CONFIGURE_ENV= ac_cv_prog_acx_pthread_config=no
SUB_FILES= pkg-message
-USE_RC_SUBR= ${PORTNAME}
OPTIONS_DEFINE= JACK PULSEAUDIO
+OPTIONS_DEFAULT= VORBIS
OPTIONS_MULTI= CODEC
OPTIONS_MULTI_CODEC= AACPLUS FAAC LAME OPUS TWOLAME VORBIS
-OPTIONS_DEFAULT= VORBIS
AACPLUS_DESC= AAC HEv2 and libsamplerate support
AACPLUS_LIB_DEPENDS= libaacplus.so:audio/libaacplus \
diff --git a/audio/darkice/distinfo b/audio/darkice/distinfo
index 91a969c2673b..86952ce278f1 100644
--- a/audio/darkice/distinfo
+++ b/audio/darkice/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1475029544
-SHA256 (darkice-1.3.tar.gz) = 2c0d0faaa627c0273b2ce8b38775a73ef97e34ef866862a398f660ad8f6e9de6
-SIZE (darkice-1.3.tar.gz) = 371411
+TIMESTAMP = 1592166243
+SHA256 (darkice-1.4.tar.gz) = e6a8ec2b447cf5b4ffaf9b62700502b6bdacebf00b476f4e9bf9f9fe1e3dd817
+SIZE (darkice-1.4.tar.gz) = 364782
diff --git a/audio/darkice/files/patch-darkice.cfg b/audio/darkice/files/patch-darkice.cfg
new file mode 100644
index 000000000000..a68af907af22
--- /dev/null
+++ b/audio/darkice/files/patch-darkice.cfg
@@ -0,0 +1,35 @@
+--- darkice.cfg.orig 2015-05-18 17:38:07 UTC
++++ darkice.cfg
+@@ -26,7 +26,9 @@ bitrate = 96 # bitrate of the stream se
+ server = yp.yourserver.com
+ # host name of the server
+ port = 8000 # port of the IceCast2 server, usually 8000
+-password = hackme # source password to the IceCast2 server
++# source password to the IceCast2 server
++password = hackme
++# there must not be a comment following the password
+ mountPoint = sample96 # mount point of this stream on the IceCast2 server
+ name = DarkIce trial
+ # name of the stream
+@@ -48,7 +50,9 @@ quality = 0.8 # encoding quality
+ server = yp.yourserver.com
+ # host name of the server
+ port = 8000 # port of the IceCast server, usually 8000
+-password = hackme # source password to the IceCast server
++# source password to the IceCast2 server
++password = hackme
++# there must not be a comment following the password
+ mountPoint = sample96 # mount point of this stream on the IceCast server
+ name = DarkIce trial
+ # name of the stream
+@@ -68,7 +72,9 @@ quality = 0.5 # encoding quality
+ server = yp.yourserver.com
+ # host name of the server
+ port = 8001 # source port of the ShoutCast server, usually 8001
+-password = hackme # source password to the ShoutCast server
++# source password to the IceCast2 server
++password = hackme
++# there must not be a comment following the password
+ name = DarkIce trial
+ # name of the stream
+ url = http://www.yourserver.com
diff --git a/audio/darkice/files/patch-src_FaacEncoder.cpp b/audio/darkice/files/patch-src_FaacEncoder.cpp
deleted file mode 100644
index 45969a66c562..000000000000
--- a/audio/darkice/files/patch-src_FaacEncoder.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/FaacEncoder.cpp.orig 2015-05-18 17:38:07 UTC
-+++ src/FaacEncoder.cpp
-@@ -95,7 +95,9 @@ FaacEncoder :: open ( void )
- faacConfig->useTns = 1;
- faacConfig->shortctl = SHORTCTL_NORMAL;
- faacConfig->useLfe = 0;
-- faacConfig->allowMidside = 1;
-+ //Do not set allowMidside for API compatibility with faac,
-+ //see https://github.com/knik0/faac/issues/8 for details
-+ //faacConfig->allowMidside = 1;
- faacConfig->bitRate = getOutBitrate() * 1000 / getOutChannel();
- faacConfig->bandWidth = lowpass;
- faacConfig->quantqual = (unsigned long) (getOutQuality() * 1000.0);
diff --git a/audio/darkice/files/pkg-message.in b/audio/darkice/files/pkg-message.in
index d20b80637700..6b2e5b95ab17 100644
--- a/audio/darkice/files/pkg-message.in
+++ b/audio/darkice/files/pkg-message.in
@@ -17,7 +17,7 @@ Then, it will be started on the next boot. If this line is already
present, the client will be started now. Otherwise, edit
/etc/rc.conf and execute this command:
- %%ETCDIR%%/rc.d/darkice start
+ %%PREFIX%%/etc/rc.d/darkice start
EOM
}
]