aboutsummaryrefslogtreecommitdiff
path: root/audio/deadbeef-mpris2-plugin/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-11-16 05:07:07 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-11-16 05:07:07 +0000
commit0f1cc5bd19306414164416d77fff724985ac1d91 (patch)
tree946255328bf2d037f81fc3881b26eea65c3803e6 /audio/deadbeef-mpris2-plugin/Makefile
parenta4444429a65156ae1aac41facd956f09b9afb6f1 (diff)
downloadports-0f1cc5bd19306414164416d77fff724985ac1d91.tar.gz
ports-0f1cc5bd19306414164416d77fff724985ac1d91.zip
Notes
Diffstat (limited to 'audio/deadbeef-mpris2-plugin/Makefile')
-rw-r--r--audio/deadbeef-mpris2-plugin/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/audio/deadbeef-mpris2-plugin/Makefile b/audio/deadbeef-mpris2-plugin/Makefile
new file mode 100644
index 000000000000..01a44c04c438
--- /dev/null
+++ b/audio/deadbeef-mpris2-plugin/Makefile
@@ -0,0 +1,26 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= deadbeef-mpris2-plugin
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.8
+CATEGORIES= audio
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= MPRIS protocol version 2 plugin for DeaDBeeF music player
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= ${LOCALBASE}/include/deadbeef/deadbeef.h:${PORTSDIR}/audio/deadbeef
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_GITHUB= yes
+GH_ACCOUNT= Serranya
+
+USES= autoreconf libtool pkgconfig
+GNU_CONFIGURE= yes
+USE_GNOME= glib20
+
+PLIST_FILES= lib/deadbeef/mpris.so
+
+.include <bsd.port.mk>