aboutsummaryrefslogtreecommitdiff
path: root/audio/denemo/Makefile
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-05-03 20:02:29 +0000
committerThomas Zander <riggs@FreeBSD.org>2015-05-03 20:02:29 +0000
commitfea7b304fa425508b7df175ce09a3597fc9175dc (patch)
treeeb9a45babbcb696c7a62aba557f0776690948a49 /audio/denemo/Makefile
parent66612130bb8b500cbc075678a7445961c99c8fc2 (diff)
downloadports-fea7b304fa425508b7df175ce09a3597fc9175dc.tar.gz
ports-fea7b304fa425508b7df175ce09a3597fc9175dc.zip
- Update to upstream version 1.2.2
- Add non-default OPTION PDF - Disable LILYPOND OPTION for now due to conflicting dependencies - Retire pkg-plist in favor of PLIST_* PR: 199208 Submitted by: tkato432@yahoo.com Reviewed by: riggs
Notes
Notes: svn path=/head/; revision=385343
Diffstat (limited to 'audio/denemo/Makefile')
-rw-r--r--audio/denemo/Makefile64
1 files changed, 50 insertions, 14 deletions
diff --git a/audio/denemo/Makefile b/audio/denemo/Makefile
index 1c373974788c..e1f450a85736 100644
--- a/audio/denemo/Makefile
+++ b/audio/denemo/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= denemo
-PORTVERSION= 1.1.8
-PORTREVISION= 4
+PORTVERSION= 1.2.2
CATEGORIES= audio
MASTER_SITES= GNU
@@ -15,11 +14,11 @@ LICENSE= GPLv3
LIB_DEPENDS= libaubio.so:${PORTSDIR}/audio/aubio \
libfluidsynth.so:${PORTSDIR}/audio/fluidsynth \
libjack.so:${PORTSDIR}/audio/jack \
- libportaudio.so.2:${PORTSDIR}/audio/portaudio2 \
libsmf.so:${PORTSDIR}/audio/libsmf \
libsndfile.so:${PORTSDIR}/audio/libsndfile \
+ libportaudio.so.2:${PORTSDIR}/audio/portaudio2 \
librubberband.so:${PORTSDIR}/audio/rubberband \
- libguile.so:${PORTSDIR}/lang/guile \
+ libguile-2.0.so:${PORTSDIR}/lang/guile2 \
libfftw3.so:${PORTSDIR}/math/fftw3
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
@@ -27,38 +26,75 @@ USES= bison gettext gmake pkgconfig
USE_GNOME= librsvg2 libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-jack \
- --disable-evince \
+ --disable-alsa \
--disable-portmidi \
- --sysconfdir=${PREFIX}/etc
+ --disable-gtk-doc \
+ --disable-gtk-doc-html \
+ --disable-gtk-doc-pdf
CPPFLAGS+= -I${LOCALBASE}/include/portaudio2 \
-I${LOCALBASE}/include
LDFLAGS+= ${LOCALBASE}/lib/portaudio2/libportaudio.so \
-L${LOCALBASE}/lib
-OPTIONS_DEFINE= DOCS EXAMPLES GTK3 LILYPOND
+PORTDOCS= *
+PORTEXAMPLES= *
+PORTDATA= *
+PLIST_FILES= bin/cairo_svg2path \
+ bin/denemo \
+ bin/denemo_file_update \
+ bin/generate_source \
+ share/appdata/denemo.appdata.xml \
+ share/applications/denemo.desktop \
+ share/fonts/truetype/denemo/Denemo.ttf \
+ share/fonts/truetype/denemo/emmentaler.ttf \
+ share/fonts/truetype/denemo/feta.ttf \
+ share/pixmaps/denemo.png
+.for i in cs de en_GB es fr it ja pl sv
+PLIST_FILES+= share/locale/${i}/LC_MESSAGES/denemo.mo
+.endfor
+OPTIONS_DEFINE= DOCS EXAMPLES LILYPOND PDF
+OPTIONS_SINGLE= TOOLKIT
+OPTIONS_SINGLE_TOOLKIT= GTK2 GTK3
+OPTIONS_DEFAULT= GTK3
+
+GTK2_USE= gnome=gtk20,gtksourceview2
+GTK2_CONFIGURE_ON= --enable-gtk2
+GTK3_USE= gnome=gtk30,gtksourceview3
LILYPOND_DESC= Install LilyPond (Printing)
LILYPOND_RUN_DEPENDS= lilypond:${PORTSDIR}/print/lilypond
+PDF_CONFIGURE_OFF= --disable-evince
+TOOLKIT_DESC= GTK+ toolkit
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MGTK3}
-USE_GNOME+= gtk30 gtksourceview3
-.else
-USE_GNOME+= gtk20 gtksourceview2
-CONFIGURE_ARGS+=--enable-gtk2
+.if ${PORT_OPTIONS:MLILYPOND}
+BROKEN= Depends transitively on conflicting versions of guile
+.endif
+
+.if ${PORT_OPTIONS:MGTK3} && ${PORT_OPTIONS:MPDF}
+LIB_DEPENDS+= libevview3.so:${PORTSDIR}/graphics/evince
+.endif
+
+.if ${PORT_OPTIONS:MGTK2} && ${PORT_OPTIONS:MPDF}
+LIB_DEPENDS+= libatrilview.so:${PORTSDIR}/graphics/atril
.endif
post-patch:
@${REINPLACE_CMD} -e \
- '/^CFLAGS=/s|_LIBS|_CFLAGS| ; \
- s|-lpthread|-pthread|' ${WRKSRC}/configure
+ 's|-lpthread|-pthread| ; \
+ /^CFLAGS=/s|_LIBS|_CFLAGS| ; \
+ s|evince-view-2.32 >= 2.|atril-view-1.5.|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
'/ docs /d ; \
/) install-data-hook/s|^|#|' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e \
's|"firefox"|"xdg-open"|' ${WRKSRC}/src/core/prefops.c
+.if ${PORT_OPTIONS:MGTK2} && ${PORT_OPTIONS:MPDF}
+ @${FIND} ${WRKSRC}/src -name "*.c" | ${XARGS} ${REINPLACE_CMD} -e \
+ '/^#include/s|evince|atril|'
+.endif
post-install:
@${MKDIR} ${STAGEDIR}${DATADIR}