aboutsummaryrefslogtreecommitdiff
path: root/audio/denemo
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-02-22 21:49:01 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-02-22 21:49:01 +0000
commitb04a19d495a5123f142ade8cb60a990eaf960d10 (patch)
tree758d22b455b7851470ca1a34e5855146a1d97c5d /audio/denemo
parent0d83c1c3bd64bcca10c6224eedf3d2f7afa0f4d4 (diff)
downloadports-b04a19d495a5123f142ade8cb60a990eaf960d10.tar.gz
ports-b04a19d495a5123f142ade8cb60a990eaf960d10.zip
- Update to 0.7.4
- portlint(1) PR: 93651 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=156714
Diffstat (limited to 'audio/denemo')
-rw-r--r--audio/denemo/Makefile65
-rw-r--r--audio/denemo/distinfo6
-rw-r--r--audio/denemo/files/patch-playback.c10
-rw-r--r--audio/denemo/files/patch-src__help.cpp28
-rw-r--r--audio/denemo/pkg-plist203
5 files changed, 258 insertions, 54 deletions
diff --git a/audio/denemo/Makefile b/audio/denemo/Makefile
index a182dba5b521..d984f11ccfa1 100644
--- a/audio/denemo/Makefile
+++ b/audio/denemo/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= denemo
-PORTVERSION= 0.5.9
-PORTREVISION= 3
+PORTVERSION= 0.7.4
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,54 +14,38 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Graphical score editor
-LIB_DEPENDS= xml.5:${PORTSDIR}/textproc/libxml
-
-GNU_CONFIGURE= yes
-PLIST= ${WRKDIR}/pkg-plist
-SHARED= denemo.conf denemo.keymaprc english.keymaprc french.keymaprc
-DOCS= AUTHORS ChangeLog DESIGN GOALS NEWS README TODO
-DOCDIR= share/doc/${PORTNAME}
+USE_X_PREFIX= yes
+USE_GNOME= gnometarget gtk20 libxml2
USE_BISON= yes
-USE_GETOPT_LONG=yes
USE_GETTEXT= yes
-USE_GNOME= gtk12
-USE_X_PREFIX= yes
+USE_GETOPT_LONG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
-BROKEN= "Does not compile on sparc64"
+BROKEN= does not compile on sparc64
.endif
-pre-patch:
-.for ii in analysis_highlighting.c easylyparser.c easylyparser.y \
- lyparserfuncs.c lyparserfuncs.h main.c playback.c print.c
- ${MV} ${WRKSRC}/${ii} ${WRKSRC}/${ii}.orig
- ${SED} -e "s:<wait.h:<sys/wait.h:g ; s:setkey:dsetkey:g" \
- < ${WRKSRC}/${ii}.orig > ${WRKSRC}/${ii}
-.endfor
-
-pre-install:
- ${ECHO_CMD} bin/${PORTNAME} > ${PLIST}
-.for i in ${SHARED}
- ${ECHO_CMD} share/denemo/$i >> ${PLIST}
-.endfor
-.for i in ${DOCS}
- ${ECHO_CMD} ${DOCDIR}/$i >> ${PLIST}
-.endfor
- ${ECHO_CMD} @dirrm ${DOCDIR} >> ${PLIST}
- ${ECHO_CMD} @dirrm share/denemo >> ${PLIST}
-
-do-install:
- ${MKDIR} ${PREFIX}/share/denemo
- ${INSTALL_PROGRAM} ${WRKSRC}/denemo ${PREFIX}/bin
-.for i in ${SHARED}
- ${INSTALL_DATA} ${WRKSRC}/$i ${DATADIR}
-.endfor
+post-patch:
+ @${REINPLACE_CMD} -e 's|CXXFLAGS="$$CFLAGS|CXXFLAGS="$$DENEMO_CFLAGS|g' \
+ -e 's|-Wall -O2|-Wall $$CXXFLAGS|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s|denemo/denemo|denemo|g" ${WRKSRC}/src/kbd-custom.cpp
+ @${REINPLACE_CMD} -e "s|^setkey|dsetkey|g" ${WRKSRC}/src/lyparserfuncs.cpp
+ @${REINPLACE_CMD} -e "s| setkey| dsetkey|g" ${WRKSRC}/src/lyparserfuncs.h
+ @${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|g" ${WRKSRC}/m4/gettext.m4 \
+ ${WRKSRC}/ltmain.sh ${WRKSRC}/src/file.cpp ${WRKSRC}/src/lyparser.cpp \
+ ${WRKSRC}/src/lyparser.y
+
+post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+.for i in AUTHORS ChangeLog DESIGN GOALS NEWS README TODO
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
diff --git a/audio/denemo/distinfo b/audio/denemo/distinfo
index fc85f28b3f3e..e474b3057a3b 100644
--- a/audio/denemo/distinfo
+++ b/audio/denemo/distinfo
@@ -1,3 +1,3 @@
-MD5 (denemo-0.5.9.tar.gz) = 9857132b06feccfd5bf9aebd2b3d33b4
-SHA256 (denemo-0.5.9.tar.gz) = e6c60208bbd4c5e37dfef0ae9ad95bd52aff8ee2576af4cf7cb8cd80222cfda8
-SIZE (denemo-0.5.9.tar.gz) = 396751
+MD5 (denemo-0.7.4.tar.gz) = 5a5680b2dab63a6217c0ab7c30be0730
+SHA256 (denemo-0.7.4.tar.gz) = ec531bf4199142314b87e4a37abe6e89ee3bd4819674230cfe2cd8b8bf7a7cc6
+SIZE (denemo-0.7.4.tar.gz) = 2712658
diff --git a/audio/denemo/files/patch-playback.c b/audio/denemo/files/patch-playback.c
deleted file mode 100644
index 1675df8cbc59..000000000000
--- a/audio/denemo/files/patch-playback.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- playback.c.old Wed Nov 14 11:13:02 2001
-+++ playback.c Wed Jan 9 19:38:16 2002
-@@ -7,6 +7,7 @@
-
-
- #include "datastructures.h"
-+#include "exportmidi.h"
- #include "exportmudela.h"
- #include "staffops.h"
- #include "scoreops.h"
diff --git a/audio/denemo/files/patch-src__help.cpp b/audio/denemo/files/patch-src__help.cpp
new file mode 100644
index 000000000000..9417b8c45116
--- /dev/null
+++ b/audio/denemo/files/patch-src__help.cpp
@@ -0,0 +1,28 @@
+--- src/help.cpp.orig Fri Oct 28 06:18:00 2005
++++ src/help.cpp Tue Feb 21 23:23:26 2006
+@@ -46,20 +46,21 @@
+ void
+ browse_manual (GtkAction * action, gpointer data)
+ {
+- gchar *browser = "sensible-browser";
++ struct scoreinfo *si= (struct scoreinfo *)data;
++
+ gint retval;
+ // struct scoreinfo *si;
+ GError *error = NULL;
+ gchar **argv;
+ gchar *cmd;
+ gchar *data_dir = gbr_find_data_dir (PKGDATADIR);
+- gchar *path = g_strdup_printf("%s/denemo/manual/manualout.html", data_dir);
++ gchar *path = g_strdup_printf("file://%s/manual/manualout.html", data_dir);
+ gchar *argument = g_shell_quote(path);
+
+
+- g_print("PKGDATADIR %s\n", PKGDATADIR);
++ //g_print("PKGDATADIR %s\n", PKGDATADIR);
+
+- cmd = g_strconcat (browser, " ", argument, NULL);
++ cmd = g_strconcat (si->prefs->browser->str, " ", argument, NULL);
+ g_free(argument);
+ if (! g_shell_parse_argv(cmd, NULL, &argv, &error))
+ {
diff --git a/audio/denemo/pkg-plist b/audio/denemo/pkg-plist
new file mode 100644
index 000000000000..e858f217d249
--- /dev/null
+++ b/audio/denemo/pkg-plist
@@ -0,0 +1,203 @@
+bin/denemo
+etc/denemo.conf
+etc/denemo.keymaprc
+include/denemo/denemo.h
+include/denemo/denemo_version.h
+%%DATADIR%%/denemoui.xml
+%%DATADIR%%/english.keymaprc
+%%DATADIR%%/french.keymaprc
+%%DATADIR%%/italian.keymaprc
+%%DATADIR%%/manual/4fo2denemo.png
+%%DATADIR%%/manual/4for2abc.png
+%%DATADIR%%/manual/4for2abcps.png
+%%DATADIR%%/manual/4for2ly.png
+%%DATADIR%%/manual/4for2new-page1.png
+%%DATADIR%%/manual/4for2new-page2.png
+%%DATADIR%%/manual/4for2touchedly.png
+%%DATADIR%%/manual/MozBook.css
+%%DATADIR%%/manual/addvc2currentstaff.png
+%%DATADIR%%/manual/bandtemplate.png
+%%DATADIR%%/manual/choraltemplate1.png
+%%DATADIR%%/manual/churchtemplate2.png
+%%DATADIR%%/manual/clefmenu.png
+%%DATADIR%%/manual/denemomain.png
+%%DATADIR%%/manual/displaymenu.png
+%%DATADIR%%/manual/docbook-complete.css
+%%DATADIR%%/manual/educationtemplate3.png
+%%DATADIR%%/manual/featest.html
+%%DATADIR%%/manual/fig1.png
+%%DATADIR%%/manual/fig3.png
+%%DATADIR%%/manual/filemenu.png
+%%DATADIR%%/manual/function.xml
+%%DATADIR%%/manual/functionaaron.xml
+%%DATADIR%%/manual/functionout.html
+%%DATADIR%%/manual/generaltemplate4.png
+%%DATADIR%%/manual/keymenu.png
+%%DATADIR%%/manual/lpmode.png
+%%DATADIR%%/manual/manual.xml
+%%DATADIR%%/manual/manualout.html
+%%DATADIR%%/manual/navigationmenu.png
+%%DATADIR%%/manual/orchestraltemplate5.png
+%%DATADIR%%/manual/othermenu1.png
+%%DATADIR%%/manual/playbackmenu.png
+%%DATADIR%%/manual/polyphony.png
+%%DATADIR%%/manual/setpreferences.png
+%%DATADIR%%/manual/staffmenu.png
+%%DATADIR%%/manual/tablituretemplate6.png
+%%DATADIR%%/manual/timemenu.png
+%%DATADIR%%/pixmaps/accent.svg
+%%DATADIR%%/pixmaps/downbow.svg
+%%DATADIR%%/pixmaps/fermata.svg
+%%DATADIR%%/pixmaps/feta26-accidentals--1.xbm
+%%DATADIR%%/pixmaps/feta26-accidentals--2.xbm
+%%DATADIR%%/pixmaps/feta26-accidentals-0.xbm
+%%DATADIR%%/pixmaps/feta26-accidentals-1.xbm
+%%DATADIR%%/pixmaps/feta26-accidentals-2.xbm
+%%DATADIR%%/pixmaps/feta26-accidentals-leftparen.xbm
+%%DATADIR%%/pixmaps/feta26-accidentals-rightparen.xbm
+%%DATADIR%%/pixmaps/feta26-clefs-alto.xbm
+%%DATADIR%%/pixmaps/feta26-clefs-alto_change.xbm
+%%DATADIR%%/pixmaps/feta26-clefs-bass.xbm
+%%DATADIR%%/pixmaps/feta26-clefs-bass_change.xbm
+%%DATADIR%%/pixmaps/feta26-clefs-g_8.xbm
+%%DATADIR%%/pixmaps/feta26-clefs-treble.xbm
+%%DATADIR%%/pixmaps/feta26-clefs-treble_change.xbm
+%%DATADIR%%/pixmaps/feta26-dots-dot.xbm
+%%DATADIR%%/pixmaps/feta26-dots-repeatcolon.xbm
+%%DATADIR%%/pixmaps/feta26-flags-d3.xbm
+%%DATADIR%%/pixmaps/feta26-flags-d4.xbm
+%%DATADIR%%/pixmaps/feta26-flags-d5.xbm
+%%DATADIR%%/pixmaps/feta26-flags-d6.xbm
+%%DATADIR%%/pixmaps/feta26-flags-dgrace.xbm
+%%DATADIR%%/pixmaps/feta26-flags-u3.xbm
+%%DATADIR%%/pixmaps/feta26-flags-u4.xbm
+%%DATADIR%%/pixmaps/feta26-flags-u5.xbm
+%%DATADIR%%/pixmaps/feta26-flags-u6.xbm
+%%DATADIR%%/pixmaps/feta26-flags-ugrace.xbm
+%%DATADIR%%/pixmaps/feta26-noteheads--1.xbm
+%%DATADIR%%/pixmaps/feta26-noteheads--2.xbm
+%%DATADIR%%/pixmaps/feta26-noteheads-0.xbm
+%%DATADIR%%/pixmaps/feta26-noteheads-0diamond.xbm
+%%DATADIR%%/pixmaps/feta26-noteheads-1.xbm
+%%DATADIR%%/pixmaps/feta26-noteheads-1diamond.xbm
+%%DATADIR%%/pixmaps/feta26-noteheads-2.xbm
+%%DATADIR%%/pixmaps/feta26-noteheads-2cross.xbm
+%%DATADIR%%/pixmaps/feta26-noteheads-2diamond.xbm
+%%DATADIR%%/pixmaps/feta26-noteheads-2harmonic.xbm
+%%DATADIR%%/pixmaps/feta26-noteheads-ledgerending.xbm
+%%DATADIR%%/pixmaps/feta26-rests--1.xbm
+%%DATADIR%%/pixmaps/feta26-rests--2.xbm
+%%DATADIR%%/pixmaps/feta26-rests--4.xbm
+%%DATADIR%%/pixmaps/feta26-rests-0.xbm
+%%DATADIR%%/pixmaps/feta26-rests-0o.xbm
+%%DATADIR%%/pixmaps/feta26-rests-1.xbm
+%%DATADIR%%/pixmaps/feta26-rests-1o.xbm
+%%DATADIR%%/pixmaps/feta26-rests-2.xbm
+%%DATADIR%%/pixmaps/feta26-rests-2mensural.xbm
+%%DATADIR%%/pixmaps/feta26-rests-3.xbm
+%%DATADIR%%/pixmaps/feta26-rests-3mensural.xbm
+%%DATADIR%%/pixmaps/feta26-rests-4.xbm
+%%DATADIR%%/pixmaps/feta26-rests-4mensural.xbm
+%%DATADIR%%/pixmaps/feta26-rests-5.xbm
+%%DATADIR%%/pixmaps/feta26-rests-6.xbm
+%%DATADIR%%/pixmaps/feta26-rests-7.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-accent.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-arpeggio.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-coda.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-dfermata.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-dmarcato.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-downbow.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-downprall.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-dpedalheel.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-dpedaltoe.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-dstaccatissimo.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-flageolet.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-mordent.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-open.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-prall.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-prallmordent.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-prallprall.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-repeatsign.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-reverseturn.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-segno.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-sforzato.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-staccato.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-stopped.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-tenuto.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-thumb.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-trilelement.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-trill-element.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-trill.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-turn.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-ufermata.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-umarcato.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-upbow.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-upedalheel.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-upedaltoe.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-upprall.xbm
+%%DATADIR%%/pixmaps/feta26-scripts-ustaccatissimo.xbm
+%%DATADIR%%/pixmaps/feta26-timesig-C2-2.xbm
+%%DATADIR%%/pixmaps/feta26-timesig-C4-4.xbm
+%%DATADIR%%/pixmaps/feta26-timesig-old2-2.xbm
+%%DATADIR%%/pixmaps/feta26-timesig-old2-4.xbm
+%%DATADIR%%/pixmaps/feta26-timesig-old3-2.xbm
+%%DATADIR%%/pixmaps/feta26-timesig-old3-4.xbm
+%%DATADIR%%/pixmaps/feta26-timesig-old4-4.xbm
+%%DATADIR%%/pixmaps/feta26-timesig-old4-8.xbm
+%%DATADIR%%/pixmaps/feta26-timesig-old6-4.xbm
+%%DATADIR%%/pixmaps/feta26-timesig-old6-8.xbm
+%%DATADIR%%/pixmaps/feta26-timesig-old6-8alt.xbm
+%%DATADIR%%/pixmaps/feta26-timesig-old9-4.xbm
+%%DATADIR%%/pixmaps/feta26-timesig-old9-8.xbm
+%%DATADIR%%/pixmaps/icon-note-0.svg
+%%DATADIR%%/pixmaps/icon-note-1.svg
+%%DATADIR%%/pixmaps/icon-note-2.svg
+%%DATADIR%%/pixmaps/icon-note-3.svg
+%%DATADIR%%/pixmaps/icon-note-4.svg
+%%DATADIR%%/pixmaps/icon-rest-0.svg
+%%DATADIR%%/pixmaps/icon-rest-1.svg
+%%DATADIR%%/pixmaps/icon-rest-2.svg
+%%DATADIR%%/pixmaps/icon-rest-3.svg
+%%DATADIR%%/pixmaps/icon-rest-4.svg
+%%DATADIR%%/pixmaps/icon-rest-5.svg
+%%DATADIR%%/pixmaps/icon-template.svg
+%%DATADIR%%/pixmaps/lheel.svg
+%%DATADIR%%/pixmaps/ltoe.svg
+%%DATADIR%%/pixmaps/marcato.svg
+%%DATADIR%%/pixmaps/mordent.svg
+%%DATADIR%%/pixmaps/notehead-0.xbm
+%%DATADIR%%/pixmaps/notehead-1.xbm
+%%DATADIR%%/pixmaps/notehead-2.xbm
+%%DATADIR%%/pixmaps/reverse-turn.svg
+%%DATADIR%%/pixmaps/rheel.svg
+%%DATADIR%%/pixmaps/rtoe.svg
+%%DATADIR%%/pixmaps/staccatissimo.svg
+%%DATADIR%%/pixmaps/staccato.svg
+%%DATADIR%%/pixmaps/tenuto.svg
+%%DATADIR%%/pixmaps/toomany.xbm
+%%DATADIR%%/pixmaps/trill.svg
+%%DATADIR%%/pixmaps/turn.svg
+%%DATADIR%%/pixmaps/upbow.svg
+%%DATADIR%%/speedy.keymaprc
+%%DATADIR%%/templates/Brassband.denemo
+%%DATADIR%%/templates/Brassbandtemplate.denemo
+%%DATADIR%%/templates/brasschoir.template.denemo
+%%DATADIR%%/templates/brasstrio.template.denemo
+%%DATADIR%%/templates/jazzcombo1.denemo
+%%DATADIR%%/templates/stringqtet.denemo
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/DESIGN
+%%PORTDOCS%%%%DOCSDIR%%/GOALS
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+share/locale/es/LC_MESSAGES/denemo.mo
+share/locale/fr/LC_MESSAGES/denemo.mo
+share/locale/sv/LC_MESSAGES/denemo.mo
+@dirrm %%DATADIR%%/templates
+@dirrm %%DATADIR%%/pixmaps
+@dirrm %%DATADIR%%/manual
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/denemo