aboutsummaryrefslogtreecommitdiff
path: root/audio/dpf-plugins-lv2
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-08-18 07:03:28 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-08-18 07:03:28 +0000
commit2964bdd8c7c684aa3b9a5a0ac1af837551e97ff0 (patch)
treee1041f1ad9c762f1ad0a0a758e2440131455d320 /audio/dpf-plugins-lv2
parentd195f2dd3cd9632a419f1c4106fa0bf5d0b25e40 (diff)
downloadports-2964bdd8c7c684aa3b9a5a0ac1af837551e97ff0.tar.gz
ports-2964bdd8c7c684aa3b9a5a0ac1af837551e97ff0.zip
New port: audio/dpf-plugins-lv2: Collection of DPF-based LV2 plugins
Notes
Notes: svn path=/head/; revision=477480
Diffstat (limited to 'audio/dpf-plugins-lv2')
-rw-r--r--audio/dpf-plugins-lv2/Makefile41
-rw-r--r--audio/dpf-plugins-lv2/distinfo3
-rw-r--r--audio/dpf-plugins-lv2/files/mntent.h62
-rw-r--r--audio/dpf-plugins-lv2/files/patch-Makefile27
-rw-r--r--audio/dpf-plugins-lv2/files/patch-Makefile.mk27
-rw-r--r--audio/dpf-plugins-lv2/files/patch-dpf_dgl_Makefile.mk26
-rw-r--r--audio/dpf-plugins-lv2/files/patch-dpf_dgl_src_Window.cpp26
-rw-r--r--audio/dpf-plugins-lv2/files/patch-dpf_utils_lv2-ttl-generator_GNUmakefile11
-rw-r--r--audio/dpf-plugins-lv2/files/patch-plugins_common_gen__dsp_genlib.cpp12
-rw-r--r--audio/dpf-plugins-lv2/pkg-descr15
-rw-r--r--audio/dpf-plugins-lv2/pkg-plist107
11 files changed, 357 insertions, 0 deletions
diff --git a/audio/dpf-plugins-lv2/Makefile b/audio/dpf-plugins-lv2/Makefile
new file mode 100644
index 000000000000..233136744f6f
--- /dev/null
+++ b/audio/dpf-plugins-lv2/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= dpf-plugins
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1-1
+DISTVERSIONSUFFIX= -g0c433e4
+CATEGORIES= audio
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Collection of DPF-based LV2 plugins
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= lv2>0:audio/lv2 \
+ bash:shells/bash
+LIB_DEPENDS= libprojectM.so:graphics/libprojectm
+
+USES= gmake localbase pkgconfig shebangfix
+SHEBANG_FILES= dpf/utils/generate-ttl.sh
+USE_GITHUB= yes
+GH_ACCOUNT= DISTRHO
+GH_PROJECT= DPF-Plugins
+USE_XORG= x11
+USE_GL= gl
+
+CXXFLAGS+= -I${FILESDIR}
+LDFLAGS+= -pthread
+
+OPTIONS_DEFINE_amd64= SIMD
+OPTIONS_DEFINE_i386= SIMD
+OPTIONS_DEFAULT_amd64= SIMD
+OPTIONS_DEFAULT_i386= SIMD
+
+SIMD_MAKE_ENV= SIMD_FLAGS="-msse -msse2 -mfpmath=sse"
+
+post-patch: # disable all plugins except for LV2
+ @${FIND} ${WRKSRC} -name "*.mk" | ${XARGS} ${REINPLACE_CMD} -i '' -E 's/BUILD_(LADSPA|DSSI|VST2) *= *true/BUILD_\1 = false/'
+
+.include <bsd.port.mk>
diff --git a/audio/dpf-plugins-lv2/distinfo b/audio/dpf-plugins-lv2/distinfo
new file mode 100644
index 000000000000..44027834e387
--- /dev/null
+++ b/audio/dpf-plugins-lv2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1534560066
+SHA256 (DISTRHO-DPF-Plugins-v1.1-1-g0c433e4_GH0.tar.gz) = 40455ca67a79ec1589f386450e242109965c4529b098264dac2df4cad673b288
+SIZE (DISTRHO-DPF-Plugins-v1.1-1-g0c433e4_GH0.tar.gz) = 10703465
diff --git a/audio/dpf-plugins-lv2/files/mntent.h b/audio/dpf-plugins-lv2/files/mntent.h
new file mode 100644
index 000000000000..e61cddd89c82
--- /dev/null
+++ b/audio/dpf-plugins-lv2/files/mntent.h
@@ -0,0 +1,62 @@
+/*
+ * mntent
+ * mntent.h - compatability header for FreeBSD
+ *
+ * Copyright (c) 2001 David Rufino <daverufino@btinternet.com>
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ */
+
+#if defined(HAVE_MNTENT_H)
+#include <mntent.h>
+#else
+#ifndef _MNTENT_H
+#define _MNTENT_H
+#include <stdio.h>
+
+#define MOUNTED "dummy"
+
+#define MNTTYPE_NFS "nfs"
+
+struct mntent {
+ char *mnt_fsname;
+ char *mnt_dir;
+ char *mnt_type;
+ char *mnt_opts;
+ int mnt_freq;
+ int mnt_passno;
+};
+
+#define setmntent(x,y) ((FILE *)0x1)
+#ifdef __cplusplus
+extern "C" {
+#endif
+struct mntent *getmntent __P ((FILE *fp));
+char *hasmntopt __P ((const struct mntent *mnt, const char *option));
+#ifdef __cplusplus
+}; // extern "C"
+#endif
+#define endmntent(x) ((int)1)
+
+#endif /* _MNTENT_H */
+#endif /* HAVE_MNTENT_H */
diff --git a/audio/dpf-plugins-lv2/files/patch-Makefile b/audio/dpf-plugins-lv2/files/patch-Makefile
new file mode 100644
index 000000000000..1e3ba2ab0f66
--- /dev/null
+++ b/audio/dpf-plugins-lv2/files/patch-Makefile
@@ -0,0 +1,27 @@
+--- Makefile.orig 2018-08-18 06:07:42 UTC
++++ Makefile
+@@ -109,17 +109,17 @@ endif
+ # --------------------------------------------------------------
+
+ install:
+- install -d $(DESTDIR)$(PREFIX)/lib/ladspa/
+- install -d $(DESTDIR)$(PREFIX)/lib/dssi/
++ #install -d $(DESTDIR)$(PREFIX)/lib/ladspa/
++ #install -d $(DESTDIR)$(PREFIX)/lib/dssi/
+ install -d $(DESTDIR)$(PREFIX)/lib/lv2/
+- install -d $(DESTDIR)$(PREFIX)/lib/vst/
++ #install -d $(DESTDIR)$(PREFIX)/lib/vst/
+
+- cp bin/*-ladspa.* $(DESTDIR)$(PREFIX)/lib/ladspa/
+- cp bin/*-dssi.* $(DESTDIR)$(PREFIX)/lib/dssi/
+- cp bin/*-vst.* $(DESTDIR)$(PREFIX)/lib/vst/
++ #cp bin/*-ladspa.* $(DESTDIR)$(PREFIX)/lib/ladspa/
++ #cp bin/*-dssi.* $(DESTDIR)$(PREFIX)/lib/dssi/
++ #cp bin/*-vst.* $(DESTDIR)$(PREFIX)/lib/vst/
+
+ ifeq ($(HAVE_DGL),true)
+- cp -r bin/*-dssi $(DESTDIR)$(PREFIX)/lib/dssi/
++ #cp -r bin/*-dssi $(DESTDIR)$(PREFIX)/lib/dssi/
+ endif
+ cp -r bin/*.lv2 $(DESTDIR)$(PREFIX)/lib/lv2/
+
diff --git a/audio/dpf-plugins-lv2/files/patch-Makefile.mk b/audio/dpf-plugins-lv2/files/patch-Makefile.mk
new file mode 100644
index 000000000000..64910b1c982f
--- /dev/null
+++ b/audio/dpf-plugins-lv2/files/patch-Makefile.mk
@@ -0,0 +1,27 @@
+--- Makefile.mk.orig 2018-04-27 06:05:19 UTC
++++ Makefile.mk
+@@ -23,7 +23,7 @@ endif
+ # Set build and link flags
+
+ BASE_FLAGS = -Wall -Wextra -pipe
+-BASE_OPTS = -O2 -ffast-math -mtune=generic -msse -msse2 -fdata-sections -ffunction-sections
++BASE_OPTS = -O2 -ffast-math -mtune=generic $(SIMD_FLAGS) -fdata-sections -ffunction-sections
+
+ ifneq ($(MACOS_OLD),true)
+ # Old MacOS doesn't support this
+@@ -35,13 +35,13 @@ ifeq ($(MACOS),true)
+ LINK_OPTS = -fdata-sections -ffunction-sections -Wl,-dead_strip -Wl,-dead_strip_dylibs
+ else
+ # Common linker flags
+-LINK_OPTS = -fdata-sections -ffunction-sections -Wl,--gc-sections -Wl,-O1 -Wl,--as-needed -Wl,--strip-all
++LINK_OPTS = -fdata-sections -ffunction-sections -Wl,--gc-sections -Wl,-O1 -Wl,--strip-all
+ endif
+
+ ifeq ($(RASPPI),true)
+ # Raspberry-Pi optimization flags
+ BASE_OPTS = -O2 -ffast-math -march=armv6 -mfpu=vfp -mfloat-abi=hard
+-LINK_OPTS = -Wl,-O1 -Wl,--as-needed -Wl,--strip-all
++LINK_OPTS = -Wl,-O1 -Wl,--strip-all
+ endif
+
+ ifeq ($(NOOPT),true)
diff --git a/audio/dpf-plugins-lv2/files/patch-dpf_dgl_Makefile.mk b/audio/dpf-plugins-lv2/files/patch-dpf_dgl_Makefile.mk
new file mode 100644
index 000000000000..0ebc623341e4
--- /dev/null
+++ b/audio/dpf-plugins-lv2/files/patch-dpf_dgl_Makefile.mk
@@ -0,0 +1,26 @@
+--- dpf/dgl/Makefile.mk.orig 2018-04-27 06:05:19 UTC
++++ dpf/dgl/Makefile.mk
+@@ -23,20 +23,20 @@ endif
+ # Set build and link flags
+
+ BASE_FLAGS = -Wall -Wextra -pipe -MD -MP
+-BASE_OPTS = -O2 -mtune=generic -msse -msse2 -fdata-sections -ffunction-sections
++BASE_OPTS = -O2 -mtune=generic $(SIMD_FLAGS) -fdata-sections -ffunction-sections
+
+ ifeq ($(MACOS),true)
+ # MacOS linker flags
+ LINK_OPTS = -fdata-sections -ffunction-sections -Wl,-dead_strip -Wl,-dead_strip_dylibs
+ else
+ # Common linker flags
+-LINK_OPTS = -fdata-sections -ffunction-sections -Wl,--gc-sections -Wl,-O1 -Wl,--as-needed -Wl,--strip-all
++LINK_OPTS = -fdata-sections -ffunction-sections -Wl,--gc-sections -Wl,-O1 -Wl,--strip-all
+ endif
+
+ ifeq ($(RASPPI),true)
+ # Raspberry-Pi optimization flags
+ BASE_OPTS = -O2 -march=armv6 -mfpu=vfp -mfloat-abi=hard
+-LINK_OPTS = -Wl,-O1 -Wl,--as-needed -Wl,--strip-all
++LINK_OPTS = -Wl,-O1 -Wl,--strip-all
+ endif
+
+ ifeq ($(NOOPT),true)
diff --git a/audio/dpf-plugins-lv2/files/patch-dpf_dgl_src_Window.cpp b/audio/dpf-plugins-lv2/files/patch-dpf_dgl_src_Window.cpp
new file mode 100644
index 000000000000..50eedaeef945
--- /dev/null
+++ b/audio/dpf-plugins-lv2/files/patch-dpf_dgl_src_Window.cpp
@@ -0,0 +1,26 @@
+--- dpf/dgl/src/Window.cpp.orig 2018-08-18 05:40:10 UTC
++++ dpf/dgl/src/Window.cpp
+@@ -51,6 +51,10 @@ extern "C" {
+ #include "../StandaloneWindow.hpp"
+ #include "../../distrho/extra/String.hpp"
+
++#if defined(__FreeBSD__)
++#include <unistd.h>
++#endif
++
+ #define FOR_EACH_WIDGET(it) \
+ for (std::list<Widget*>::iterator it = fWidgets.begin(); it != fWidgets.end(); ++it)
+
+@@ -1151,7 +1155,12 @@ bool Window::openFileBrowser(const FileB
+
+ if (startDir.isEmpty())
+ {
++#if defined(__FreeBSD__)
++ char buf[1024];
++ if (char* const dir_name = ::getwd(buf))
++#else
+ if (char* const dir_name = get_current_dir_name())
++#endif
+ {
+ startDir = dir_name;
+ std::free(dir_name);
diff --git a/audio/dpf-plugins-lv2/files/patch-dpf_utils_lv2-ttl-generator_GNUmakefile b/audio/dpf-plugins-lv2/files/patch-dpf_utils_lv2-ttl-generator_GNUmakefile
new file mode 100644
index 000000000000..a5f1b7a32048
--- /dev/null
+++ b/audio/dpf-plugins-lv2/files/patch-dpf_utils_lv2-ttl-generator_GNUmakefile
@@ -0,0 +1,11 @@
+--- dpf/utils/lv2-ttl-generator/GNUmakefile.orig 2018-08-18 06:55:42 UTC
++++ dpf/utils/lv2-ttl-generator/GNUmakefile
+@@ -9,7 +9,7 @@ build: ../lv2_ttl_generator
+ endif
+
+ ../lv2_ttl_generator: lv2_ttl_generator.c
+- $(CC) $< $(CFLAGS) -o $@ $(LDFLAGS) -ldl
++ $(CC) $< $(CFLAGS) -o $@ $(LDFLAGS)
+
+ ../lv2_ttl_generator.exe: lv2_ttl_generator.c
+ $(CC) $< $(CFLAGS) -o $@ $(LDFLAGS) -static
diff --git a/audio/dpf-plugins-lv2/files/patch-plugins_common_gen__dsp_genlib.cpp b/audio/dpf-plugins-lv2/files/patch-plugins_common_gen__dsp_genlib.cpp
new file mode 100644
index 000000000000..a257db1f3d31
--- /dev/null
+++ b/audio/dpf-plugins-lv2/files/patch-plugins_common_gen__dsp_genlib.cpp
@@ -0,0 +1,12 @@
+--- plugins/common/gen_dsp/genlib.cpp.orig 2018-04-27 06:05:19 UTC
++++ plugins/common/gen_dsp/genlib.cpp
+@@ -29,7 +29,8 @@ OR THE USE OR OTHER DEALINGS IN THE SOFT
+ #if DISTRHO_OS_MAC
+ # include <malloc/malloc.h>
+ #else
+-# include <malloc.h>
++# include <stdlib.h>
++#include <malloc_np.h>
+ # if DISTRHO_OS_WINDOWS
+ # define malloc_size _msize
+ # else
diff --git a/audio/dpf-plugins-lv2/pkg-descr b/audio/dpf-plugins-lv2/pkg-descr
new file mode 100644
index 000000000000..b7055feda86e
--- /dev/null
+++ b/audio/dpf-plugins-lv2/pkg-descr
@@ -0,0 +1,15 @@
+Collection of DPF-based plugins.
+They come in LADSPA, DSSI, LV2 and VST2 formats, but only LV2
+plugins are included in the port.
+
+The list of plugins:
+* glBars
+* Kars
+* Max-Gen examples (MaBitcrush, MaFreeverb, MaGigaverb, MaPitchshift)
+* Mini-Series (3BandEQ. 3BandSplitter, PingPongPan)
+* ndc-Plugs (Amplitude Imposer, Cycle Shifter, Soul Force)
+* MVerb
+* Nekobi
+* ProM
+
+WWW: https://github.com/DISTRHO/DPF-Plugins
diff --git a/audio/dpf-plugins-lv2/pkg-plist b/audio/dpf-plugins-lv2/pkg-plist
new file mode 100644
index 000000000000..13ae4d76dea1
--- /dev/null
+++ b/audio/dpf-plugins-lv2/pkg-plist
@@ -0,0 +1,107 @@
+lib/lv2/3BandEQ.lv2/3BandEQ_dsp.so
+lib/lv2/3BandEQ.lv2/3BandEQ_dsp.ttl
+lib/lv2/3BandEQ.lv2/3BandEQ_ui.so
+lib/lv2/3BandEQ.lv2/3BandEQ_ui.ttl
+lib/lv2/3BandEQ.lv2/manifest.ttl
+lib/lv2/3BandEQ.lv2/presets.ttl
+lib/lv2/3BandSplitter.lv2/3BandSplitter_dsp.so
+lib/lv2/3BandSplitter.lv2/3BandSplitter_dsp.ttl
+lib/lv2/3BandSplitter.lv2/3BandSplitter_ui.so
+lib/lv2/3BandSplitter.lv2/3BandSplitter_ui.ttl
+lib/lv2/3BandSplitter.lv2/manifest.ttl
+lib/lv2/3BandSplitter.lv2/presets.ttl
+lib/lv2/AmplitudeImposer.lv2/AmplitudeImposer_dsp.so
+lib/lv2/AmplitudeImposer.lv2/AmplitudeImposer_dsp.ttl
+lib/lv2/AmplitudeImposer.lv2/AmplitudeImposer_ui.so
+lib/lv2/AmplitudeImposer.lv2/AmplitudeImposer_ui.ttl
+lib/lv2/AmplitudeImposer.lv2/manifest.ttl
+lib/lv2/AmplitudeImposer.lv2/presets.ttl
+lib/lv2/CycleShifter.lv2/CycleShifter_dsp.so
+lib/lv2/CycleShifter.lv2/CycleShifter_dsp.ttl
+lib/lv2/CycleShifter.lv2/CycleShifter_ui.so
+lib/lv2/CycleShifter.lv2/CycleShifter_ui.ttl
+lib/lv2/CycleShifter.lv2/manifest.ttl
+lib/lv2/CycleShifter.lv2/presets.ttl
+lib/lv2/Kars.lv2/Kars_dsp.so
+lib/lv2/Kars.lv2/Kars_dsp.ttl
+lib/lv2/Kars.lv2/Kars_ui.so
+lib/lv2/Kars.lv2/Kars_ui.ttl
+lib/lv2/Kars.lv2/manifest.ttl
+lib/lv2/Kars.lv2/modgui.ttl
+lib/lv2/Kars.lv2/modgui/icon-kars.html
+lib/lv2/Kars.lv2/modgui/pedals/boxy-small/yellow.png
+lib/lv2/Kars.lv2/modgui/pedals/footswitch.png
+lib/lv2/Kars.lv2/modgui/screenshot-kars.png
+lib/lv2/Kars.lv2/modgui/stylesheet-kars.css
+lib/lv2/Kars.lv2/modgui/thumbnail-kars.png
+lib/lv2/MVerb.lv2/MVerb_dsp.so
+lib/lv2/MVerb.lv2/MVerb_dsp.ttl
+lib/lv2/MVerb.lv2/MVerb_ui.so
+lib/lv2/MVerb.lv2/MVerb_ui.ttl
+lib/lv2/MVerb.lv2/manifest.ttl
+lib/lv2/MVerb.lv2/modgui.ttl
+lib/lv2/MVerb.lv2/modgui/combos/model-001/model-0930.png
+lib/lv2/MVerb.lv2/modgui/icon-mverb.html
+lib/lv2/MVerb.lv2/modgui/knobs/chicken-head/_strip.png
+lib/lv2/MVerb.lv2/modgui/screenshot-mverb.png
+lib/lv2/MVerb.lv2/modgui/stylesheet-mverb.css
+lib/lv2/MVerb.lv2/modgui/switches/switch-001.png
+lib/lv2/MVerb.lv2/modgui/thumbnail-mverb.png
+lib/lv2/MVerb.lv2/modgui/utils/dropdown-arrow-white.png
+lib/lv2/MVerb.lv2/presets.ttl
+lib/lv2/MaBitcrush.lv2/MaBitcrush_dsp.so
+lib/lv2/MaBitcrush.lv2/MaBitcrush_dsp.ttl
+lib/lv2/MaBitcrush.lv2/manifest.ttl
+lib/lv2/MaFreeverb.lv2/MaFreeverb_dsp.so
+lib/lv2/MaFreeverb.lv2/MaFreeverb_dsp.ttl
+lib/lv2/MaFreeverb.lv2/manifest.ttl
+lib/lv2/MaGigaverb.lv2/MaGigaverb_dsp.so
+lib/lv2/MaGigaverb.lv2/MaGigaverb_dsp.ttl
+lib/lv2/MaGigaverb.lv2/manifest.ttl
+lib/lv2/MaPitchshift.lv2/MaPitchshift_dsp.so
+lib/lv2/MaPitchshift.lv2/MaPitchshift_dsp.ttl
+lib/lv2/MaPitchshift.lv2/manifest.ttl
+lib/lv2/Nekobi.lv2/Nekobi_dsp.so
+lib/lv2/Nekobi.lv2/Nekobi_dsp.ttl
+lib/lv2/Nekobi.lv2/Nekobi_ui.so
+lib/lv2/Nekobi.lv2/Nekobi_ui.ttl
+lib/lv2/Nekobi.lv2/manifest.ttl
+lib/lv2/Nekobi.lv2/modgui.ttl
+lib/lv2/Nekobi.lv2/modgui/background.png
+lib/lv2/Nekobi.lv2/modgui/footswitch.png
+lib/lv2/Nekobi.lv2/modgui/icon-nekobi.html
+lib/lv2/Nekobi.lv2/modgui/knob.png
+lib/lv2/Nekobi.lv2/modgui/led-off.png
+lib/lv2/Nekobi.lv2/modgui/led-on.png
+lib/lv2/Nekobi.lv2/modgui/screenshot-nekobi.png
+lib/lv2/Nekobi.lv2/modgui/slider-horizontal.png
+lib/lv2/Nekobi.lv2/modgui/slider-vertical.png
+lib/lv2/Nekobi.lv2/modgui/stylesheet-nekobi.css
+lib/lv2/Nekobi.lv2/modgui/thumb-nekobi.png
+lib/lv2/PingPongPan.lv2/PingPongPan_dsp.so
+lib/lv2/PingPongPan.lv2/PingPongPan_dsp.ttl
+lib/lv2/PingPongPan.lv2/PingPongPan_ui.so
+lib/lv2/PingPongPan.lv2/PingPongPan_ui.ttl
+lib/lv2/PingPongPan.lv2/manifest.ttl
+lib/lv2/PingPongPan.lv2/modgui.ttl
+lib/lv2/PingPongPan.lv2/modgui/background.png
+lib/lv2/PingPongPan.lv2/modgui/footswitch.png
+lib/lv2/PingPongPan.lv2/modgui/icon-ppp.html
+lib/lv2/PingPongPan.lv2/modgui/knob.png
+lib/lv2/PingPongPan.lv2/modgui/screenshot-ppp.png
+lib/lv2/PingPongPan.lv2/modgui/slider.png
+lib/lv2/PingPongPan.lv2/modgui/stylesheet-ppp.css
+lib/lv2/PingPongPan.lv2/modgui/thumb-ppp.png
+lib/lv2/PingPongPan.lv2/presets.ttl
+lib/lv2/ProM.lv2/ProM.so
+lib/lv2/ProM.lv2/ProM.ttl
+lib/lv2/ProM.lv2/manifest.ttl
+lib/lv2/SoulForce.lv2/SoulForce_dsp.so
+lib/lv2/SoulForce.lv2/SoulForce_dsp.ttl
+lib/lv2/SoulForce.lv2/SoulForce_ui.so
+lib/lv2/SoulForce.lv2/SoulForce_ui.ttl
+lib/lv2/SoulForce.lv2/manifest.ttl
+lib/lv2/SoulForce.lv2/presets.ttl
+lib/lv2/glBars.lv2/glBars.so
+lib/lv2/glBars.lv2/glBars.ttl
+lib/lv2/glBars.lv2/manifest.ttl