aboutsummaryrefslogtreecommitdiff
path: root/audio/drumpiler
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-15 08:16:15 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-15 08:16:15 +0000
commit798308e61705c5d49ce3e7b740092753e10e51a1 (patch)
treef7859ca3fe40c034dc216953fd555dd7c7d31a4c /audio/drumpiler
parentae484cf2387fc826318b811aaef6f26ba13fdc00 (diff)
downloadports-798308e61705c5d49ce3e7b740092753e10e51a1.tar.gz
ports-798308e61705c5d49ce3e7b740092753e10e51a1.zip
add drumpiler 0.9.0
Drum machine compiler
Notes
Notes: svn path=/head/; revision=98186
Diffstat (limited to 'audio/drumpiler')
-rw-r--r--audio/drumpiler/Makefile32
-rw-r--r--audio/drumpiler/distinfo1
-rw-r--r--audio/drumpiler/pkg-descr5
-rw-r--r--audio/drumpiler/pkg-plist1
4 files changed, 39 insertions, 0 deletions
diff --git a/audio/drumpiler/Makefile b/audio/drumpiler/Makefile
new file mode 100644
index 000000000000..ddc216f62236
--- /dev/null
+++ b/audio/drumpiler/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: drumpiler
+# Date created: Jan 15, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= drumpiler
+PORTVERSION= 0.9.0
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Drum machine compiler
+
+USE_REINPLACE= yes
+USE_SDL= yes
+CFLAGS+= `${SDL_CONFIG} --cflags`
+LIBS+= `${SDL_CONFIG} --libs`
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|SDL.h|SDL11/SDL.h|" ${WRKSRC}/drumpiler.c
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} -DUSESDL -o drumpiler drumpiler.c ${LIBS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/drumpiler ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/audio/drumpiler/distinfo b/audio/drumpiler/distinfo
new file mode 100644
index 000000000000..3008c1155b54
--- /dev/null
+++ b/audio/drumpiler/distinfo
@@ -0,0 +1 @@
+MD5 (drumpiler-0.9.0.tar.gz) = c229d575cae646f530ef23d2cfe88366
diff --git a/audio/drumpiler/pkg-descr b/audio/drumpiler/pkg-descr
new file mode 100644
index 000000000000..8f6b309279cc
--- /dev/null
+++ b/audio/drumpiler/pkg-descr
@@ -0,0 +1,5 @@
+Drum machine compiler. You write the drum patterns in textfile with a list of
+samples (*.WAV files). Feat.subroutine calls, loops, tempo changes, 8 volume
+levels, 16bit-stereo-44khz mixing.
+
+WWW: http://drumpiler.sourceforge.net/
diff --git a/audio/drumpiler/pkg-plist b/audio/drumpiler/pkg-plist
new file mode 100644
index 000000000000..742cd1b14217
--- /dev/null
+++ b/audio/drumpiler/pkg-plist
@@ -0,0 +1 @@
+bin/drumpiler