aboutsummaryrefslogtreecommitdiff
path: root/audio/easytag
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2013-12-16 07:53:19 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2013-12-16 07:53:19 +0000
commitbcd557ebda0121a81733f322e1cb5010a5568b18 (patch)
tree78988371a8acff4e989984d70f0f19245499e65f /audio/easytag
parentc53daa51d52834478dcafd968f6c3890a96b1a60 (diff)
downloadports-bcd557ebda0121a81733f322e1cb5010a5568b18.tar.gz
ports-bcd557ebda0121a81733f322e1cb5010a5568b18.zip
- easytag depends on taglib not on mp4v2 since 2.1.8
- support staging - add license - make NLS support conditional PR: 184499 Submitted by: Vladimir Kondratiev <wulf@cicgroup.ru>
Notes
Notes: svn path=/head/; revision=336613
Diffstat (limited to 'audio/easytag')
-rw-r--r--audio/easytag/Makefile32
-rw-r--r--audio/easytag/pkg-plist79
2 files changed, 60 insertions, 51 deletions
diff --git a/audio/easytag/Makefile b/audio/easytag/Makefile
index 58cba3fdb96f..152dca7198db 100644
--- a/audio/easytag/Makefile
+++ b/audio/easytag/Makefile
@@ -3,45 +3,37 @@
PORTNAME= easytag
PORTVERSION= 2.1.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= GNOME
MAINTAINER= novel@FreeBSD.org
COMMENT= GTK2 Tag editor for MP3 and OGG files
+LICENSE= GPLv2
+
LIB_DEPENDS= libid3.so:${PORTSDIR}/audio/id3lib \
libid3tag.so:${PORTSDIR}/audio/libid3tag \
libvorbis.so:${PORTSDIR}/audio/libvorbis \
libFLAC.so:${PORTSDIR}/audio/flac \
- libmp4v2.so:${PORTSDIR}/multimedia/mp4v2
+ libtag.so:${PORTSDIR}/audio/taglib
-MAN1= easytag.1
CONFLICTS= easytag-devel-[0-9]*
-NO_STAGE= yes
USE_XZ= yes
-USES= gettext gmake pkgconfig
-USE_GNOME= gnomehack gnomeprefix gtk20 desktopfileutils
+USES= gmake pkgconfig pathfix desktop-file-utils
+USE_GNOME= gtk20
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_GTK
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= WAVPACK
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MWAVPACK}
-LIB_DEPENDS+= libwavpack.so:${PORTSDIR}/audio/wavpack
-CONFIGURE_ARGS+= --enable-wavpack
-.else
-CONFIGURE_ARGS+= --disable-wavpack
-.endif
+OPTIONS_DEFINE= WAVPACK NLS
-post-patch:
- @${REINPLACE_CMD} -e 's|<mp4\.h>|<mp4v2/mp4v2.h>|g' \
- ${WRKSRC}/src/mp4_header.c \
- ${WRKSRC}/src/mp4_tag.c
+OPTIONS_SUB= yes
+WAVPACK_LIB_DEPENDS= libwavpack.so:${PORTSDIR}/audio/wavpack
+WAVPACK_CONFIGURE_ENABLE= wavpack
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
.include <bsd.port.mk>
diff --git a/audio/easytag/pkg-plist b/audio/easytag/pkg-plist
index 3b2529bf6b7e..84916139efba 100644
--- a/audio/easytag/pkg-plist
+++ b/audio/easytag/pkg-plist
@@ -1,33 +1,9 @@
bin/easytag
-%%DOCSDIR%%/HACKING
-%%DOCSDIR%%/THANKS
-%%DOCSDIR%%/TODO
+man/man1/easytag.1.gz
share/applications/easytag.desktop
-share/locale/bg/LC_MESSAGES/easytag.mo
-share/locale/cs/LC_MESSAGES/easytag.mo
-share/locale/da/LC_MESSAGES/easytag.mo
-share/locale/de/LC_MESSAGES/easytag.mo
-share/locale/el/LC_MESSAGES/easytag.mo
-share/locale/es/LC_MESSAGES/easytag.mo
-share/locale/fr/LC_MESSAGES/easytag.mo
-share/locale/he/LC_MESSAGES/easytag.mo
-share/locale/hu/LC_MESSAGES/easytag.mo
-share/locale/it/LC_MESSAGES/easytag.mo
-share/locale/ja/LC_MESSAGES/easytag.mo
-share/locale/lt/LC_MESSAGES/easytag.mo
-share/locale/nl/LC_MESSAGES/easytag.mo
-share/locale/pl/LC_MESSAGES/easytag.mo
-share/locale/pt_BR/LC_MESSAGES/easytag.mo
-share/locale/ro/LC_MESSAGES/easytag.mo
-share/locale/ru/LC_MESSAGES/easytag.mo
-share/locale/sl/LC_MESSAGES/easytag.mo
-share/locale/sr/LC_MESSAGES/easytag.mo
-share/locale/sr@Latn/LC_MESSAGES/easytag.mo
-share/locale/sr@latin/LC_MESSAGES/easytag.mo
-share/locale/sv/LC_MESSAGES/easytag.mo
-share/locale/uk/LC_MESSAGES/easytag.mo
-share/locale/zh_CN/LC_MESSAGES/easytag.mo
-share/locale/zh_TW/LC_MESSAGES/easytag.mo
+%%PORTDOCS%%%%DOCSDIR%%/HACKING
+%%PORTDOCS%%%%DOCSDIR%%/THANKS
+%%PORTDOCS%%%%DOCSDIR%%/TODO
share/icons/hicolor/128x128/apps/easytag.png
share/icons/hicolor/16x16/apps/easytag.png
share/icons/hicolor/256x256/apps/easytag.png
@@ -35,6 +11,47 @@ share/icons/hicolor/32x32/apps/easytag.png
share/icons/hicolor/48x48/apps/easytag.png
share/icons/hicolor/64x64/apps/easytag.png
share/icons/hicolor/scalable/apps/easytag.svg
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@dirrm %%DOCSDIR%%
+%%NLS%%share/locale/bg/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/da/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/de/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/el/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/es/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/he/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/it/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/sr@Latn/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/sr@latin/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/easytag.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/easytag.mo
+%%NLS%%@dirrmtry share/locale/sr@latin/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/sr@latin
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/256x256/apps
+@dirrmtry share/icons/hicolor/256x256
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor/128x128/apps
+@dirrmtry share/icons/hicolor/128x128
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+%%PORTDOCS%%@dirrm %%DOCSDIR%%