aboutsummaryrefslogtreecommitdiff
path: root/audio/ecasound
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2001-08-24 17:04:29 +0000
committerPeter Pentchev <roam@FreeBSD.org>2001-08-24 17:04:29 +0000
commitd010fd5acb41ed048778a1f3c04fe5d4940b1e65 (patch)
tree106d6db7ce8ebeb60fae8c04122a4bb5017d5674 /audio/ecasound
parentf7238cf741c6f50109dcb22f1a4fb0e7f14f2a83 (diff)
downloadports-d010fd5acb41ed048778a1f3c04fe5d4940b1e65.tar.gz
ports-d010fd5acb41ed048778a1f3c04fe5d4940b1e65.zip
Notes
Diffstat (limited to 'audio/ecasound')
-rw-r--r--audio/ecasound/Makefile36
-rw-r--r--audio/ecasound/distinfo2
-rw-r--r--audio/ecasound/pkg-plist24
3 files changed, 44 insertions, 18 deletions
diff --git a/audio/ecasound/Makefile b/audio/ecasound/Makefile
index 59c5e539da9c..9430610ed685 100644
--- a/audio/ecasound/Makefile
+++ b/audio/ecasound/Makefile
@@ -1,18 +1,18 @@
# New ports collection makefile for: ecasound
# Date created: 22 dec 2000
-# Whom: The Anarcat <anarcat@tao.ca>
+# Whom: The Anarcat <anarcat@anarcat.dyndns.org>
#
# $FreeBSD$
#
PORTNAME= ecasound
-PORTVERSION= 1.9dev5
+PORTVERSION= 2.0.2
CATEGORIES= audio
MASTER_SITES= http://ecasound.seul.org/download/ \
${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ecawave
+MASTER_SITE_SUBDIR= ecasound
-MAINTAINER= anarcat@tao.ca
+MAINTAINER= anarcat@anarcat.dyndns.org
USE_GMAKE= yes
USE_AUTOMAKE= yes
@@ -39,18 +39,32 @@ LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
CONFIGURE_ARGS+= --disable-audiofile
.endif
-.if defined(WITH_PYECASOUND)
-USE_PYTHON= yes
-PLIST_SUB+= WITH_PYECASOUND=""
-.else
-CONFIGURE_ARGS+= --disable-pyecasound
-PLIST_SUB+= WITH_PYECASOUND="@comment "
-.endif
+#.if defined(WITH_PYECASOUND)
+#USE_PYTHON= yes
+#PLIST_SUB+= WITH_PYECASOUND=""
+#.else
+#CONFIGURE_ARGS+= --disable-pyecasound
+#PLIST_SUB+= WITH_PYECASOUND="@comment "
+#.endif
MAN1= ecasound-iam.1 ecasound.1 ecatools.1
MAN5= ecasoundrc.5
#post-install:
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ecasound
+ ${MKDIR} ${PREFIX}/share/doc/ecasound/programmers_guide
+ ${MKDIR} ${PREFIX}/share/doc/ecasound/users_guide
+ ${INSTALL_MAN} ${WRKSRC}/Documentation/*.html \
+ ${WRKSRC}/Documentation/*.txt \
+ ${PREFIX}/share/doc/ecasound
+ ${INSTALL_MAN} ${WRKSRC}/Documentation/programmers_guide/*.html \
+ ${PREFIX}/share/doc/ecasound/programmers_guide
+ ${INSTALL_MAN} ${WRKSRC}/Documentation/users_guide/*.html \
+ ${PREFIX}/share/doc/ecasound/users_guide
+.endif
+
# strip ${PREFIX}/bin/ecaconvert ${PREFIX}/bin/ecafixdc \
#${PREFIX}/bin/ecanormalize ${PREFIX}/bin/ecaplay ${PREFIX}/bin/ecasignalview \
#${PREFIX}/bin/ecasound ${PREFIX}/bin/ecasound-config ${PREFIX}/bin/ecasoundc-config
diff --git a/audio/ecasound/distinfo b/audio/ecasound/distinfo
index 03fdf168d3d2..bb866a06f594 100644
--- a/audio/ecasound/distinfo
+++ b/audio/ecasound/distinfo
@@ -1 +1 @@
-MD5 (ecasound-1.9dev5.tar.gz) = 2bfe0c4bf28a036c56333da28c5b8c20
+MD5 (ecasound-2.0.2.tar.gz) = 33e42f52792bfebfe44b06879493631f
diff --git a/audio/ecasound/pkg-plist b/audio/ecasound/pkg-plist
index f2ae1b5fa175..0fd2d8960fdd 100644
--- a/audio/ecasound/pkg-plist
+++ b/audio/ecasound/pkg-plist
@@ -79,8 +79,8 @@ include/ecasound/ecasoundc.h
include/ecasound/file-preset.h
include/ecasound/finite-envelope.h
include/ecasound/generic-controller.h
+include/ecasound/generic-linear-envelope.h
include/ecasound/global-preset.h
-include/ecasound/ladspa.h
include/ecasound/layer.h
include/ecasound/linear-envelope.h
include/ecasound/midi-cc.h
@@ -126,15 +126,27 @@ lib/libecasound.so
lib/libecasound.so.7
lib/libecasoundc.a
lib/libecasoundc.so
-lib/libecasoundc.so.0
+lib/libecasoundc.so.1
lib/libkvutils.a
lib/libkvutils.so
lib/libkvutils.so.2
share/ecasound/effect_presets
share/ecasound/generic_oscillators
-%%WITH_PYECASOUND%%lib/%%PYTHON_VERSION%%/site-packages/libpyecasound.so
-%%WITH_PYECASOUND%%lib/%%PYTHON_VERSION%%/site-packages/pyeca.py
-@dirrm share/ecasound
-@dirrm lib/ecasound-plugins
+%%PORTDOCS%%share/doc/ecasound/ecasound-iam_manpage.html
+%%PORTDOCS%%share/doc/ecasound/ecasound_faq.html
+%%PORTDOCS%%share/doc/ecasound/ecasound_faq.txt
+%%PORTDOCS%%share/doc/ecasound/ecasound_manpage.html
+%%PORTDOCS%%share/doc/ecasound/ecasoundrc_manpage.html
+%%PORTDOCS%%share/doc/ecasound/ecatools_manpage.html
+%%PORTDOCS%%share/doc/ecasound/examples.html
+%%PORTDOCS%%share/doc/ecasound/index.html
+%%PORTDOCS%%share/doc/ecasound/programmers_guide/eci_doc.html
+%%PORTDOCS%%share/doc/ecasound/programmers_guide/programmers_guide.html
+%%PORTDOCS%%share/doc/ecasound/users_guide/users_guide.html
+%%PORTDOCS%%@dirrm share/doc/ecasound/programmers_guide
+%%PORTDOCS%%@dirrm share/doc/ecasound/users_guide
+%%PORTDOCS%%@dirrm share/doc/ecasound/
@dirrm include/ecasound
@dirrm include/kvutils
+@dirrm lib/ecasound-plugins
+@dirrm share/ecasound