aboutsummaryrefslogtreecommitdiff
path: root/audio/ecasound
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-08-06 05:38:13 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-08-06 05:38:13 +0000
commitd3e42040773960ddf1629c4d76fb5b126d5ac193 (patch)
tree178666ba372b64b14b5ab1ee38900a1781b2c62a /audio/ecasound
parent182ebbde04f979b6a0ce3ac2d55ac75926ffe41c (diff)
downloadports-d3e42040773960ddf1629c4d76fb5b126d5ac193.tar.gz
ports-d3e42040773960ddf1629c4d76fb5b126d5ac193.zip
- Depend on readline port if library exists
program will link it rather than a system one PR: ports/101437 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Notes
Notes: svn path=/head/; revision=169795
Diffstat (limited to 'audio/ecasound')
-rw-r--r--audio/ecasound/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/audio/ecasound/Makefile b/audio/ecasound/Makefile
index 731211c1e0e5..f04a9c635aef 100644
--- a/audio/ecasound/Makefile
+++ b/audio/ecasound/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ecasound
PORTVERSION= 2.4.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://ecasound.seul.org/download/
@@ -16,7 +16,7 @@ COMMENT= Multitrack audio processing software
USE_GNOME= gnometarget
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-pyecasound --disable-rubyecasound --with-largefile \
--enable-sys-readline
@@ -32,8 +32,11 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
+.if ${OSVERSION} < 500000 || exists(${LOCALBASE}/lib/libreadline.so.5)
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.endif
+
+.if ${OSVERSION} < 500000
CFLAGS+= -fpermissive
.endif