aboutsummaryrefslogtreecommitdiff
path: root/audio/epos-devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-07-16 05:48:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-07-16 05:48:14 +0000
commit54659968ea246646b844219fb0e58aa67d4669c3 (patch)
treea73c25801d8712f65ae322261161e6c1ce8d2bc8 /audio/epos-devel
parent8d5f3c22d7b6dd3499c20b6a148d1645d7f997aa (diff)
downloadports-54659968ea246646b844219fb0e58aa67d4669c3.tar.gz
ports-54659968ea246646b844219fb0e58aa67d4669c3.zip
- Fix build clang
PR: 180516 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=323095
Diffstat (limited to 'audio/epos-devel')
-rw-r--r--audio/epos-devel/Makefile15
-rw-r--r--audio/epos-devel/files/patch-src__nnet__map.h11
-rw-r--r--audio/epos-devel/files/patch-src__nnet__neural_parse.yy11
3 files changed, 28 insertions, 9 deletions
diff --git a/audio/epos-devel/Makefile b/audio/epos-devel/Makefile
index 78d274dfa20f..06436c55231b 100644
--- a/audio/epos-devel/Makefile
+++ b/audio/epos-devel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: epos-devel
-# Date created: 3 September 2005
-# Whom: Martin Matuska <mm@FreeBSD.org>
-#
+# Created by: Martin Matuska <mm@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= epos
PORTVERSION= 2.5.37
@@ -15,14 +11,15 @@ COMMENT= Text-to-Speech system
LICENSE= GPLv2 LGPL20
LICENSE_COMB= multi
-LICENSE_FILE_GPLv2= ${WRKSRC}/doc/COPYING
-LICENSE_FILE_LGPL20= ${WRKSRC}/libs/regex/COPYING.LIB
+USES= bison gmake
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+CONFIGURE_ENV= ac_cv_lib_stdcpp_main=no
MAKE_JOBS_SAFE= yes
post-patch:
- ${REINPLACE_CMD} -e 's/^\(SUBDIRS =.*\)doc/\1/' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's/^\(SUBDIRS =.*\)doc/\1/' ${WRKSRC}/Makefile.in
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|-ggdb||'
.include <bsd.port.mk>
diff --git a/audio/epos-devel/files/patch-src__nnet__map.h b/audio/epos-devel/files/patch-src__nnet__map.h
new file mode 100644
index 000000000000..17fb6bdf7d8b
--- /dev/null
+++ b/audio/epos-devel/files/patch-src__nnet__map.h
@@ -0,0 +1,11 @@
+--- src/nnet/map.h.orig
++++ src/nnet/map.h
+@@ -25,7 +25,7 @@
+ else {
+ TData x;
+ x.first() = key;
+- return insert (x)->second();
++ return this->insert (x)->second();
+ }
+ }
+
diff --git a/audio/epos-devel/files/patch-src__nnet__neural_parse.yy b/audio/epos-devel/files/patch-src__nnet__neural_parse.yy
new file mode 100644
index 000000000000..e7f49d56490e
--- /dev/null
+++ b/audio/epos-devel/files/patch-src__nnet__neural_parse.yy
@@ -0,0 +1,11 @@
+--- src/nnet/neural_parse.yy.orig
++++ src/nnet/neural_parse.yy
+@@ -255,7 +255,7 @@
+
+ int yyerror (char *s)
+ {
+- shriek (812, fmt ("BISON:yyerror:bison_nnet parser: bison_row %i (not counting empty rows) '%s' is erroneous. %s\n", row_num, bison_row_buf, s));
++ shriek (812, fmt ("BISON:yyerror:bison_nnet parser: bison_row %i (not counting empty rows) '%s' is erroneous. %s\n", row_num, bison_row_buf.c_str(), s));
+ return -1;
+ }
+