aboutsummaryrefslogtreecommitdiff
path: root/audio/espeak
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2015-02-09 14:32:16 +0000
committerNicola Vitale <nivit@FreeBSD.org>2015-02-09 14:32:16 +0000
commitf96893e5cabbcafd3122b68f0bb4729e01a03c8e (patch)
tree06dbce16180d4d9f9f46893af1e611748731c855 /audio/espeak
parent1c6d1c7331e706dcc84787167fac6c6e69bddf8c (diff)
downloadports-f96893e5cabbcafd3122b68f0bb4729e01a03c8e.tar.gz
ports-f96893e5cabbcafd3122b68f0bb4729e01a03c8e.zip
- Update to 1.48.04
- Use option helpers - Use a compiler understanding C++0X when PULSEAUDIO option is ON [1] PR: 195264 [1] Submitted by: Lawrence Chen <beastie@tardisi.com>
Notes
Notes: svn path=/head/; revision=378732
Diffstat (limited to 'audio/espeak')
-rw-r--r--audio/espeak/Makefile35
-rw-r--r--audio/espeak/distinfo4
-rw-r--r--audio/espeak/pkg-plist15
3 files changed, 30 insertions, 24 deletions
diff --git a/audio/espeak/Makefile b/audio/espeak/Makefile
index 220eaf0f2e94..4066dc171b2c 100644
--- a/audio/espeak/Makefile
+++ b/audio/espeak/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= espeak
-PORTVERSION= 1.47.11
+PORTVERSION= 1.48.04
PORTREVISION= 0
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
@@ -13,10 +13,6 @@ COMMENT= Software speech synthesizer
LICENSE= GPLv3
-# default is runtime audio detection
-LIB_DEPENDS= ${PORTAUDIOLIB} \
- ${PULSEAUDIOLIB}
-
OPTIONS_DEFINE= DOCS
OPTIONS_DEFAULT= PORTAUDIO
OPTIONS_RADIO= AUDIO_SYSTEM
@@ -26,11 +22,22 @@ RUNTIME_DESC= Sound interface selected at runtime
PORTAUDIOLIB= libportaudio.so.0:${PORTSDIR}/audio/portaudio
PULSEAUDIOLIB= libpulse.so:${PORTSDIR}/audio/pulseaudio
+PORTAUDIO_LIB_DEPENDS= ${PORTAUDIOLIB}
+PULSEAUDIO_LIB_DEPENDS= ${PULSEAUDIOLIB}
+RUNTIME_LIB_DEPENDS= ${PORTAUDIOLIB} \
+ ${PULSEAUDIOLIB}
+
+PULSEAUDIO_USES= compiler:c++0x
+RUNTIME_USES= compiler:c++0x
+
+PULSEAUDIO_MAKE_ENV= AUDIO="pulseaudio"
+PORTAUDIO_MAKE_ENV= AUDIO="portaudio"
+RUNTIME_MAKE_ENV= AUDIO="runtime"
+
CONFLICTS= speak-1.[0-9]
MAKE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}" \
- AUDIO="${AUDIO}"
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
CXXFLAGS+= -I${LOCALBASE}/include
USES= gmake zip
@@ -45,20 +52,6 @@ REINPLACE_ARGS= -i.bak -e "s|%%DATADIR%%|${DATADIR}|g"
BROKEN_sparc64= Does not compile on sparc64
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MRUNTIME}
-AUDIO= "runtime"
-.endif
-.if ${PORT_OPTIONS:MPULSEAUDIO}
-AUDIO= "pulseaudio"
-PORTAUDIOLIB=
-.endif
-.if ${PORT_OPTIONS:MPORTAUDIO}
-AUDIO= "portaudio"
-PULSEAUDIOLIB=
-.endif
-
post-patch:
cd ${BUILD_WRKSRC} && ${REINPLACE_CMD} ${REINPLACE_FILES}
diff --git a/audio/espeak/distinfo b/audio/espeak/distinfo
index 4672080f9f2e..434d826f7654 100644
--- a/audio/espeak/distinfo
+++ b/audio/espeak/distinfo
@@ -1,2 +1,2 @@
-SHA256 (espeak-1.47.11-source.zip) = 9bd4d0569af48a2cb13fa76704dec3124d27025a3f21c87598457976472b360c
-SIZE (espeak-1.47.11-source.zip) = 2813649
+SHA256 (espeak-1.48.04-source.zip) = bf9a17673adffcc28ff7ea18764f06136547e97bbd9edf2ec612f09b207f0659
+SIZE (espeak-1.48.04-source.zip) = 3019245
diff --git a/audio/espeak/pkg-plist b/audio/espeak/pkg-plist
index 5243cfa6228a..6cb80f5ae78c 100644
--- a/audio/espeak/pkg-plist
+++ b/audio/espeak/pkg-plist
@@ -3,7 +3,7 @@ include/espeak/speak_lib.h
lib/libespeak.a
lib/libespeak.so
lib/libespeak.so.1
-lib/libespeak.so.1.1.47
+lib/libespeak.so.1.1.48
%%PORTDOCS%%%%DOCSDIR%%/add_language.html
%%PORTDOCS%%%%DOCSDIR%%/analyse.html
%%PORTDOCS%%%%DOCSDIR%%/commands.html
@@ -25,6 +25,7 @@ lib/libespeak.so.1.1.47
%%DATADIR%%/espeak-data/af_dict
%%DATADIR%%/espeak-data/am_dict
%%DATADIR%%/espeak-data/an_dict
+%%DATADIR%%/espeak-data/as_dict
%%DATADIR%%/espeak-data/az_dict
%%DATADIR%%/espeak-data/bg_dict
%%DATADIR%%/espeak-data/bn_dict
@@ -38,11 +39,14 @@ lib/libespeak.so.1.1.47
%%DATADIR%%/espeak-data/eo_dict
%%DATADIR%%/espeak-data/es_dict
%%DATADIR%%/espeak-data/et_dict
+%%DATADIR%%/espeak-data/eu_dict
%%DATADIR%%/espeak-data/fa_dict
%%DATADIR%%/espeak-data/fi_dict
%%DATADIR%%/espeak-data/fr_dict
%%DATADIR%%/espeak-data/ga_dict
+%%DATADIR%%/espeak-data/gd_dict
%%DATADIR%%/espeak-data/grc_dict
+%%DATADIR%%/espeak-data/gu_dict
%%DATADIR%%/espeak-data/hbs_dict
%%DATADIR%%/espeak-data/hi_dict
%%DATADIR%%/espeak-data/hu_dict
@@ -58,6 +62,7 @@ lib/libespeak.so.1.1.47
%%DATADIR%%/espeak-data/ko_dict
%%DATADIR%%/espeak-data/ku_dict
%%DATADIR%%/espeak-data/la_dict
+%%DATADIR%%/espeak-data/lfn_dict
%%DATADIR%%/espeak-data/lt_dict
%%DATADIR%%/espeak-data/lv_dict
%%DATADIR%%/espeak-data/mbrola_ph/af1_phtrans
@@ -105,6 +110,7 @@ lib/libespeak.so.1.1.47
%%DATADIR%%/espeak-data/ne_dict
%%DATADIR%%/espeak-data/nl_dict
%%DATADIR%%/espeak-data/no_dict
+%%DATADIR%%/espeak-data/or_dict
%%DATADIR%%/espeak-data/pa_dict
%%DATADIR%%/espeak-data/pap_dict
%%DATADIR%%/espeak-data/phondata
@@ -232,6 +238,7 @@ lib/libespeak.so.1.1.47
%%DATADIR%%/espeak-data/voices/mb/mb-ic1
%%DATADIR%%/espeak-data/voices/mb/mb-id1
%%DATADIR%%/espeak-data/voices/mb/mb-ir1
+%%DATADIR%%/espeak-data/voices/mb/mb-ir2
%%DATADIR%%/espeak-data/voices/mb/mb-it3
%%DATADIR%%/espeak-data/voices/mb/mb-it4
%%DATADIR%%/espeak-data/voices/mb/mb-la1
@@ -264,14 +271,20 @@ lib/libespeak.so.1.1.47
%%DATADIR%%/espeak-data/voices/other/grc
%%DATADIR%%/espeak-data/voices/other/jbo
%%DATADIR%%/espeak-data/voices/other/la
+%%DATADIR%%/espeak-data/voices/other/lfn
%%DATADIR%%/espeak-data/voices/other/sw
%%DATADIR%%/espeak-data/voices/pt
%%DATADIR%%/espeak-data/voices/test/am
+%%DATADIR%%/espeak-data/voices/test/as
%%DATADIR%%/espeak-data/voices/test/az
%%DATADIR%%/espeak-data/voices/test/bn
+%%DATADIR%%/espeak-data/voices/test/eu
+%%DATADIR%%/espeak-data/voices/test/gd
+%%DATADIR%%/espeak-data/voices/test/gu
%%DATADIR%%/espeak-data/voices/test/kl
%%DATADIR%%/espeak-data/voices/test/ko
%%DATADIR%%/espeak-data/voices/test/nci
+%%DATADIR%%/espeak-data/voices/test/or
%%DATADIR%%/espeak-data/voices/test/pap
%%DATADIR%%/espeak-data/voices/test/si
%%DATADIR%%/espeak-data/voices/test/sl