aboutsummaryrefslogtreecommitdiff
path: root/audio/extace
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-05-23 09:47:27 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-05-23 09:47:27 +0000
commitd143f7e5ca5239cc7be12685b8a0231c06ceb38a (patch)
tree20d53a37b8d6866eef2e978d977a4c6fb98ecc77 /audio/extace
parente1431f76439f6edd29d5d93ff00a749eee59fb54 (diff)
downloadports-d143f7e5ca5239cc7be12685b8a0231c06ceb38a.tar.gz
ports-d143f7e5ca5239cc7be12685b8a0231c06ceb38a.zip
Notes
Diffstat (limited to 'audio/extace')
-rw-r--r--audio/extace/Makefile31
-rw-r--r--audio/extace/distinfo1
-rw-r--r--audio/extace/files/patch-aa11
-rw-r--r--audio/extace/pkg-comment1
-rw-r--r--audio/extace/pkg-descr7
-rw-r--r--audio/extace/pkg-plist2
6 files changed, 53 insertions, 0 deletions
diff --git a/audio/extace/Makefile b/audio/extace/Makefile
new file mode 100644
index 000000000000..7ab22abbddac
--- /dev/null
+++ b/audio/extace/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: extace
+# Date created: 8 April 2000
+# Whom: Maxim Sobolev
+#
+# $FreeBSD$
+#
+
+PORTNAME= extace
+PORTVERSION= 1.2.23
+CATEGORIES= audio
+MASTER_SITES= http://download.sourceforge.net/eXtace/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
+ esd.2:${PORTSDIR}/audio/esound \
+ fftw.2:${PORTSDIR}/math/fftw
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+ESD_CONFIG?= ${LOCALBASE}/bin/esd-config
+
+CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ ESD_CONFIG="${ESD_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/audio/extace/distinfo b/audio/extace/distinfo
new file mode 100644
index 000000000000..a8fd3b201f7b
--- /dev/null
+++ b/audio/extace/distinfo
@@ -0,0 +1 @@
+MD5 (extace-1.2.23.tar.gz) = 35f5dfa810bc7bd43bb40811a2e5ba77
diff --git a/audio/extace/files/patch-aa b/audio/extace/files/patch-aa
new file mode 100644
index 000000000000..7fc941847a01
--- /dev/null
+++ b/audio/extace/files/patch-aa
@@ -0,0 +1,11 @@
+--- configure.orig Mon Apr 10 15:41:18 2000
++++ configure Mon Apr 10 15:42:04 2000
+@@ -3619,7 +3619,7 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lgdk_imlib `gtk-config --libs` $LIBS"
++LIBS="-lgdk_imlib `$GTK_CONFIG --libs` $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 3625 "configure"
+ #include "confdefs.h"
diff --git a/audio/extace/pkg-comment b/audio/extace/pkg-comment
new file mode 100644
index 000000000000..f9f2610b21a8
--- /dev/null
+++ b/audio/extace/pkg-comment
@@ -0,0 +1 @@
+eXtace is a Audio Visualization plugin for the X-Window System
diff --git a/audio/extace/pkg-descr b/audio/extace/pkg-descr
new file mode 100644
index 000000000000..9a3f1a1c3901
--- /dev/null
+++ b/audio/extace/pkg-descr
@@ -0,0 +1,7 @@
+eXtace is a Audio Visualization plugin for the X-Window System. It connects to
+ESD (Enlightened Sound Daemon) and displays the audio data as either a 3D
+textured landscape, 3d pointed landscape, 16-256 channel graphic EQ, a
+multi-mode Oscilloscope, or a Spectragram. All modes are fully scalable to
+nearly ANY resolution!
+
+WWW: http://eXtace.sourceforge.net/
diff --git a/audio/extace/pkg-plist b/audio/extace/pkg-plist
new file mode 100644
index 000000000000..184a75c53d82
--- /dev/null
+++ b/audio/extace/pkg-plist
@@ -0,0 +1,2 @@
+bin/extace
+share/gnome/apps/Multimedia/extace.desktop