aboutsummaryrefslogtreecommitdiff
path: root/audio/ezstream
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-01-14 16:00:26 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-01-14 16:00:26 +0000
commit09ecaf226021f88e95e2da58b9951e1f410cb534 (patch)
tree6615efcc89934c445820a50fa10bbe9360c2ecee /audio/ezstream
parentda8adf524aa450101f2b64875be1053baa5d94fc (diff)
downloadports-09ecaf226021f88e95e2da58b9951e1f410cb534.tar.gz
ports-09ecaf226021f88e95e2da58b9951e1f410cb534.zip
- Add taglib support
PR: 130472 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=226097
Diffstat (limited to 'audio/ezstream')
-rw-r--r--audio/ezstream/Makefile55
-rw-r--r--audio/ezstream/pkg-descr24
2 files changed, 54 insertions, 25 deletions
diff --git a/audio/ezstream/Makefile b/audio/ezstream/Makefile
index bad86d73fd80..9eac217a99c6 100644
--- a/audio/ezstream/Makefile
+++ b/audio/ezstream/Makefile
@@ -7,40 +7,59 @@
PORTNAME= ezstream
PORTVERSION= 0.5.3
+PORTREVISION= 1
CATEGORIES= audio
-MASTER_SITES= http://svn.xiph.org/releases/ezstream/
+MASTER_SITES= http://downloads.xiph.org/releases/ezstream/
MAINTAINER= ports@FreeBSD.org
COMMENT= A command line utility for streaming to icecast servers
LIB_DEPENDS= shout.5:${PORTSDIR}/audio/libshout2 \
- vorbis.4:${PORTSDIR}/audio/libvorbis \
- xml2.5:${PORTSDIR}/textproc/libxml2
+ vorbis.4:${PORTSDIR}/audio/libvorbis
+OPTIONS= TAGLIB "TagLib support" on
+
+USE_GNOME= libxml2
+USE_ICONV= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
-LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
+MAN1= ezstream.1
+PORTDOCS= NEWS README
+PORTEXAMPLES= ezstream_metadata.xml ezstream_mp3.xml \
+ ezstream_reencode_mp3.xml ezstream_reencode_theora.xml \
+ ezstream_reencode_vorbis.xml ezstream_stdin_vorbis.xml \
+ ezstream_vorbis.xml meta.sh play.sh
+PLIST_FILES= bin/ezstream
-CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-PLIST_FILES= bin/ezstream
-PORTEXAMPLES= ezstream_metadata.xml ezstream_mp3.xml ezstream_reencode_mp3.xml \
- ezstream_reencode_theora.xml ezstream_reencode_vorbis.xml \
- ezstream_stdin_vorbis.xml ezstream_vorbis.xml meta.sh play.sh
+.include <bsd.port.pre.mk>
-MAN1= ezstream.1
+.if defined(WITHOUT_TAGLIB)
+CONFIGURE_ARGS+= --without-taglib
+.else
+LIB_DEPENDS+= tag.6:${PORTSDIR}/audio/taglib
+CONFIGURE_ARGS+= --with-taglib=${LOCALBASE}
+.endif
post-patch:
- ${REINPLACE_CMD} -e 's|COPYING NEWS README||g; s|examples||g; \
- s|install-dist_docDATA||g' ${WRKSRC}/Makefile.am ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s|examples||g ; \
+ s|: install-dist_docDATA|:|g' ${WRKSRC}/Makefile.in
-.if !defined(NOPORTEXAMPLES)
post-install:
- ${INSTALL} -d ${EXAMPLESDIR}
-.for ex in ${PORTEXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/examples/${ex} ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for file in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/examples/${file} ${EXAMPLESDIR}
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/ezstream/pkg-descr b/audio/ezstream/pkg-descr
index 200cf938cc8e..845de074aed8 100644
--- a/audio/ezstream/pkg-descr
+++ b/audio/ezstream/pkg-descr
@@ -1,8 +1,18 @@
-ezstream is a command line utility which is a improved version
-of the old "shout" utility. It enables you to stream mp3 or vorbis
-files to an icecast server without reencoding and thus requires
-very little CPU. ezstream is controlled via a XML config file.
-ezstream can stream mp3 and ogg vorbis files as well as reading
-from stdin. ID3v1 tags are supported in mp3 files and all ogg
-vorbis tags are propagated as metadata as well.
+Ezstream is a command line source client for Icecast media streaming servers.
+It began as the successor of the old "shout" utility, and has since gained a
+lot of useful features.
+
+In its basic mode of operation, it streams media files or data from standard
+input without reencoding and thus requires only very little CPU resources.
+It can also use various external decoders and encoders to reencode from one
+format to another, and stream the result to an Icecast server. Additional
+features include scriptable playlist and metadata handling. All of its
+features make ezstream a very flexible source client.
+
+Supported media formats for streaming are MP3, Ogg Vorbis and Ogg Theora.
+Native metadata support includes MP3 (ID3v1 only) and Ogg Vorbis, and many
+more formats when the optional TagLib support has been compiled in.
+
+Ezstream is free software and licensed under the GNU General Public License.
+
WWW: http://www.icecast.org/ezstream.php