aboutsummaryrefslogtreecommitdiff
path: root/audio/faad
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2017-11-01 15:36:02 +0000
committerThomas Zander <riggs@FreeBSD.org>2017-11-01 15:36:02 +0000
commit7bad0ac619c0ab61860316a5b1806b2a43bdb3c3 (patch)
treeb4d6e0065154901e3a0e78b6248321961388486c /audio/faad
parent6186431c53b685f6462fb05ae53bf432558af4f9 (diff)
downloadports-7bad0ac619c0ab61860316a5b1806b2a43bdb3c3.tar.gz
ports-7bad0ac619c0ab61860316a5b1806b2a43bdb3c3.zip
Update to upstream version 2.8.6
Notes
Notes: svn path=/head/; revision=453292
Diffstat (limited to 'audio/faad')
-rw-r--r--audio/faad/Makefile14
-rw-r--r--audio/faad/distinfo5
-rw-r--r--audio/faad/files/patch-common_mp4ff_Makefile.am10
-rw-r--r--audio/faad/files/patch-frontend_main.c258
-rw-r--r--audio/faad/pkg-plist4
5 files changed, 22 insertions, 269 deletions
diff --git a/audio/faad/Makefile b/audio/faad/Makefile
index 70b754244e17..0c5da42a4dcb 100644
--- a/audio/faad/Makefile
+++ b/audio/faad/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= faad2
-PORTVERSION= 2.7
-PORTREVISION= 6
+PORTVERSION= 2.8.6
PORTEPOCH= 1
CATEGORIES= audio
-MASTER_SITES= SF/faac/${PORTNAME}-src/${PORTNAME}-${PORTVERSION}
+MASTER_SITES= SF/faac/${PORTNAME}-src/${PORTNAME}-${PORTVERSION:R}.0
MAINTAINER= multimedia@FreeBSD.org
COMMENT= MPEG-2 and MPEG-4 AAC audio decoder
@@ -14,7 +13,9 @@ COMMENT= MPEG-2 and MPEG-4 AAC audio decoder
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= autoreconf gmake libtool tar:bzip2
+USES= autoreconf gmake libtool
+INSTALL_TARGET= install-strip
+
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -lpthread -L${LOCALBASE}/lib
@@ -24,8 +25,6 @@ post-extract:
@${LN} -sf faad.man ${WRKSRC}/frontend/faad.1
post-patch:
- @${REINPLACE_CMD} -e '/AC_CONFIG_FILES(plugins/d' \
- ${WRKSRC}/configure.in
@${REINPLACE_CMD} -e 's|faad.man|faad.1|g' \
${WRKSRC}/frontend/Makefile.am
@${REINPLACE_CMD} -e 's|^AM_CFLAGS|AM_CPPFLAGS|g ; \
@@ -38,7 +37,4 @@ post-patch:
post-configure:
@${REINPLACE_CMD} "s/444/644/g" ${WRKSRC}/common/mp4ff/Makefile
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libfaad.so.2
-
.include <bsd.port.mk>
diff --git a/audio/faad/distinfo b/audio/faad/distinfo
index a34f468e06a6..a92d009fb5a6 100644
--- a/audio/faad/distinfo
+++ b/audio/faad/distinfo
@@ -1,2 +1,3 @@
-SHA256 (faad2-2.7.tar.bz2) = 14561b5d6bc457e825bfd3921ae50a6648f377a9396eaf16d4b057b39a3f63b5
-SIZE (faad2-2.7.tar.bz2) = 901043
+TIMESTAMP = 1509541380
+SHA256 (faad2-2.8.6.tar.gz) = 654977adbf62eb81f4fca00152aca58ce3b6dd157181b9edd7bed687a7c73f21
+SIZE (faad2-2.8.6.tar.gz) = 1025654
diff --git a/audio/faad/files/patch-common_mp4ff_Makefile.am b/audio/faad/files/patch-common_mp4ff_Makefile.am
new file mode 100644
index 000000000000..dac68419d88b
--- /dev/null
+++ b/audio/faad/files/patch-common_mp4ff_Makefile.am
@@ -0,0 +1,10 @@
+--- common/mp4ff/Makefile.am.orig 2017-07-17 12:04:02 UTC
++++ common/mp4ff/Makefile.am
+@@ -1,5 +1,5 @@
+-noinst_LIBRARIES = libmp4ff.a
+-noinst_HEADERS = mp4ff.h mp4ffint.h
++lib_LIBRARIES = libmp4ff.a
++include_HEADERS = mp4ff.h mp4ffint.h
+
+ libmp4ff_a_CFLAGS = -DUSE_TAGGING=1
+
diff --git a/audio/faad/files/patch-frontend_main.c b/audio/faad/files/patch-frontend_main.c
deleted file mode 100644
index 6050cc55ad73..000000000000
--- a/audio/faad/files/patch-frontend_main.c
+++ /dev/null
@@ -1,258 +0,0 @@
---- frontend/main.c.orig 2008-09-22 17:55:09 UTC
-+++ frontend/main.c
-@@ -137,6 +137,31 @@ static void advance_buffer(aac_buffer *b
- b->bytes_into_buffer = 0;
- }
-
-+static void lookforheader(aac_buffer *b)
-+{
-+ int i = 0;
-+ while (!b->at_eof )
-+ {
-+ if (b->bytes_into_buffer > 4)
-+ {
-+ if( ((b->buffer[0+i] == 0xff) && ((b->buffer[1+i] & 0xf6) == 0xf0)) ||
-+ (b->buffer[0+i] == 'A' && b->buffer[1+i] == 'D' && b->buffer[2+i] == 'I' && b->buffer[3+i] == 'F'))
-+ {
-+ fill_buffer(b);
-+ break;
-+ } else {
-+ i++;
-+ b->file_offset += 1;
-+ b->bytes_consumed += 1;
-+ b->bytes_into_buffer -= 1;
-+ }
-+ } else {
-+ fill_buffer(b);
-+ i = 0;
-+ }
-+ }
-+}
-+
- static int adts_sample_rates[] = {96000,88200,64000,48000,44100,32000,24000,22050,16000,12000,11025,8000,7350,0,0,0};
-
- static int adts_parse(aac_buffer *b, int *bitrate, float *length)
-@@ -424,6 +449,8 @@ static int decodeAACfile(char *aacfile,
- float length = 0;
-
- int first_time = 1;
-+ int retval;
-+ int streaminput = 0;
-
- aac_buffer b;
-
-@@ -439,17 +466,39 @@ static int decodeAACfile(char *aacfile,
- }
- }
-
-- b.infile = fopen(aacfile, "rb");
-- if (b.infile == NULL)
-+ if (0 == strcmp(aacfile, "-"))
- {
-- /* unable to open file */
-- faad_fprintf(stderr, "Error opening file: %s\n", aacfile);
-- return 1;
-+ b.infile = stdin;
-+#ifdef _WIN32
-+ setmode(fileno(stdin), O_BINARY);
-+#endif
-+
-+ } else
-+ {
-+ b.infile = fopen(aacfile, "rb");
-+ if (b.infile == NULL)
-+ {
-+ /* unable to open file */
-+ faad_fprintf(stderr, "Error opening file: %s\n", aacfile);
-+ return 1;
-+ }
- }
-
-- fseek(b.infile, 0, SEEK_END);
-- fileread = ftell(b.infile);
-- fseek(b.infile, 0, SEEK_SET);
-+ retval = fseek(b.infile, 0, SEEK_END);
-+#ifdef _WIN32
-+ if (0 == strcmp(aacfile, "-")) {
-+ retval = -1;
-+ }
-+#endif
-+ if (retval )
-+ {
-+ faad_fprintf(stderr, "Input not seekable %s\n", aacfile);
-+ fileread = -1;
-+ streaminput = 1;
-+ } else {
-+ fileread = ftell(b.infile);
-+ fseek(b.infile, 0, SEEK_SET);
-+ };
-
- if (!(b.buffer = (unsigned char*)malloc(FAAD_MIN_STREAMSIZE*MAX_CHANNELS)))
- {
-@@ -494,19 +543,39 @@ static int decodeAACfile(char *aacfile,
-
- /* get AAC infos for printing */
- header_type = 0;
-+ if (streaminput == 1 )
-+ lookforheader(&b);
-+
- if ((b.buffer[0] == 0xFF) && ((b.buffer[1] & 0xF6) == 0xF0))
- {
-- adts_parse(&b, &bitrate, &length);
-- fseek(b.infile, tagsize, SEEK_SET);
-+ if (streaminput ==1)
-+ {
-+ int frames, frame_length;
-+ int samplerate;
-+ float frames_per_sec, bytes_per_frame;
-+ samplerate = adts_sample_rates[(b.buffer[2]&0x3c)>>2];
-+ frame_length = ((((unsigned int)b.buffer[3] & 0x3)) << 11)
-+ | (((unsigned int)b.buffer[4]) << 3) | (b.buffer[5] >> 5);
-
-- bread = fread(b.buffer, 1, FAAD_MIN_STREAMSIZE*MAX_CHANNELS, b.infile);
-- if (bread != FAAD_MIN_STREAMSIZE*MAX_CHANNELS)
-- b.at_eof = 1;
-- else
-- b.at_eof = 0;
-- b.bytes_into_buffer = bread;
-- b.bytes_consumed = 0;
-- b.file_offset = tagsize;
-+ frames_per_sec = (float)samplerate/1024.0f;
-+ bytes_per_frame = (float)frame_length/(float)(1000);
-+ bitrate = (int)(8. * bytes_per_frame * frames_per_sec + 0.5);
-+ length = 1;
-+ faad_fprintf(stderr, "Streamed input format samplerate %d channels %d.\n",samplerate,channels);
-+
-+ } else {
-+ adts_parse(&b, &bitrate, &length);
-+ fseek(b.infile, tagsize, SEEK_SET);
-+
-+ bread = fread(b.buffer, 1, FAAD_MIN_STREAMSIZE*MAX_CHANNELS, b.infile);
-+ if (bread != FAAD_MIN_STREAMSIZE*MAX_CHANNELS)
-+ b.at_eof = 1;
-+ else
-+ b.at_eof = 0;
-+ b.bytes_into_buffer = bread;
-+ b.bytes_consumed = 0;
-+ b.file_offset = tagsize;
-+ }
-
- header_type = 1;
- } else if (memcmp(b.buffer, "ADIF", 4) == 0) {
-@@ -538,7 +607,8 @@ static int decodeAACfile(char *aacfile,
- if (b.buffer)
- free(b.buffer);
- NeAACDecClose(hDecoder);
-- fclose(b.infile);
-+ if (b.infile != stdin)
-+ fclose(b.infile);
- return 1;
- }
- advance_buffer(&b, bread);
-@@ -564,7 +634,8 @@ static int decodeAACfile(char *aacfile,
- if (infoOnly)
- {
- NeAACDecClose(hDecoder);
-- fclose(b.infile);
-+ if (b.infile != stdin)
-+ fclose(b.infile);
- if (b.buffer)
- free(b.buffer);
- return 0;
-@@ -621,7 +692,8 @@ static int decodeAACfile(char *aacfile,
- if (b.buffer)
- free(b.buffer);
- NeAACDecClose(hDecoder);
-- fclose(b.infile);
-+ if (b.infile != stdin)
-+ fclose(b.infile);
- return 0;
- }
- } else {
-@@ -662,7 +734,8 @@ static int decodeAACfile(char *aacfile,
- fclose(adtsFile);
- }
-
-- fclose(b.infile);
-+ if (b.infile != stdin)
-+ fclose(b.infile);
-
- if (!first_time && !adts_out)
- close_audio_file(aufile);
-@@ -750,6 +823,11 @@ static int decodeMP4file(char *mp4file,
- /* initialise the callback structure */
- mp4ff_callback_t *mp4cb = malloc(sizeof(mp4ff_callback_t));
-
-+ if (strcmp(mp4file, "-") == 0 ) {
-+ faad_fprintf(stderr, "Cannot open stdin for MP4 input \n");
-+ return 1;
-+ }
-+
- mp4File = fopen(mp4file, "rb");
- mp4cb->read = read_callback;
- mp4cb->seek = seek_callback;
-@@ -1016,6 +1094,7 @@ int main(int argc, char *argv[])
- int result;
- int infoOnly = 0;
- int writeToStdio = 0;
-+ int readFromStdin = 0;
- int object_type = LC;
- int def_srate = 0;
- int downMatrix = 0;
-@@ -1229,15 +1308,30 @@ int main(int argc, char *argv[])
- }
-
- /* check for mp4 file */
-- mp4file = 0;
-- hMP4File = fopen(aacFileName, "rb");
-- if (!hMP4File)
-- {
-- faad_fprintf(stderr, "Error opening file: %s\n", aacFileName);
-- return 1;
-+ if (0 == strcmp(aacFileName, "-")) {
-+ faad_fprintf(stderr, "Reading from stdin: %s\n", aacFileName);
-+ readFromStdin = 1;
-+ hMP4File = stdin;
-+#ifdef _WIN32
-+ setmode(fileno(stdin), O_BINARY);
-+#endif
-+
-+ } else {
-+
-+ mp4file = 0;
-+ hMP4File = fopen(aacFileName, "rb");
-+ if (!hMP4File)
-+ {
-+ faad_fprintf(stderr, "Error opening file: %s\n", aacFileName);
-+ return 1;
-+ }
- }
-+
- fread(header, 1, 8, hMP4File);
-- fclose(hMP4File);
-+
-+ if (! readFromStdin )
-+ fclose(hMP4File);
-+
- if (header[4] == 'f' && header[5] == 't' && header[6] == 'y' && header[7] == 'p')
- mp4file = 1;
-
-@@ -1246,6 +1340,18 @@ int main(int argc, char *argv[])
- result = decodeMP4file(aacFileName, audioFileName, adtsFileName, writeToStdio,
- outputFormat, format, downMatrix, noGapless, infoOnly, adts_out, &length);
- } else {
-+
-+ if (readFromStdin == 1) {
-+ ungetc(header[7],hMP4File);
-+ ungetc(header[6],hMP4File);
-+ ungetc(header[5],hMP4File);
-+ ungetc(header[4],hMP4File);
-+ ungetc(header[3],hMP4File);
-+ ungetc(header[2],hMP4File);
-+ ungetc(header[1],hMP4File);
-+ ungetc(header[0],hMP4File);
-+ }
-+
- result = decodeAACfile(aacFileName, audioFileName, adtsFileName, writeToStdio,
- def_srate, object_type, outputFormat, format, downMatrix, infoOnly, adts_out,
- old_format, &length);
diff --git a/audio/faad/pkg-plist b/audio/faad/pkg-plist
index 28478164cd7b..4c415e31c523 100644
--- a/audio/faad/pkg-plist
+++ b/audio/faad/pkg-plist
@@ -7,5 +7,9 @@ lib/libfaad.a
lib/libfaad.so
lib/libfaad.so.2
lib/libfaad.so.2.0.0
+lib/libfaad_drm.a
+lib/libfaad_drm.so
+lib/libfaad_drm.so.2
+lib/libfaad_drm.so.2.0.0
lib/libmp4ff.a
man/man1/faad.1.gz