aboutsummaryrefslogtreecommitdiff
path: root/audio/faad
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2018-07-07 13:30:07 +0000
committerThomas Zander <riggs@FreeBSD.org>2018-07-07 13:30:07 +0000
commitc31e361f726d7fa62ed4241a842d8ce4c54208d7 (patch)
tree9f40ad20915d0227ff51425da36c08f351cad2eb /audio/faad
parente83c57c6bdcb58d971221750dc3ccaf1a79ffb8f (diff)
downloadports-c31e361f726d7fa62ed4241a842d8ce4c54208d7.tar.gz
ports-c31e361f726d7fa62ed4241a842d8ce4c54208d7.zip
Notes
Diffstat (limited to 'audio/faad')
-rw-r--r--audio/faad/Makefile4
-rw-r--r--audio/faad/files/patch-frontend_mp4read.c13
2 files changed, 13 insertions, 4 deletions
diff --git a/audio/faad/Makefile b/audio/faad/Makefile
index d1063671ac89..fcb6b7d082d6 100644
--- a/audio/faad/Makefile
+++ b/audio/faad/Makefile
@@ -13,10 +13,6 @@ COMMENT= MPEG-2 and MPEG-4 AAC audio decoder
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_mips= fails to build: mp4read.c:(.text+0x87c): undefined reference to '__builtin_bswap16'
-BROKEN_mips64= fails to build: mp4read.c:(.text+0x87c): undefined reference to '__builtin_bswap16'
-BROKEN_powerpc64= fails to build: mp4read.o:(.text+0x714): undefined reference to '__builtin_bswap16'
-
USES= autoreconf gmake libtool
INSTALL_TARGET= install-strip
diff --git a/audio/faad/files/patch-frontend_mp4read.c b/audio/faad/files/patch-frontend_mp4read.c
new file mode 100644
index 000000000000..41cf82a33cae
--- /dev/null
+++ b/audio/faad/files/patch-frontend_mp4read.c
@@ -0,0 +1,13 @@
+Make sure WORDS_BIGENDIAN is available on big endian archs like
+powerpc{,64}.
+
+--- frontend/mp4read.c.orig 2018-06-26 06:56:37 UTC
++++ frontend/mp4read.c
+@@ -24,6 +24,7 @@
+ #include <time.h>
+ #include <limits.h>
+
++#include "config.h"
+ #include "unicode_support.h"
+ #include "mp4read.h"
+