aboutsummaryrefslogtreecommitdiff
path: root/audio/fapg
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-29 10:41:09 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-29 10:41:09 +0000
commit905d669bdd666dd615d1a35d177851ab79d576b1 (patch)
treea96518986b6caac031adc0e39a62cf9a914a1ae0 /audio/fapg
parentf9d671cff068987a2930510f4a9ad7866daa100c (diff)
downloadports-905d669bdd666dd615d1a35d177851ab79d576b1.tar.gz
ports-905d669bdd666dd615d1a35d177851ab79d576b1.zip
Notes
Diffstat (limited to 'audio/fapg')
-rw-r--r--audio/fapg/Makefile47
-rw-r--r--audio/fapg/distinfo3
-rw-r--r--audio/fapg/files/getopt.h82
-rw-r--r--audio/fapg/pkg-descr6
-rw-r--r--audio/fapg/pkg-plist4
5 files changed, 142 insertions, 0 deletions
diff --git a/audio/fapg/Makefile b/audio/fapg/Makefile
new file mode 100644
index 000000000000..bc8bd6dc9d4a
--- /dev/null
+++ b/audio/fapg/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: fapg
+# Date created: 2006-06-22
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fapg
+PORTVERSION= 0.35
+CATEGORIES= audio
+MASTER_SITES= http://royale.zerezo.com/${PORTNAME}/
+
+MAINTAINER= chinsan.tw@FreeBSD.org
+COMMENT= Fast Audio Playlist Generator
+
+MAKE_ARGS+= CC=${CC}
+USE_GETOPT_LONG=yes
+
+MAN1= fapg.1
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${OSVERSION} < 500000
+ @${REINPLACE_CMD} -e 's,g2,g2 -I${LOCALBASE}/include \
+ -L${LOCALBASE}/lib -lgnugetopt,' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '32 s,<,\",; 32 s,>,\",' \
+ ${WRKSRC}/fapg.c
+ @${CP} ${FILESDIR}/getopt.h ${WRKSRC}
+.endif
+
+do-build:
+ @cd ${WRKSRC} && ${MAKE} ${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/fapg.1 ${PREFIX}/man/man1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in COPYING README
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/fapg/distinfo b/audio/fapg/distinfo
new file mode 100644
index 000000000000..4b7e24204402
--- /dev/null
+++ b/audio/fapg/distinfo
@@ -0,0 +1,3 @@
+MD5 (fapg-0.35.tar.gz) = a23c2747fc977cce74a09167a0809e86
+SHA256 (fapg-0.35.tar.gz) = c5df6ddddd26ac93104960f86c41f8cd85a268cc9fe6ff5ff87841c64ef9e715
+SIZE (fapg-0.35.tar.gz) = 21886
diff --git a/audio/fapg/files/getopt.h b/audio/fapg/files/getopt.h
new file mode 100644
index 000000000000..67cdaf36ba3a
--- /dev/null
+++ b/audio/fapg/files/getopt.h
@@ -0,0 +1,82 @@
+/*-
+ * Copyright (c) 2000 The NetBSD Foundation, Inc.
+ * All rights reserved.
+ *
+ * This code is derived from software contributed to The NetBSD Foundation
+ * by Dieter Baron and Thomas Klausner.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ * 3. All advertising materials mentioning features or use of this software
+ * must display the following acknowledgement:
+ * This product includes software developed by the NetBSD
+ * Foundation, Inc. and its contributors.
+ * 4. Neither the name of The NetBSD Foundation nor the names of its
+ * contributors may be used to endorse or promote products derived
+ * from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE NETBSD FOUNDATION, INC. AND CONTRIBUTORS
+ * ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
+ * TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+ * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE FOUNDATION OR CONTRIBUTORS
+ * BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+ * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+ * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+ * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+ * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
+#ifndef _GETOPT_H_
+#define _GETOPT_H_
+
+#include <sys/cdefs.h>
+
+/*
+ * GNU-like getopt_long()/getopt_long_only() with 4.4BSD optreset extension.
+ * getopt() is declared here too for GNU programs.
+ */
+#define no_argument 0
+#define required_argument 1
+#define optional_argument 2
+
+struct option {
+ /* name of long option */
+ const char *name;
+ /*
+ * one of no_argument, required_argument, and optional_argument:
+ * whether option takes an argument
+ */
+ int has_arg;
+ /* if not NULL, set *flag to val when option found */
+ int *flag;
+ /* if flag not NULL, value to set *flag to; else return value */
+ int val;
+};
+
+__BEGIN_DECLS
+int getopt_long(int, char * const *, const char *,
+ const struct option *, int *);
+int getopt_long_only(int, char * const *, const char *,
+ const struct option *, int *);
+#ifndef _GETOPT_DECLARED
+#define _GETOPT_DECLARED
+int getopt(int, char * const [], const char *);
+
+extern char *optarg; /* getopt(3) external variables */
+extern int optind, opterr, optopt;
+#endif
+#ifndef _OPTRESET_DECLARED
+#define _OPTRESET_DECLARED
+extern int optreset; /* getopt(3) externalvariable */
+#endif
+__END_DECLS
+
+#endif /* !_GETOPT_H_ */
diff --git a/audio/fapg/pkg-descr b/audio/fapg/pkg-descr
new file mode 100644
index 000000000000..bb6943cb3e43
--- /dev/null
+++ b/audio/fapg/pkg-descr
@@ -0,0 +1,6 @@
+fapg is a tool to generate list of audio files (Wav, MP3, Ogg, etc) in various
+formats (M3U, PLS, HTML, etc).
+It is very usefull if you have a large amount of audio files and you want to
+quickly and frequently build a playlist.
+
+WWW: http://royale.zerezo.com/fapg/
diff --git a/audio/fapg/pkg-plist b/audio/fapg/pkg-plist
new file mode 100644
index 000000000000..8f33f57180df
--- /dev/null
+++ b/audio/fapg/pkg-plist
@@ -0,0 +1,4 @@
+bin/fapg
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%