aboutsummaryrefslogtreecommitdiff
path: root/audio/fapg
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-05-01 10:16:24 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-05-01 10:16:24 +0000
commitd0741281508e536b4a48382b5d086c1253487d91 (patch)
tree6e1441fe9ac8d0285c3724bff04726bc9bc17157 /audio/fapg
parent4dcd208df1fd1041a1ce617dc41447f30d7ab915 (diff)
downloadports-d0741281508e536b4a48382b5d086c1253487d91.tar.gz
ports-d0741281508e536b4a48382b5d086c1253487d91.zip
- Update to 0.41.
Notes
Notes: svn path=/head/; revision=212405
Diffstat (limited to 'audio/fapg')
-rw-r--r--audio/fapg/Makefile4
-rw-r--r--audio/fapg/distinfo6
-rw-r--r--audio/fapg/files/getopt.h82
-rw-r--r--audio/fapg/files/patch-fapg.c43
4 files changed, 49 insertions, 86 deletions
diff --git a/audio/fapg/Makefile b/audio/fapg/Makefile
index 97d72882727e..f512a12c292a 100644
--- a/audio/fapg/Makefile
+++ b/audio/fapg/Makefile
@@ -6,13 +6,15 @@
#
PORTNAME= fapg
-PORTVERSION= 0.38
+PORTVERSION= 0.41
CATEGORIES= audio
MASTER_SITES= http://royale.zerezo.com/${PORTNAME}/
MAINTAINER= chinsan@FreeBSD.org
COMMENT= Fast Audio Playlist Generator
+LIB_DEPENDS= uriparser:${PORTSDIR}/net/uriparser
+
MAKE_ARGS+= CC=${CC}
MAN1= fapg.1
diff --git a/audio/fapg/distinfo b/audio/fapg/distinfo
index 51b57ebbc407..6316d6a31f50 100644
--- a/audio/fapg/distinfo
+++ b/audio/fapg/distinfo
@@ -1,3 +1,3 @@
-MD5 (fapg-0.38.tar.gz) = 1f31463768853c301bee3cb99520a417
-SHA256 (fapg-0.38.tar.gz) = b02f14f21f53da7d7f1020313891ea12892a5385332e7610a4da58800880c548
-SIZE (fapg-0.38.tar.gz) = 23014
+MD5 (fapg-0.41.tar.gz) = 64be7045dfc0874a831e7d5fb5c435a4
+SHA256 (fapg-0.41.tar.gz) = 0c09229c1473999f5939770326d8294adfa1847ae3da5f0c7827747284fc54ae
+SIZE (fapg-0.41.tar.gz) = 94315
diff --git a/audio/fapg/files/getopt.h b/audio/fapg/files/getopt.h
deleted file mode 100644
index 67cdaf36ba3a..000000000000
--- a/audio/fapg/files/getopt.h
+++ /dev/null
@@ -1,82 +0,0 @@
-/*-
- * Copyright (c) 2000 The NetBSD Foundation, Inc.
- * All rights reserved.
- *
- * This code is derived from software contributed to The NetBSD Foundation
- * by Dieter Baron and Thomas Klausner.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- * 1. Redistributions of source code must retain the above copyright
- * notice, this list of conditions and the following disclaimer.
- * 2. Redistributions in binary form must reproduce the above copyright
- * notice, this list of conditions and the following disclaimer in the
- * documentation and/or other materials provided with the distribution.
- * 3. All advertising materials mentioning features or use of this software
- * must display the following acknowledgement:
- * This product includes software developed by the NetBSD
- * Foundation, Inc. and its contributors.
- * 4. Neither the name of The NetBSD Foundation nor the names of its
- * contributors may be used to endorse or promote products derived
- * from this software without specific prior written permission.
- *
- * THIS SOFTWARE IS PROVIDED BY THE NETBSD FOUNDATION, INC. AND CONTRIBUTORS
- * ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
- * TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
- * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE FOUNDATION OR CONTRIBUTORS
- * BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
- * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
- * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
- * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
- * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
- * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
- * POSSIBILITY OF SUCH DAMAGE.
- */
-
-#ifndef _GETOPT_H_
-#define _GETOPT_H_
-
-#include <sys/cdefs.h>
-
-/*
- * GNU-like getopt_long()/getopt_long_only() with 4.4BSD optreset extension.
- * getopt() is declared here too for GNU programs.
- */
-#define no_argument 0
-#define required_argument 1
-#define optional_argument 2
-
-struct option {
- /* name of long option */
- const char *name;
- /*
- * one of no_argument, required_argument, and optional_argument:
- * whether option takes an argument
- */
- int has_arg;
- /* if not NULL, set *flag to val when option found */
- int *flag;
- /* if flag not NULL, value to set *flag to; else return value */
- int val;
-};
-
-__BEGIN_DECLS
-int getopt_long(int, char * const *, const char *,
- const struct option *, int *);
-int getopt_long_only(int, char * const *, const char *,
- const struct option *, int *);
-#ifndef _GETOPT_DECLARED
-#define _GETOPT_DECLARED
-int getopt(int, char * const [], const char *);
-
-extern char *optarg; /* getopt(3) external variables */
-extern int optind, opterr, optopt;
-#endif
-#ifndef _OPTRESET_DECLARED
-#define _OPTRESET_DECLARED
-extern int optreset; /* getopt(3) externalvariable */
-#endif
-__END_DECLS
-
-#endif /* !_GETOPT_H_ */
diff --git a/audio/fapg/files/patch-fapg.c b/audio/fapg/files/patch-fapg.c
new file mode 100644
index 000000000000..ebfad5e3e95d
--- /dev/null
+++ b/audio/fapg/files/patch-fapg.c
@@ -0,0 +1,43 @@
+--- fapg.c.orig 2008-03-11 02:18:04.000000000 +0800
++++ fapg.c 2008-05-01 17:46:37.000000000 +0800
+@@ -1514,8 +1514,7 @@
+ break;
+ case FORMAT_HTML:
+ printf
+- ("<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Strict//EN\" \"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd\">%s%s<html>%s%s<head>%s<title>Playlist generated by FAPG "
+- VERSION
++ ("<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Strict//EN\" \"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd\">%s%s<html>%s%s<head>%s<title>Playlist generated by FAPG 0.41"
+ "</title>%s<meta http-equiv=\"Content-Type\" content=\"text/html; charset=iso-8859-1\" />%s<style type=\"text/css\">%s<!--%s%sbody,td,tr {%s font-family: Verdana, Arial, Helvetica, sans-serif;%s font-size: 12px;%s color: #000000;%s}%s%sbody {%s background: #ffffff;%s}%s%sth {%s text-align: center;%s background: #ffcccc;%s padding-left: 15px;%s padding-right: 15px;%s border: 1px #dd8888 solid;%s}%s%std {%s text-align: center;%s background: #eeeeee;%s padding-left: 15px;%s padding-right: 15px;%s border: 1px #cccccc solid;%s}%s%sh1 {%s font-size: 25px;%s}%s%sp {%s font-size: 10px;%s}%s%sa {%s color: #993333;%s text-decoration: none;%s}%s%sa:hover {%s text-decoration: underline;%s}%s%s-->%s</style>%s</head>%s%s<body>%s%s<h1>Playlist</h1>%s%s<table>%s<tr><th>Entry</th><th>Artist</th><th>Title</th><th>Length</th></tr>%s",
+ eol, eol, eol, eol, eol, eol, eol, eol, eol, eol, eol, eol,
+ eol, eol, eol, eol, eol, eol, eol, eol, eol, eol, eol, eol,
+@@ -1532,10 +1531,8 @@
+ strftime(timebuffer, 255, "%a %d %b %Y %T %z",
+ localtime(&zeit));
+ printf
+- ("<?xml version=\"1.0\" encoding=\"ISO-8859-1\"?>%s<!-- generator=\"FAPG "
+- VERSION
+- " -->%s<rss xmlns:itunes=\"http://www.itunes.com/DTDs/Podcast-1.0.dtd\" version=\"2.0\">%s <channel>%s\t<title>%s - %s - %s</title>%s\t<description>Directory Tree %s</description>%s\t<link>%s</link>%s\t<itunes:image href=\"%s/xml/podcast.jpg\"/>%s\t<lastBuildDate>%s</lastBuildDate>%s\t<generator>FAPG "
+- VERSION
++ ("<?xml version=\"1.0\" encoding=\"ISO-8859-1\"?>%s<!-- generator=\"FAPG 0.41"
++ " -->%s<rss xmlns:itunes=\"http://www.itunes.com/DTDs/Podcast-1.0.dtd\" version=\"2.0\">%s <channel>%s\t<title>%s - %s - %s</title>%s\t<description>Directory Tree %s</description>%s\t<link>%s</link>%s\t<itunes:image href=\"%s/xml/podcast.jpg\"/>%s\t<lastBuildDate>%s</lastBuildDate>%s\t<generator>FAPG 0.41"
+ "</generator>%s\t<image>%s\t\t<url>%s/podcast.jpg</url>%s\t\t<title>Server Logo</title>%s\t\t<link>%s</link>%s\t\t<description>Feed provided by FAPG. Click to visit.</description>%s\t</image>%s\t<itunes:owner>%s\t\t<itunes:name>Admin %s</itunes:name>%s\t\t<itunes:email>podcast@%s</itunes:email>%s\t</itunes:owner>%s\t<category>Various</category>%s\t<itunes:subtitle>Directory Tree %s</itunes:subtitle>%s\t<itunes:author>%s</itunes:author>%s\t<copyright>unknown</copyright>%s\t<language>%s</language>%s\t<itunes:explicit>No</itunes:explicit>%s\t<ttl>1800</ttl>%s",
+ eol, eol, eol, eol, hostname, dir, argv[optind], eol,
+ prefix, eol, base, eol, prefix, eol, timebuffer, eol, eol,
+@@ -1560,7 +1557,7 @@
+ #ifdef HAVE_LIBURIPARSER
+ case FORMAT_XSPF:
+ printf("<?xml version=\"1.0\" encoding=\"ISO-8859-1\"?>\n"
+- "<!-- generator=\"FAPG " VERSION " -->\n"
++ "<!-- generator=\"FAPG 0.41 -->\n"
+ "<playlist version=\"1\" xmlns=\"http://xspf.org/ns/0/\">\n"
+ "<trackList>\n");
+ break;
+@@ -1615,7 +1612,7 @@
+ case FORMAT_HTML:
+ printf
+ ("</table>%s%s<p>Playlist generated by <a href=\"http://royale.zerezo.com/fapg/\">FAPG "
+- VERSION "</a></p>%s%s</body>%s%s</html>", eol, eol, eol, eol,
++ "0.41</a></p>%s%s</body>%s%s</html>", eol, eol, eol, eol,
+ eol, eol);
+ break;
+ case FORMAT_RSS: