aboutsummaryrefslogtreecommitdiff
path: root/audio/faust-lv2
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-07-20 20:50:31 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-07-20 20:50:31 +0000
commitb4f52d112c61ab383371a9d777208a6ab1d0c329 (patch)
tree1357ca815d550b7dcb0f2dc0e24335deb3342763 /audio/faust-lv2
parent5936b0b76e238355d670195c64bfd0d1a59c854f (diff)
downloadports-b4f52d112c61ab383371a9d777208a6ab1d0c329.tar.gz
ports-b4f52d112c61ab383371a9d777208a6ab1d0c329.zip
New port: audio/faust-lv2: LV2 plugin architecture for the Faust programming language
PR: 221685
Notes
Notes: svn path=/head/; revision=475035
Diffstat (limited to 'audio/faust-lv2')
-rw-r--r--audio/faust-lv2/Makefile34
-rw-r--r--audio/faust-lv2/distinfo3
-rw-r--r--audio/faust-lv2/files/patch-Makefile20
-rw-r--r--audio/faust-lv2/pkg-descr14
-rw-r--r--audio/faust-lv2/pkg-plist71
5 files changed, 142 insertions, 0 deletions
diff --git a/audio/faust-lv2/Makefile b/audio/faust-lv2/Makefile
new file mode 100644
index 000000000000..809d92bd7936
--- /dev/null
+++ b/audio/faust-lv2/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= faust
+DISTVERSION= 1.4.20180118
+CATEGORIES= audio
+MASTER_SITES= https://bitbucket.org/${BB_ACCOUNT}/${BB_PROJECT}/get/${BB_COMMIT}.tar.gz?dummy=/
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= LV2 plugin architecture for the Faust programming language
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>0:audio/lv2 \
+ faust>0:audio/faust \
+ ${LOCALBASE}/include/boost/circular_buffer.hpp:devel/boost-libs
+
+USES= gmake localbase tar:bz2
+
+BB_ACCOUNT= agraef
+BB_PROJECT= faust-lv2
+BB_COMMIT= 4dc83e28e998
+
+WRKSRC= ${WRKDIR}/${BB_ACCOUNT}-${BB_PROJECT}-${BB_COMMIT}
+
+OPTIONS_DEFINE_amd64= SIMD
+OPTIONS_DEFINE_i386= SIMD
+OPTIONS_DEFAULT_amd64= SIMD
+OPTIONS_DEFAULT_i386= SIMD
+
+SIMD_CFLAGS= -msse -msse2 -mfpmath=sse
+
+.include <bsd.port.mk>
diff --git a/audio/faust-lv2/distinfo b/audio/faust-lv2/distinfo
new file mode 100644
index 000000000000..8f68b4410213
--- /dev/null
+++ b/audio/faust-lv2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532119503
+SHA256 (faust-1.4.20180118.tar.bz2) = 9218dcc7893e02d1df8bd9bbe6c015e6deff6718162e8b0781eea95f6478b5e5
+SIZE (faust-1.4.20180118.tar.bz2) = 123225
diff --git a/audio/faust-lv2/files/patch-Makefile b/audio/faust-lv2/files/patch-Makefile
new file mode 100644
index 000000000000..88ccb8ff549f
--- /dev/null
+++ b/audio/faust-lv2/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig 2018-07-20 20:26:02 UTC
++++ Makefile
+@@ -117,7 +117,7 @@ endif
+ #KEEP = true
+
+ # Default compilation flags.
+-CFLAGS = -O3
++CFLAGS ?= -O3
+ # Use this for debugging output instead.
+ #CFLAGS = -g -O2
+
+@@ -145,7 +145,7 @@ EXTRA_CFLAGS += -fPIC
+ endif
+ ifneq "$(findstring x86,$(host))" ""
+ # architecture-specific options for x86 and x86_64
+-EXTRA_CFLAGS += -msse -ffast-math
++EXTRA_CFLAGS += -ffast-math
+ endif
+
+ # DSP sources and derived files.
diff --git a/audio/faust-lv2/pkg-descr b/audio/faust-lv2/pkg-descr
new file mode 100644
index 000000000000..003d71868dac
--- /dev/null
+++ b/audio/faust-lv2/pkg-descr
@@ -0,0 +1,14 @@
+This project provides an LV2 plugin architecture for the Faust programming
+language. The package contains the Faust architecture and templates for the
+needed LV2 manifest (ttl) files, a collection of sample plugins written in
+Faust, and a generic GNU Makefile as well as a shell script to compile plugins
+using the architecture.
+
+faust-lv2 is free and open source software. The latest source can be found in
+the git repository at https://bitbucket.org/agraef/faust-lv2. In the downloads
+section of this site you can also find released tarballs along with my faust-lv2
+paper for the 2013 Linux Audio Conference. Please use the issue tracker for bug
+reports and requests. You're also invited to join one of Grame's Faust mailing
+lists to discuss faust-lv2 or Faust in general.
+
+WWW: https://bitbucket.org/agraef/faust-lv2
diff --git a/audio/faust-lv2/pkg-plist b/audio/faust-lv2/pkg-plist
new file mode 100644
index 000000000000..4d8a2dd1806d
--- /dev/null
+++ b/audio/faust-lv2/pkg-plist
@@ -0,0 +1,71 @@
+lib/lv2/faust.lv2/NLFeks.so
+lib/lv2/faust.lv2/NLFeks.ttl
+lib/lv2/faust.lv2/NLFfm.so
+lib/lv2/faust.lv2/NLFfm.ttl
+lib/lv2/faust.lv2/amp.so
+lib/lv2/faust.lv2/amp.ttl
+lib/lv2/faust.lv2/bass.so
+lib/lv2/faust.lv2/bass.ttl
+lib/lv2/faust.lv2/blowBottle.so
+lib/lv2/faust.lv2/blowBottle.ttl
+lib/lv2/faust.lv2/blowHole.so
+lib/lv2/faust.lv2/blowHole.ttl
+lib/lv2/faust.lv2/bowed.so
+lib/lv2/faust.lv2/bowed.ttl
+lib/lv2/faust.lv2/brass.so
+lib/lv2/faust.lv2/brass.ttl
+lib/lv2/faust.lv2/chimes.so
+lib/lv2/faust.lv2/chimes.ttl
+lib/lv2/faust.lv2/chorus.so
+lib/lv2/faust.lv2/chorus.ttl
+lib/lv2/faust.lv2/clarinet.so
+lib/lv2/faust.lv2/clarinet.ttl
+lib/lv2/faust.lv2/compressor.so
+lib/lv2/faust.lv2/compressor.ttl
+lib/lv2/faust.lv2/echo.so
+lib/lv2/faust.lv2/echo.ttl
+lib/lv2/faust.lv2/expander.so
+lib/lv2/faust.lv2/expander.ttl
+lib/lv2/faust.lv2/flanger.so
+lib/lv2/faust.lv2/flanger.ttl
+lib/lv2/faust.lv2/flute.so
+lib/lv2/faust.lv2/flute.ttl
+lib/lv2/faust.lv2/freeverb.so
+lib/lv2/faust.lv2/freeverb.ttl
+lib/lv2/faust.lv2/glassHarmonica.so
+lib/lv2/faust.lv2/glassHarmonica.ttl
+lib/lv2/faust.lv2/harpsi.so
+lib/lv2/faust.lv2/harpsi.ttl
+lib/lv2/faust.lv2/karplus.so
+lib/lv2/faust.lv2/karplus.ttl
+lib/lv2/faust.lv2/kisana.so
+lib/lv2/faust.lv2/kisana.ttl
+lib/lv2/faust.lv2/manifest.ttl
+lib/lv2/faust.lv2/modalBar.so
+lib/lv2/faust.lv2/modalBar.ttl
+lib/lv2/faust.lv2/organ.so
+lib/lv2/faust.lv2/organ.ttl
+lib/lv2/faust.lv2/phasemod.so
+lib/lv2/faust.lv2/phasemod.ttl
+lib/lv2/faust.lv2/piano.so
+lib/lv2/faust.lv2/piano.ttl
+lib/lv2/faust.lv2/saxophony.so
+lib/lv2/faust.lv2/saxophony.ttl
+lib/lv2/faust.lv2/sitar.so
+lib/lv2/faust.lv2/sitar.ttl
+lib/lv2/faust.lv2/subtractive.so
+lib/lv2/faust.lv2/subtractive.ttl
+lib/lv2/faust.lv2/tibetanBowl.so
+lib/lv2/faust.lv2/tibetanBowl.ttl
+lib/lv2/faust.lv2/tunedBar.so
+lib/lv2/faust.lv2/tunedBar.ttl
+lib/lv2/faust.lv2/uniBar.so
+lib/lv2/faust.lv2/uniBar.ttl
+lib/lv2/faust.lv2/voiceForm.so
+lib/lv2/faust.lv2/voiceForm.ttl
+lib/lv2/faust.lv2/wahwah.so
+lib/lv2/faust.lv2/wahwah.ttl
+lib/lv2/faust.lv2/waveshaper.so
+lib/lv2/faust.lv2/waveshaper.ttl
+lib/lv2/faust.lv2/zita_rev1.so
+lib/lv2/faust.lv2/zita_rev1.ttl