aboutsummaryrefslogtreecommitdiff
path: root/audio/faust
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-02-16 21:33:04 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-02-16 21:33:04 +0000
commit63e73c2bd13aaafd547bf8ba6dabcf6e84766e0d (patch)
tree551b99b8c49cefeed3db4072e3734e6cb4cd8e8c /audio/faust
parentfec756427e62d48be5b283b9f7f7eb2e2475e58b (diff)
downloadports-63e73c2bd13aaafd547bf8ba6dabcf6e84766e0d.tar.gz
ports-63e73c2bd13aaafd547bf8ba6dabcf6e84766e0d.zip
audio/faust: Update 2.27.2 -> 2.30.5
Notes
Notes: svn path=/head/; revision=565462
Diffstat (limited to 'audio/faust')
-rw-r--r--audio/faust/Makefile9
-rw-r--r--audio/faust/distinfo14
-rw-r--r--audio/faust/files/patch-architecture_faust_dsp_dsp-adapter.h15
-rw-r--r--audio/faust/files/patch-build_CMakeLists.txt4
-rw-r--r--audio/faust/pkg-plist37
5 files changed, 66 insertions, 13 deletions
diff --git a/audio/faust/Makefile b/audio/faust/Makefile
index 6be756987666..e13cbdc64fc0 100644
--- a/audio/faust/Makefile
+++ b/audio/faust/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= faust
-DISTVERSION= 2.27.2
+DISTVERSION= 2.30.5
CATEGORIES= audio devel
MAINTAINER= yuri@FreeBSD.org
@@ -12,14 +12,15 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING.txt
LIB_DEPENDS= libLLVM-${LLVM_VERSION:C/([1-9])([0-9])/\1/}.so:devel/llvm${LLVM_VERSION}
+RUN_DEPENDS= bash:shells/bash
USES= compiler:c++11-lang cmake ncurses python pkgconfig shebangfix
USE_GITHUB= yes
GH_ACCOUNT= grame-cncm
GH_TUPLE= \
- grame-cncm:faustlibraries:cde57d76dd8c4b124998a5490164e4b58ae9495f:grame_cncm_faustlibraries/libraries \
- google:oboe:f644b60eaf0deea5b9c7af443e28d42c4995b59e:google_oboe/architecture/android/app/oboe \
- google:oboe:f644b60eaf0deea5b9c7af443e28d42c4995b59e:google_oboe/architecture/smartKeyboard/android/app/oboe \
+ grame-cncm:faustlibraries:41b6ba7:grame_cncm_faustlibraries/libraries \
+ google:oboe:5eb2ea6:google_oboe/architecture/android/app/oboe \
+ google:oboe:5eb2ea6:google_oboe/architecture/smartKeyboard/android/app/oboe
SHEBANG_FILES= tools/faust2appls/* tools/benchmark/faustbench tools/sound2faust/sound2reader
diff --git a/audio/faust/distinfo b/audio/faust/distinfo
index 83eb60e1f720..421d6fafdc9a 100644
--- a/audio/faust/distinfo
+++ b/audio/faust/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1600719770
-SHA256 (grame-cncm-faust-2.27.2_GH0.tar.gz) = 3367a868a93b63582bae29ab8783f1df7a10f4084a2bc1d2258ebf3d6a8c31d7
-SIZE (grame-cncm-faust-2.27.2_GH0.tar.gz) = 70252522
-SHA256 (grame-cncm-faustlibraries-cde57d76dd8c4b124998a5490164e4b58ae9495f_GH0.tar.gz) = ef1275b819cc48d9297b43fc83acf6bf7ce0c39903007fbec9379056f5b2f995
-SIZE (grame-cncm-faustlibraries-cde57d76dd8c4b124998a5490164e4b58ae9495f_GH0.tar.gz) = 7140745
-SHA256 (google-oboe-f644b60eaf0deea5b9c7af443e28d42c4995b59e_GH0.tar.gz) = 5d10693fd849b318260d3c36175511f0f3b6deb2fc70e3e44430053b636fab53
-SIZE (google-oboe-f644b60eaf0deea5b9c7af443e28d42c4995b59e_GH0.tar.gz) = 5823831
+TIMESTAMP = 1613507928
+SHA256 (grame-cncm-faust-2.30.5_GH0.tar.gz) = 3bf05afb6bcbfe20912ed9dc12c194b566c025e7ef52acaa8165d425c2e96e56
+SIZE (grame-cncm-faust-2.30.5_GH0.tar.gz) = 67047334
+SHA256 (grame-cncm-faustlibraries-41b6ba7_GH0.tar.gz) = abe4d04d07b1df26750fc3e804a6e519aa1653bee2e8025369fc476c368efdb8
+SIZE (grame-cncm-faustlibraries-41b6ba7_GH0.tar.gz) = 7671741
+SHA256 (google-oboe-5eb2ea6_GH0.tar.gz) = 43156e8b77e091736665505a7adf52913f23bd276bec4ef97eae70662084296d
+SIZE (google-oboe-5eb2ea6_GH0.tar.gz) = 6107684
diff --git a/audio/faust/files/patch-architecture_faust_dsp_dsp-adapter.h b/audio/faust/files/patch-architecture_faust_dsp_dsp-adapter.h
new file mode 100644
index 000000000000..0f3c8282fb31
--- /dev/null
+++ b/audio/faust/files/patch-architecture_faust_dsp_dsp-adapter.h
@@ -0,0 +1,15 @@
+--- architecture/faust/dsp/dsp-adapter.h.orig 2021-02-16 21:19:00 UTC
++++ architecture/faust/dsp/dsp-adapter.h
+@@ -26,7 +26,11 @@
+ #define __dsp_adapter__
+
+ #ifndef _WIN32
+-#include <alloca.h>
++# ifndef __FreeBSD__
++# include <alloca.h>
++# else
++# include <stdlib.h>
++# endif
+ #endif
+ #include <string.h>
+ #include <iostream>
diff --git a/audio/faust/files/patch-build_CMakeLists.txt b/audio/faust/files/patch-build_CMakeLists.txt
index edf9488df8d6..e0d81ea9b5c0 100644
--- a/audio/faust/files/patch-build_CMakeLists.txt
+++ b/audio/faust/files/patch-build_CMakeLists.txt
@@ -1,4 +1,4 @@
---- build/CMakeLists.txt.orig 2020-08-03 13:32:44 UTC
+--- build/CMakeLists.txt.orig 2021-01-14 11:18:56 UTC
+++ build/CMakeLists.txt
@@ -53,7 +53,7 @@ endif()
@@ -9,7 +9,7 @@
file (GLOB HH ${SRCDIR}/*.hh ${SRCDIR}/*/*.hh ${SRCDIR}/generator/fir/*.hh)
####################################
-@@ -351,13 +351,15 @@ install (
+@@ -352,13 +352,15 @@ install (
####################################
# install examples
diff --git a/audio/faust/pkg-plist b/audio/faust/pkg-plist
index 1494cdcec73a..8354ef62e0bd 100644
--- a/audio/faust/pkg-plist
+++ b/audio/faust/pkg-plist
@@ -13,6 +13,7 @@ bin/faust2caqt
bin/faust2caqtios
bin/faust2csound
bin/faust2csvplot
+bin/faust2dplug
bin/faust2dssi
bin/faust2dummy
bin/faust2dummymem
@@ -69,6 +70,7 @@ bin/faust2svg
bin/faust2svgviewer
bin/faust2teensy
bin/faust2unity
+bin/faust2vcvrack
bin/faust2vst
bin/faust2vsti
bin/faust2w32max6
@@ -112,11 +114,13 @@ include/faust/dsp/dsp-adapter.h
include/faust/dsp/dsp-bench.h
include/faust/dsp/dsp-checker.h
include/faust/dsp/dsp-combiner.h
+include/faust/dsp/dsp-compute-adapter.h
include/faust/dsp/dsp-optimizer.h
include/faust/dsp/dsp-tools.h
include/faust/dsp/dsp.h
include/faust/dsp/fastmath.cpp
include/faust/dsp/faust-dynamic-engine.cpp
+include/faust/dsp/faust-dynamic-engine.cpp.orig
include/faust/dsp/faust-dynamic-engine.h
include/faust/dsp/faust-engine.h
include/faust/dsp/faust-poly-engine.h
@@ -127,6 +131,7 @@ include/faust/dsp/libfaust.h
include/faust/dsp/llvm-c-dsp.h
include/faust/dsp/llvm-dsp-adapter.h
include/faust/dsp/llvm-dsp-multi.h
+include/faust/dsp/llvm-dsp-multifun.h
include/faust/dsp/llvm-dsp.h
include/faust/dsp/llvm-machine-dsp.h
include/faust/dsp/one-sample-dsp.h
@@ -140,6 +145,7 @@ include/faust/dsp/soul-cpp-dsp.h
include/faust/dsp/soulpatch-dsp.h
include/faust/dsp/sound-player.h
include/faust/dsp/timed-dsp.h
+include/faust/dsp/timed-dsp.h.orig
include/faust/dsp/wasm-dsp-imp.h
include/faust/dsp/wasm-dsp.h
include/faust/gui/APIUI.h
@@ -149,6 +155,7 @@ include/faust/gui/CInterface.h
include/faust/gui/ControlUI.h
include/faust/gui/DecoratorUI.h
include/faust/gui/Esp32ControlUI.h
+include/faust/gui/Esp32Reader.h
include/faust/gui/Esp32SensorUI.h
include/faust/gui/FUI.h
include/faust/gui/GTKUI.h
@@ -162,6 +169,7 @@ include/faust/gui/JuceOSCUI.h
include/faust/gui/JuceParameterUI.h
include/faust/gui/JuceReader.h
include/faust/gui/JuceStateUI.h
+include/faust/gui/LayoutUI.h
include/faust/gui/LibsndfileReader.h
include/faust/gui/MapUI.h
include/faust/gui/MemoryReader.h
@@ -204,6 +212,7 @@ include/faust/midi/RtMidi.cpp
include/faust/midi/RtMidi.h
include/faust/midi/bela-midi.h
include/faust/midi/esp32-midi.h
+include/faust/midi/gramophone-midi.h
include/faust/midi/iplug2-midi.h
include/faust/midi/jack-midi.h
include/faust/midi/juce-midi.h
@@ -335,6 +344,7 @@ lib/libOSCFaust.a
%%DATADIR%%/basics.lib
%%DATADIR%%/bela.cpp
%%DATADIR%%/bench.cpp
+%%DATADIR%%/bench.d
%%DATADIR%%/c-jack-gtk.c
%%DATADIR%%/ca-qt.cpp
%%DATADIR%%/compressors.lib
@@ -358,6 +368,11 @@ lib/libOSCFaust.a
%%DATADIR%%/esp32/drivers/ac101/AC101.h
%%DATADIR%%/esp32/drivers/ac101/CMakeLists.txt
%%DATADIR%%/esp32/drivers/ac101/component.mk
+%%DATADIR%%/esp32/drivers/es8388/CMakeLists.txt
+%%DATADIR%%/esp32/drivers/es8388/adf_structs.h
+%%DATADIR%%/esp32/drivers/es8388/component.mk
+%%DATADIR%%/esp32/drivers/es8388/es8388.cpp
+%%DATADIR%%/esp32/drivers/es8388/es8388.h
%%DATADIR%%/esp32/drivers/wm8978/CMakeLists.txt
%%DATADIR%%/esp32/drivers/wm8978/README.md
%%DATADIR%%/esp32/drivers/wm8978/WM8978.cpp
@@ -365,6 +380,17 @@ lib/libOSCFaust.a
%%DATADIR%%/esp32/drivers/wm8978/component.mk
%%DATADIR%%/esp32/esp32.cpp
%%DATADIR%%/esp32/esp32.h
+%%DATADIR%%/esp32/gramo-bt-midi/CMakeLists.txt
+%%DATADIR%%/esp32/gramo-bt-midi/Makefile
+%%DATADIR%%/esp32/gramo-bt-midi/components/blemidi/CMakeLists.txt
+%%DATADIR%%/esp32/gramo-bt-midi/components/blemidi/README.md
+%%DATADIR%%/esp32/gramo-bt-midi/components/blemidi/blemidi.c
+%%DATADIR%%/esp32/gramo-bt-midi/components/blemidi/component.mk
+%%DATADIR%%/esp32/gramo-bt-midi/components/blemidi/include/blemidi.h
+%%DATADIR%%/esp32/gramo-bt-midi/main/CMakeLists.txt
+%%DATADIR%%/esp32/gramo-bt-midi/main/component.mk
+%%DATADIR%%/esp32/gramo-bt-midi/sdkconfig
+%%DATADIR%%/esp32/gramo-bt-midi/sdkconfig-bt
%%DATADIR%%/esp32/gramophone-multi.cpp
%%DATADIR%%/esp32/gramophone.cpp
%%DATADIR%%/esp32/volume.dsp
@@ -373,6 +399,7 @@ lib/libOSCFaust.a
%%DATADIR%%/faustui.js
%%DATADIR%%/faustvst.cpp
%%DATADIR%%/faustvstqt.h
+%%DATADIR%%/fds.lib
%%DATADIR%%/filter.lib
%%DATADIR%%/filters.lib
%%DATADIR%%/gen-json.cpp
@@ -576,12 +603,16 @@ lib/libOSCFaust.a
%%DATADIR%%/maxmsp.lib
%%DATADIR%%/mi.lib
%%DATADIR%%/minimal-bench.cpp
+%%DATADIR%%/minimal-dplug.d
+%%DATADIR%%/minimal-effect.c
%%DATADIR%%/minimal-effect.cpp
%%DATADIR%%/minimal-jack.rs
+%%DATADIR%%/minimal-params.d
%%DATADIR%%/minimal-portaudio.rs
%%DATADIR%%/minimal-static.cpp
%%DATADIR%%/minimal.c
%%DATADIR%%/minimal.cpp
+%%DATADIR%%/minimal.d
%%DATADIR%%/minimal.rs
%%DATADIR%%/misceffects.lib
%%DATADIR%%/module.cpp
@@ -685,6 +716,7 @@ lib/libOSCFaust.a
%%DATADIR%%/pure.c
%%DATADIR%%/pure.cpp
%%DATADIR%%/puredata.cpp
+%%DATADIR%%/quantizers.lib
%%DATADIR%%/ra-qt.cpp
%%DATADIR%%/reducemaps.lib
%%DATADIR%%/reverbs.lib
@@ -768,8 +800,13 @@ lib/libOSCFaust.a
%%DATADIR%%/unity/unity.cpp
%%DATADIR%%/unity/unityplugin.cpp
%%DATADIR%%/vaeffects.lib
+%%DATADIR%%/vcvrack/README.md
+%%DATADIR%%/vcvrack/template/Makefile
+%%DATADIR%%/vcvrack/template/res/FaustModule.svg
+%%DATADIR%%/vcvrack/template/src/FaustModule.cpp
%%DATADIR%%/version.lib
%%DATADIR%%/vst.cpp
+%%DATADIR%%/wdmodels.lib
%%DATADIR%%/webaudio.lib
%%DATADIR%%/webaudio/ExportLib.js
%%DATADIR%%/webaudio/README.md