aboutsummaryrefslogtreecommitdiff
path: root/audio/faust
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-05-05 19:18:25 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-05-05 19:18:25 +0000
commitc97c739ee3d803fc5bbb5223a217aa21b36dddcc (patch)
tree35531776577d6cef1344bf8adbdee6a2f3ce89c9 /audio/faust
parent2d0fd5e0b414ffe9cd75220a37bcb34fc3957835 (diff)
downloadports-c97c739ee3d803fc5bbb5223a217aa21b36dddcc.tar.gz
ports-c97c739ee3d803fc5bbb5223a217aa21b36dddcc.zip
audio/faust: Unbreak by making it accept any llvm versions
LLVM versions were hardcoded to the list 5.0.0, 5.0.1. When 5.0.2 came it caused faust to break. Fixed this by accepting any llvm versions.
Notes
Notes: svn path=/head/; revision=469161
Diffstat (limited to 'audio/faust')
-rw-r--r--audio/faust/files/patch-compiler_Makefile.unix17
1 files changed, 17 insertions, 0 deletions
diff --git a/audio/faust/files/patch-compiler_Makefile.unix b/audio/faust/files/patch-compiler_Makefile.unix
new file mode 100644
index 000000000000..eaf8bd7ecb17
--- /dev/null
+++ b/audio/faust/files/patch-compiler_Makefile.unix
@@ -0,0 +1,17 @@
+--- compiler/Makefile.unix.orig 2018-05-05 19:02:08 UTC
++++ compiler/Makefile.unix
+@@ -150,12 +150,12 @@ else ifeq ($(LLVM_VERSION),$(filter $(LL
+ CLANGLIBS=$(CLANGLIBSLIST)
+ CXXFLAGS += -std=gnu++11
+
+-else ifeq ($(LLVM_VERSION),$(filter $(LLVM_VERSION), 5.0.0 5.0.1))
++else ifeq ($(patsubst 5.%,5,$(LLVM_VERSION)), 5)
+ LLVM_VERSION = LLVM_50
+ CLANGLIBS=$(CLANGLIBSLIST)
+ CXXFLAGS += -std=gnu++11
+
+-else ifeq ($(LLVM_VERSION),$(filter $(LLVM_VERSION), 6.0.0 6.0.0svn))
++else ifeq ($(patsubst 6.%,6,$(LLVM_VERSION)), 6)
+ LLVM_VERSION = LLVM_60
+ CLANGLIBS=$(CLANGLIBSLIST)
+ CXXFLAGS += -std=gnu++11