aboutsummaryrefslogtreecommitdiff
path: root/audio/fdmf
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-11-02 20:35:49 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-11-02 20:35:49 +0000
commit8e473b64e79d995298b53b9c10452d3b45cbcbe7 (patch)
tree9cf4b14ed693f151b342331c8713f5edb3617f70 /audio/fdmf
parent62a7486b94e43b8977f25e89d8b8c91bfb3e3013 (diff)
downloadports-8e473b64e79d995298b53b9c10452d3b45cbcbe7.tar.gz
ports-8e473b64e79d995298b53b9c10452d3b45cbcbe7.zip
Add port audio/fdmf:
fdmf is portable perl/C software for finding pairs of music files in a collection that are likely to contain the same music. It works on the music itself, not on the filename, tags, or headers. It uses an audio fingerprint, or perceptual hash to recognize the duplicate files. It is currently under heavy development, so it might be buggy, broken, or otherwise bad. But it works for me. WWW: http://www.w140.com/audio/ Author: Kurt Rosenfeld <kurt at w140 dot com>
Notes
Notes: svn path=/head/; revision=176225
Diffstat (limited to 'audio/fdmf')
-rw-r--r--audio/fdmf/Makefile43
-rw-r--r--audio/fdmf/distinfo3
-rw-r--r--audio/fdmf/pkg-descr9
3 files changed, 55 insertions, 0 deletions
diff --git a/audio/fdmf/Makefile b/audio/fdmf/Makefile
new file mode 100644
index 000000000000..8c9f51df1529
--- /dev/null
+++ b/audio/fdmf/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: fdmf
+# Date created: 2 November 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fdmf
+DISTVERSION= 0.0.9r
+CATEGORIES= audio
+MASTER_SITES= http://w140.com/audio/ CSME
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Find similar music by perceptual hashing
+
+LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
+ plot.4:${PORTSDIR}/graphics/plotutils \
+ fftw3.4:${PORTSDIR}/math/fftw3
+RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer \
+ mpg123:${PORTSDIR}/audio/mpg123 \
+ ogg123:${PORTSDIR}/audio/vorbis-tools \
+ p5-GDBM>=0:${PORTSDIR}/databases/p5-GDBM
+
+USE_PERL5= yes
+CFLAGS= -I${LOCALBASE}/include -L. -L${LOCALBASE}/lib
+MAKE_ENV= VPATH=common
+PORTDOCS= README
+BINS= sonic_reducer vector_pairs
+SCRS= ${PORTNAME} ${PORTNAME}_bench cleanup_dups optparam
+PLIST_FILES= ${BINS:S,^,bin/,}
+
+post-patch:
+ @${REINPLACE_CMD} -Ee '/^(CFLAGS|CC) =/s|.*||' -e 's|common/||g' ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${BINS:S,^,${WRKSRC}/,} ${PREFIX}/bin/
+ @${INSTALL_SCRIPT} ${SCRS:S,^,${WRKSRC}/,} ${PREFIX}/bin/
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/fdmf/distinfo b/audio/fdmf/distinfo
new file mode 100644
index 000000000000..13bebd6f8804
--- /dev/null
+++ b/audio/fdmf/distinfo
@@ -0,0 +1,3 @@
+MD5 (fdmf-0.0.9r.tar.gz) = 1d79911c83605a68573d0a2ea8a01d18
+SHA256 (fdmf-0.0.9r.tar.gz) = 0df28a54d092f4f9274c040cc4b53331b9e06f8a9aa0eeb53ec5f0c26a836988
+SIZE (fdmf-0.0.9r.tar.gz) = 24027
diff --git a/audio/fdmf/pkg-descr b/audio/fdmf/pkg-descr
new file mode 100644
index 000000000000..3130f53f70e1
--- /dev/null
+++ b/audio/fdmf/pkg-descr
@@ -0,0 +1,9 @@
+fdmf is portable perl/C software for finding pairs of music files in a
+collection that are likely to contain the same music. It works on the
+music itself, not on the filename, tags, or headers. It uses an audio
+fingerprint, or perceptual hash to recognize the duplicate files. It is
+currently under heavy development, so it might be buggy, broken, or
+otherwise bad. But it works for me.
+
+WWW: http://www.w140.com/audio/
+Author: Kurt Rosenfeld <kurt at w140 dot com>