aboutsummaryrefslogtreecommitdiff
path: root/audio/festival
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-30 10:09:28 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-30 10:09:28 +0000
commit441a24d9eec38fd1c7b42519888711590851a593 (patch)
tree100dd1c0b4ab649af9c4e5f20e79110024160687 /audio/festival
parent239c6a9f27f38d5f9aa5baa99e664b6191779a8d (diff)
downloadports-441a24d9eec38fd1c7b42519888711590851a593.tar.gz
ports-441a24d9eec38fd1c7b42519888711590851a593.zip
- Fix build when CC is absolute path
Upstream build scripts have some machinery to include compiler-specific .mak file depending on compiler used. This is handled in an ugly way by the port, roughly, upstream makefile includes ${CC}.mak and ports Makefile copies that from default .mak. This is breaks when CC is an absolute path and is useless anyway, as even if it was implemented properly, customized .mak files are for compilers we'll never use such as gcc 3.2, intel and suncc. So make upstream makefile always include the default .mak. PR: 215253 Approved by: maintainer timeout (mi@aldan.algebra.com, 6 weeks) MFH: 2017Q1
Notes
Notes: svn path=/head/; revision=432825
Diffstat (limited to 'audio/festival')
-rw-r--r--audio/festival/Makefile5
-rw-r--r--audio/festival/files/patch-speech__tools_config_compilers_gcc.mak11
2 files changed, 12 insertions, 4 deletions
diff --git a/audio/festival/Makefile b/audio/festival/Makefile
index 1752b694168a..18e471d22c68 100644
--- a/audio/festival/Makefile
+++ b/audio/festival/Makefile
@@ -87,14 +87,11 @@ do-configure:
# This step helps non-i386 systems and is harmless on i386
-${LN} -s ix86_FreeBSD.mak ${WRKDIR}/$d/config/systems/${ARCH:S/armv6/arm/}_unknown.mak
.endfor
- ${REINPLACE_CMD} \
+ @${REINPLACE_CMD} \
-e '/^CFLAGS *=/s|$$| ${CFLAGS}|' \
-e '/^CXXFLAGS *=/s|$$| ${CXXFLAGS}|' \
-e 's,^OPTIMI,#OPTIMI,' \
${WRKSRC}/speech_tools/config/compilers/gcc*.mak
- # This step helps to use a compiler, the vendor has not seen before:
- ${TEST} -e ${WRKDIR}/speech_tools/config/compilers/${CC}.mak || \
- ${LN} -s gcc_defaults.mak ${WRKDIR}/speech_tools/config/compilers/${CC}.mak
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
diff --git a/audio/festival/files/patch-speech__tools_config_compilers_gcc.mak b/audio/festival/files/patch-speech__tools_config_compilers_gcc.mak
new file mode 100644
index 000000000000..dca78d8382d6
--- /dev/null
+++ b/audio/festival/files/patch-speech__tools_config_compilers_gcc.mak
@@ -0,0 +1,11 @@
+--- speech_tools/config/compilers/gcc.mak.orig 2001-04-04 11:55:32 UTC
++++ speech_tools/config/compilers/gcc.mak
+@@ -38,8 +38,4 @@
+ ## ##
+ ###########################################################################
+
+-ifdef GCC
+-include $(EST)/config/compilers/$(GCC).mak
+-else
+ include $(EST)/config/compilers/gcc_defaults.mak
+-endif