aboutsummaryrefslogtreecommitdiff
path: root/audio/firefly/Makefile
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-06-21 20:44:12 +0000
committerChris Rees <crees@FreeBSD.org>2011-06-21 20:44:12 +0000
commitc99300f228fb27d9ec68c9dd9144a0914828d3c2 (patch)
tree0dc651bc5829d9250b93d3e40c85200b9901f9bd /audio/firefly/Makefile
parent9aa2347461e8b3311277bc20e9c44c07a12387e6 (diff)
downloadports-c99300f228fb27d9ec68c9dd9144a0914828d3c2.tar.gz
ports-c99300f228fb27d9ec68c9dd9144a0914828d3c2.zip
Notes
Diffstat (limited to 'audio/firefly/Makefile')
-rw-r--r--audio/firefly/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/audio/firefly/Makefile b/audio/firefly/Makefile
index b292d23cd624..4f8d7575d749 100644
--- a/audio/firefly/Makefile
+++ b/audio/firefly/Makefile
@@ -38,12 +38,10 @@ DAAPD_USER?= daapd
DAAPD_GROUP?= daapd
DAAPD_DBDIR?= ${PREFIX}/var/db/${PORTNAME}
USE_RC_SUBR= mt-daapd
+USERS= ${DAAPD_USER}
+GROUPS= ${DAAPD_GROUP}
PLIST_SUB+= DAAPD_DBDIR=${DAAPD_DBDIR}
-SUB_LIST+= USER=${DAAPD_USER}\
- GROUP=${DAAPD_GROUP}\
- DAAPD_DBDIR=${DAAPD_DBDIR}
-SUB_FILES+= pkg-install pkg-deinstall
USE_LDCONFIG= yes
@@ -57,9 +55,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|' \
${WRKSRC}/configure
-pre-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}