aboutsummaryrefslogtreecommitdiff
path: root/audio/firefly
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2011-12-27 04:23:04 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2011-12-27 04:23:04 +0000
commitd4aa640ccb272ab341ca4dd13b695174cadc7e7e (patch)
tree66edc63a6a760b383b703bc9ba67dd5bdcc54d6f /audio/firefly
parent91c2998a3d250b4c15aaacd0d5ce1b4e3207bbfd (diff)
downloadports-d4aa640ccb272ab341ca4dd13b695174cadc7e7e.tar.gz
ports-d4aa640ccb272ab341ca4dd13b695174cadc7e7e.zip
Notes
Diffstat (limited to 'audio/firefly')
-rw-r--r--audio/firefly/Makefile2
-rw-r--r--audio/firefly/files/patch-plugins_out-daap.c24
2 files changed, 25 insertions, 1 deletions
diff --git a/audio/firefly/Makefile b/audio/firefly/Makefile
index c8065cce1aef..fe173189ecec 100644
--- a/audio/firefly/Makefile
+++ b/audio/firefly/Makefile
@@ -6,7 +6,7 @@
PORTNAME= firefly
PORTVERSION= 1696
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= http://nightlies.fireflymediaserver.org/nightlies/svn-${PORTVERSION}/ \
http://www.magnesium.net/~mdf/distfiles/
diff --git a/audio/firefly/files/patch-plugins_out-daap.c b/audio/firefly/files/patch-plugins_out-daap.c
new file mode 100644
index 000000000000..2bd59918b114
--- /dev/null
+++ b/audio/firefly/files/patch-plugins_out-daap.c
@@ -0,0 +1,24 @@
+--- src/plugins/out-daap.c 2007-10-13 15:10:06.000000000 -0700
++++ src/plugins/out-daap.c.new 2011-10-16 18:08:53.207764000 -0700
+@@ -1392,11 +1393,9 @@
+
+ size = sizeof(servername);
+ pi_server_name(servername,&size);
+- // supports_update = conf_get_int("daap","supports_update",1);
++ supports_update = pi_conf_get_int("daap","supports_update",1);
+
+ actual_length=139 + (int) strlen(servername);
+- if(!supports_update)
+- actual_length -= 9;
+
+ if(actual_length > sizeof(server_info)) {
+ pi_log(E_FATAL,"Server name too long.\n");
+@@ -1434,6 +1433,8 @@
+ current += dmap_add_int(current,"msdc",1); /* 12 */
+
+ if(supports_update)
++ current += dmap_add_char(current,"msup",1); /* 9 */
++ else
+ current += dmap_add_char(current,"msup",0); /* 9 */
+
+ out_daap_output_start(pwsc,ppi,actual_length);