aboutsummaryrefslogtreecommitdiff
path: root/audio/flac/Makefile
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-06-25 15:56:39 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-06-25 15:57:35 +0000
commitf7f2d731c8d9a0cdfce89950e2d387dc07909e30 (patch)
treefeeda08916f947b53860993923f2982f3749264b /audio/flac/Makefile
parent4828dae14a73369845cad8d6e0927164a9dcc2d0 (diff)
downloadports-f7f2d731c8d9a0cdfce89950e2d387dc07909e30.tar.gz
ports-f7f2d731c8d9a0cdfce89950e2d387dc07909e30.zip
Diffstat (limited to 'audio/flac/Makefile')
-rw-r--r--audio/flac/Makefile47
1 files changed, 22 insertions, 25 deletions
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index 7a2684acdde5..765ecaa4ab43 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -1,7 +1,8 @@
PORTNAME= flac
-PORTVERSION= 1.4.2
+DISTVERSION= 1.4.3
CATEGORIES= audio
-MASTER_SITES= https://downloads.xiph.org/releases/flac/
+MASTER_SITES= https://github.com/xiph/${PORTNAME}/releases/download/${DISTVERSION}/ \
+ https://downloads.xiph.org/releases/${PORTNAME}/
MAINTAINER= naddy@FreeBSD.org
COMMENT= Free lossless audio codec
@@ -14,37 +15,33 @@ LICENSE_FILE_GFDL= ${WRKSRC}/COPYING.FDL
LIB_DEPENDS= libogg.so:audio/libogg
-USES= compiler:c11 cpe iconv libtool pathfix pkgconfig tar:xz
-
+USES= cmake:testing compiler:c11 cpe gettext-runtime iconv \
+ pathfix pkgconfig tar:xz
CPE_VENDOR= flac_project
+USE_LDCONFIG= yes
# Preserve UTF-8 filenames in test/flac-to-flac-metadata-test-files/.
# They are referenced by the test suite.
EXTRACT_CMD= ${SETENV} LC_ALL=C.UTF-8 ${TAR}
-USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-static \
- --with-ogg="${LOCALBASE}" \
- --disable-doxygen-docs \
- --disable-thorough-tests \
- --disable-xmms-plugin
-INSTALL_TARGET= install-strip
-TEST_TARGET= check
+CMAKE_TESTING_ARGS= -DCMAKE_CTEST_ARGUMENTS="-E;libFLAC"
-OPTIONS_DEFINE= DOCS
+CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=${PREFIX}/man
+CMAKE_OFF= BUILD_DOCS BUILD_TESTING WITH_STACK_PROTECTOR
+CMAKE_ON= BUILD_SHARED_LIBS
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS
-.if ${ARCH} != powerpc64le
-CONFIGURE_ARGS+=--disable-vsx
-.endif
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/src/*/*.m4 ${STAGEDIR}${PREFIX}/share/aclocal
-# test_libFLAC:
-# "iterator claims file is writable when tester thinks it should not be"
-.if ${UID} == 0
-do-test:
- @${ECHO_MSG} "The tests cannot be run as root, skipping."
-.endif
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/api
+ ${INSTALL_MAN} ${WRKSRC}/doc/api/* ${STAGEDIR}${DOCSDIR}/api
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/images
+ ${INSTALL_MAN} ${WRKSRC}/doc/images/*.gif ${STAGEDIR}${DOCSDIR}/images
+ ${INSTALL_MAN} ${WRKSRC}/doc/images/*.svg ${STAGEDIR}${DOCSDIR}/images
+ ${INSTALL_MAN} ${WRKSRC}/doc/*.tag ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/isoflac.txt ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>