aboutsummaryrefslogtreecommitdiff
path: root/audio/flac
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-06-11 08:21:42 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-06-11 08:21:42 +0000
commit33b8e400e2a25bc974a5b2d032544d9dc577eeba (patch)
treede51f39a83e8b4085ce6c2dd44fe47680f0e278f /audio/flac
parentca97f4417ad3dee330bc29f5826a1fe5294bdc38 (diff)
downloadports-33b8e400e2a25bc974a5b2d032544d9dc577eeba.tar.gz
ports-33b8e400e2a25bc974a5b2d032544d9dc577eeba.zip
audio/flac: add USES=compiler:c11
This is to fix audio/audacity: /usr/local/bin/ld: ondemand/audacity-ODDecodeFlacTask.o:(.data.rel.ro._ZTV10ODFLACFile[_ZTV10ODFLACFile]+0x148): undefined reference to `FLAC::Decoder::File::init(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)' /usr/local/bin/ld: ondemand/audacity-ODDecodeFlacTask.o:(.data.rel.ro._ZTV10ODFLACFile[_ZTV10ODFLACFile]+0x160): undefined reference to `FLAC::Decoder::File::init_ogg(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)' /usr/local/bin/ld: import/audacity-ImportFLAC.o:(.data.rel.ro._ZTV10MyFLACFile[_ZTV10MyFLACFile]+0x148): undefined reference to `FLAC::Decoder::File::init(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)' /usr/local/bin/ld: import/audacity-ImportFLAC.o:(.data.rel.ro._ZTV10MyFLACFile[_ZTV10MyFLACFile]+0x160): undefined reference to `FLAC::Decoder::File::init_ogg(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)' Approved by: mentors (implicite approval)
Notes
Notes: svn path=/head/; revision=503942
Diffstat (limited to 'audio/flac')
-rw-r--r--audio/flac/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index cf90af0731cd..ad0d5a43e3ba 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -18,7 +18,7 @@ LICENSE_FILE_GFDL= ${WRKSRC}/COPYING.FDL
LIB_DEPENDS= libogg.so:audio/libogg
-USES= iconv libtool pathfix pkgconfig tar:xz
+USES= compiler:c11 iconv libtool pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes