aboutsummaryrefslogtreecommitdiff
path: root/audio/flac
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2015-01-10 20:16:37 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2015-01-10 20:16:37 +0000
commit403699b0e5b14dbe29716aaa1bbfb4f6f92200c6 (patch)
tree0136b53f7b2cb0ace03ff355f488dc1bb9b846c6 /audio/flac
parent5118b324f4f511dff0b945e070f2775b8da62fac (diff)
downloadports-403699b0e5b14dbe29716aaa1bbfb4f6f92200c6.tar.gz
ports-403699b0e5b14dbe29716aaa1bbfb4f6f92200c6.zip
Update to FLAC 1.3.1. No significant user-visible changes.
Drop iconv option again and always require iconv for flac.
Notes
Notes: svn path=/head/; revision=376724
Diffstat (limited to 'audio/flac')
-rw-r--r--audio/flac/Makefile25
-rw-r--r--audio/flac/distinfo4
-rw-r--r--audio/flac/files/patch-configure41
-rw-r--r--audio/flac/files/patch-man_flac.113
-rw-r--r--audio/flac/files/patch-src_libFLAC_stream__decoder.c32
-rw-r--r--audio/flac/files/patch-src_libFLAC_stream__encoder.c14
-rw-r--r--audio/flac/pkg-plist70
7 files changed, 45 insertions, 154 deletions
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index 771cb51e71bd..b30e0ea9b53f 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= flac
-PORTVERSION= 1.3.0
-PORTREVISION= 4
+PORTVERSION= 1.3.1
CATEGORIES= audio
MASTER_SITES= http://downloads.xiph.org/releases/flac/
@@ -12,7 +11,8 @@ COMMENT= Free lossless audio codec
LIB_DEPENDS= libogg.so:${PORTSDIR}/audio/libogg
-USES= libtool pathfix pkgconfig tar:xz
+USES= iconv libtool pathfix pkgconfig tar:xz
+
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static \
@@ -22,26 +22,17 @@ CONFIGURE_ARGS= --enable-static \
--disable-thorough-tests \
--disable-xmms-plugin
-OPTIONS_DEFINE= DOCS ICONV
-OPTIONS_DEFAULT=ICONV
-
-ICONV_USES= iconv
-ICONV_CPPFLAGS= -I${ICONV_PREFIX}/include
-ICONV_LDFLAGS= -L${ICONV_PREFIX}/lib
-ICONV_CONFIGURE_OFF= am_cv_func_iconv=no
-
.include <bsd.port.options.mk>
.if ${ARCH} == "i386"
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
.endif
-pre-patch:
- @${REINPLACE_CMD} 's:^docdir = $$(datadir)/doc/$$(PACKAGE)-$$(VERSION):docdir = $$(datadir)/doc/$$(PACKAGE):' \
- `find ${WRKSRC}/doc -name Makefile.in`
-
-post-build:
- ${REINPLACE_CMD} 's:%%PREFIX%%:${PREFIX}:' ${WRKSRC}/man/flac.1
+post-install:
+ cd ${STAGEDIR}${PREFIX}/share/doc && ${MV} ${DISTNAME} flac
+ ${REINPLACE_CMD} 's:%%PREFIX%%:${PREFIX}:' \
+ ${STAGEDIR}${PREFIX}/man/man1/flac.1
+ ${RM} ${STAGEDIR}${PREFIX}/man/man1/flac.1.bak
regression-test: build
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check
diff --git a/audio/flac/distinfo b/audio/flac/distinfo
index 60d728331dda..55be70352a62 100644
--- a/audio/flac/distinfo
+++ b/audio/flac/distinfo
@@ -1,2 +1,2 @@
-SHA256 (flac-1.3.0.tar.xz) = fa2d64aac1f77e31dfbb270aeb08f5b32e27036a52ad15e69a77e309528010dc
-SIZE (flac-1.3.0.tar.xz) = 1084256
+SHA256 (flac-1.3.1.tar.xz) = 4773c0099dba767d963fd92143263be338c48702172e8754b9bc5103efe1c56c
+SIZE (flac-1.3.1.tar.xz) = 941848
diff --git a/audio/flac/files/patch-configure b/audio/flac/files/patch-configure
index f4d604e92fac..e83412207e15 100644
--- a/audio/flac/files/patch-configure
+++ b/audio/flac/files/patch-configure
@@ -1,14 +1,31 @@
-
-$FreeBSD$
-
---- configure.orig 2013-05-27 10:11:54.740045000 +0200
-+++ configure 2013-06-09 18:15:53.000000000 +0200
-@@ -19807,7 +19807,7 @@ else
+--- configure.orig 2014-11-27 02:46:58 UTC
++++ configure
+@@ -17885,7 +17885,7 @@ _ACEOF
+
+ asm_optimisation=no
+ case "$host_cpu" in
+- x86_64)
++ amd64|x86_64)
+ if test $ac_cv_sizeof_voidp = 4 ; then
+ # This must be a 32 bit user space running on 64 bit kernel so treat
+ # this as ia32.
+@@ -19874,8 +19874,8 @@ if test "x$debug" = xtrue; then
+ CFLAGS="-g $CFLAGS"
+ else
CPPFLAGS="-DNDEBUG $CPPFLAGS"
- if test "x$GCC" = xyes; then
- if test "x$user_cflags" = x; then
-- CFLAGS="-O3 -funroll-loops -Wall -W -Winline"
-+ CFLAGS="-Wall -W"
- fi
- fi
+- CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//;s/-g//')
+- CFLAGS="-O3 -funroll-loops $CFLAGS"
++ #CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//;s/-g//')
++ #CFLAGS="-O3 -funroll-loops $CFLAGS"
fi
+
+
+@@ -20051,7 +20051,7 @@ rm -f core conftest.err conftest.$ac_obj
+
+ fi
+
+- if test "x$asm_optimisation$sse_os" = "xyesyes" ; then
++ if false test "x$asm_optimisation$sse_os" = "xyesyes" ; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking if $CC accepts -msse2" >&5
+ $as_echo_n "checking if $CC accepts -msse2... " >&6; }
+ ac_add_cflags__old_cflags="$CFLAGS"
diff --git a/audio/flac/files/patch-man_flac.1 b/audio/flac/files/patch-man_flac.1
index 938598f371ed..3e0f42f2a925 100644
--- a/audio/flac/files/patch-man_flac.1
+++ b/audio/flac/files/patch-man_flac.1
@@ -1,14 +1,11 @@
-
-$FreeBSD$
-
---- man/flac.1.orig 2013-05-26 11:30:33.924201000 +0200
-+++ man/flac.1 2013-06-09 18:16:59.000000000 +0200
-@@ -380,7 +380,7 @@ These flags can be used to invert the se
+--- man/flac.1.orig 2014-11-25 03:40:14 UTC
++++ man/flac.1
+@@ -384,7 +384,7 @@ These flags can be used to invert the se
.PP
- metaflac(1).
+ metaflac(1)
.PP
-The programs are documented fully by HTML format documentation, available in \fI/usr/share/doc/libflac-doc/html\fR on Debian GNU/Linux systems.
+The programs are documented fully by HTML format documentation, available in \fI%%PREFIX%%/share/doc/flac/html\fR.
.SH "AUTHOR"
.PP
- This manual page was written by Matt Zimmerman <mdz@debian.org> for the Debian GNU/Linux system (but may be used by others).
+ This manual page was initially written by Matt Zimmerman <mdz@debian.org> for the Debian GNU/Linux system (but may be used by others). It has been kept up-to-date by the Xiph.org Foundation.
diff --git a/audio/flac/files/patch-src_libFLAC_stream__decoder.c b/audio/flac/files/patch-src_libFLAC_stream__decoder.c
deleted file mode 100644
index bdff2c3b1966..000000000000
--- a/audio/flac/files/patch-src_libFLAC_stream__decoder.c
+++ /dev/null
@@ -1,32 +0,0 @@
---- src/libFLAC/stream_decoder.c.orig 2013-05-26 09:30:33 UTC
-+++ src/libFLAC/stream_decoder.c
-@@ -71,7 +71,7 @@ FLAC_API int FLAC_API_SUPPORTS_OGG_FLAC
- *
- ***********************************************************************/
-
--static FLAC__byte ID3V2_TAG_[3] = { 'I', 'D', '3' };
-+static const FLAC__byte ID3V2_TAG_[3] = { 'I', 'D', '3' };
-
- /***********************************************************************
- *
-@@ -1365,6 +1365,10 @@ FLAC__bool find_metadata_(FLAC__StreamDe
- id = 0;
- continue;
- }
-+
-+ if(id >= 3)
-+ return false;
-+
- if(x == ID3V2_TAG_[id]) {
- id++;
- i = 0;
-@@ -2705,7 +2709,8 @@ FLAC__bool read_residual_partitioned_ric
- if(decoder->private_->frame.header.blocksize < predictor_order) {
- send_error_to_client_(decoder, FLAC__STREAM_DECODER_ERROR_STATUS_LOST_SYNC);
- decoder->protected_->state = FLAC__STREAM_DECODER_SEARCH_FOR_FRAME_SYNC;
-- return true;
-+ /* We have received a potentially malicious bt stream. All we can do is error out to avoid a heap overflow. */
-+ return false;
- }
- }
- else {
diff --git a/audio/flac/files/patch-src_libFLAC_stream__encoder.c b/audio/flac/files/patch-src_libFLAC_stream__encoder.c
deleted file mode 100644
index 4392b9b0fa5a..000000000000
--- a/audio/flac/files/patch-src_libFLAC_stream__encoder.c
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/libFLAC/stream_encoder.c.orig
-+++ src/libFLAC/stream_encoder.c
-@@ -3784,7 +3784,7 @@
- /* slightly pessimistic but still catches all common cases */
- /* WATCHOUT: "+ bps" is an assumption that the average residual magnitude will not be more than "bps" bits */
- if(FLAC__bitmath_ilog2(default_partition_samples) + bps < 32) {
-- FLAC__uint32 abs_residual_partition_sum;
-+ FLAC__uint64 abs_residual_partition_sum;
-
- for(partition = residual_sample = 0; partition < partitions; partition++) {
- end += default_partition_samples;
diff --git a/audio/flac/pkg-plist b/audio/flac/pkg-plist
index ad0a6178c353..4b7f0e4a55b1 100644
--- a/audio/flac/pkg-plist
+++ b/audio/flac/pkg-plist
@@ -30,90 +30,22 @@ share/aclocal/libFLAC++.m4
share/aclocal/libFLAC.m4
%%PORTDOCS%%%%DOCSDIR%%/FLAC.tag
%%PORTDOCS%%%%DOCSDIR%%/html/changelog.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison__chopin_prelude_24.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison__dream_theater_600.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison__eddie_warner_titus.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison__fanfare_de_l_eventail_de_jeanne.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison__gloria_estefan_conga.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison__hand_in_my_pocket.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison__l_sub_raga_sivapriya.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison__laetatus_sum.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison__mummified_in_barbed_wire.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison__prokofiev_pcon3_3.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison__ravel_sq4_4.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison__scarlatti_k42.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison__tool_forty_six_and_2.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison__white_room.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison_all_cpudectime.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison_all_cpuenctime.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison_all_procdectime.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison_all_procenctime.html
-%%PORTDOCS%%%%DOCSDIR%%/html/comparison_all_ratio.html
%%PORTDOCS%%%%DOCSDIR%%/html/developers.html
%%PORTDOCS%%%%DOCSDIR%%/html/documentation.html
%%PORTDOCS%%%%DOCSDIR%%/html/documentation_bugs.html
%%PORTDOCS%%%%DOCSDIR%%/html/documentation_example_code.html
%%PORTDOCS%%%%DOCSDIR%%/html/documentation_format_overview.html
-%%PORTDOCS%%%%DOCSDIR%%/html/documentation_tasks.html
%%PORTDOCS%%%%DOCSDIR%%/html/documentation_tools.html
%%PORTDOCS%%%%DOCSDIR%%/html/documentation_tools_flac.html
%%PORTDOCS%%%%DOCSDIR%%/html/documentation_tools_metaflac.html
-%%PORTDOCS%%%%DOCSDIR%%/html/documentation_tools_plugins.html
-%%PORTDOCS%%%%DOCSDIR%%/html/download.html
%%PORTDOCS%%%%DOCSDIR%%/html/faq.html
%%PORTDOCS%%%%DOCSDIR%%/html/favicon.ico
%%PORTDOCS%%%%DOCSDIR%%/html/features.html
%%PORTDOCS%%%%DOCSDIR%%/html/flac.css
%%PORTDOCS%%%%DOCSDIR%%/html/format.html
%%PORTDOCS%%%%DOCSDIR%%/html/id.html
-%%PORTDOCS%%%%DOCSDIR%%/html/images/1x1.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/images/cafebug.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/Blackbird_Front_low3_325x87.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/MS300frontsmall_270x108.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/MediaBox_Frt_170x325.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/SB_Hero_Black_325x182.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/Sooloos-ControlOne_325x328.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/Z500_front_325x94.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/a2_01_325x252.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/arcus_325x135.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/bmp-1430_325x241.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/cs505_front_lrg_325x113.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/enus_3-4lft-hires_product_eva8000_325x127.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/escient_ProductLine_325x163.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/hifidelio_bl_front_Z_RGB_325x163.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/i-station-mini-dx_325x237.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/iwod-g10_325x257.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/knc_hr-2800_325x209.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/mediaready_prodmain_MRMCa_325x232.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/meizu_m6_325x206.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/musica_artwork_325x90.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/neodigits_x5000_325x124.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/onda-vx737_325x240.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/request_n_front_325x103.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/rio_karma_279x254.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/sonos_family_RGB_325x200.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/teclast-tl29_325x244.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/transporter_hero_grey_325x208.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/tvix-4000_325x204.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/hw/vibez_nofm_combi_black_b_325x220.jpg
-%%PORTDOCS%%%%DOCSDIR%%/html/images/logo100.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/images/logo.svg
%%PORTDOCS%%%%DOCSDIR%%/html/images/logo130.gif
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/itunes.html
%%PORTDOCS%%%%DOCSDIR%%/html/license.html
-%%PORTDOCS%%%%DOCSDIR%%/html/links.html
-%%PORTDOCS%%%%DOCSDIR%%/html/news.html
%%PORTDOCS%%%%DOCSDIR%%/html/ogg_mapping.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ru/authors.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ru/comparison.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ru/developers.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ru/documentation.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ru/download.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ru/features.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ru/format.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ru/goals.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ru/id.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ru/index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ru/links.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ru/news.html