aboutsummaryrefslogtreecommitdiff
path: root/audio/flite
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-03-31 13:23:57 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-03-31 13:23:57 +0000
commit4a25988c2efdd2f32f4d5a642dfd5eb9e55445d1 (patch)
tree14ead431677446a0606c66e97dfe153c406a39ba /audio/flite
parent5353c9f050f401e0b18faaefe9f8abeaf40d687f (diff)
downloadports-4a25988c2efdd2f32f4d5a642dfd5eb9e55445d1.tar.gz
ports-4a25988c2efdd2f32f4d5a642dfd5eb9e55445d1.zip
- Update to 1.3
PR: ports/121609 Submitted by: Richard Neese <r.neese@gmail.com> Approved by: maintainer timeout (sobomax; 20 days)
Notes
Notes: svn path=/head/; revision=210244
Diffstat (limited to 'audio/flite')
-rw-r--r--audio/flite/Makefile6
-rw-r--r--audio/flite/distinfo6
-rw-r--r--audio/flite/files/patch-Makefile24
-rw-r--r--audio/flite/files/patch-configure19
-rw-r--r--audio/flite/files/patch-lang-cmulex-make_cmulex14
-rw-r--r--audio/flite/files/patch-lib::Makefile15
-rw-r--r--audio/flite/files/patch-src-audio-au_sun.c25
-rw-r--r--audio/flite/files/patch-tools-funds_sts_main.c19
-rw-r--r--audio/flite/files/patch-tools-huff_table59
-rw-r--r--audio/flite/pkg-plist21
10 files changed, 165 insertions, 43 deletions
diff --git a/audio/flite/Makefile b/audio/flite/Makefile
index 82145884bd33..92841cf6d51a 100644
--- a/audio/flite/Makefile
+++ b/audio/flite/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= flite
-PORTVERSION= 1.2
-PORTREVISION= 1
+PORTVERSION= 1.3
CATEGORIES= audio
MASTER_SITES= http://www.speech.cs.cmu.edu/flite/packed/${PORTNAME}-${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-release
@@ -15,11 +14,10 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-release
MAINTAINER= sobomax@FreeBSD.org
COMMENT= A small run-time speech synthesis engine
-USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared=yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
diff --git a/audio/flite/distinfo b/audio/flite/distinfo
index 89013128fc67..323bd866efbf 100644
--- a/audio/flite/distinfo
+++ b/audio/flite/distinfo
@@ -1,3 +1,3 @@
-MD5 (flite-1.2-release.tar.bz2) = 24c1576f5b3eb23ecedf4bebde96710f
-SHA256 (flite-1.2-release.tar.bz2) = 10ff42ce08a628c7fd84d26b5228d549e9eecb1eb03cb158e87d8be66bc58ae2
-SIZE (flite-1.2-release.tar.bz2) = 7817919
+MD5 (flite-1.3-release.tar.gz) = ae0aca1cb7b4801f4372f3a75a9e52b5
+SHA256 (flite-1.3-release.tar.gz) = 922225f7001e57a0fbace8833b0a48790a68f6c7b491f2d47c78ad537ab78a8b
+SIZE (flite-1.3-release.tar.gz) = 10663835
diff --git a/audio/flite/files/patch-Makefile b/audio/flite/files/patch-Makefile
new file mode 100644
index 000000000000..b37c81c0b7d4
--- /dev/null
+++ b/audio/flite/files/patch-Makefile
@@ -0,0 +1,24 @@
+--- Makefile.orig 2005-11-01 14:40:45.000000000 +0100
++++ Makefile 2008-03-31 15:19:26.000000000 +0200
+@@ -48,6 +48,7 @@
+ FILES = Makefile README ACKNOWLEDGEMENTS COPYING $(CONFIG)
+ DIST_CLEAN = config.cache config.log config.status \
+ config/config config/system.mak FileList
++DOCDIR= $(PREFIX)/share/doc/flite
+
+ HOST_ONLY_DIRS = tools main
+ ALL = $(BUILD_DIRS)
+@@ -108,10 +109,12 @@
+ mkdir -p $(INSTALLBINDIR)
+ mkdir -p $(INSTALLLIBDIR)
+ mkdir -p $(INSTALLINCDIR)
++ mkdir -p $(DOCDIR)
+ $(INSTALL) -m 644 include/*.h $(INSTALLINCDIR)
+- @ $(MAKE) -C lib --no-print-directory install
++ $(INSTALL) -m 644 $(LIBDIR)/libflite* $(INSTALLLIBDIR)
+ $(INSTALL) -m 755 bin/flite $(INSTALLBINDIR)
+ $(INSTALL) -m 755 bin/flite_time $(INSTALLBINDIR)
++ $(INSTALL) -m 644 README $(DOCDIR)
+
+ time-stamp :
+ @ echo $(PROJECT_NAME) >.time-stamp
diff --git a/audio/flite/files/patch-configure b/audio/flite/files/patch-configure
index 431ff29f0670..c7622a2a5756 100644
--- a/audio/flite/files/patch-configure
+++ b/audio/flite/files/patch-configure
@@ -3,22 +3,23 @@ $FreeBSD$
--- configure.orig
+++ configure
-@@ -1113,6 +1113,9 @@
+@@ -2772,7 +2772,7 @@
OTHERLIBS=
if test "$shared" = true; then
- case "$host_os" in
-+ *bsd*)
-+ SHFLAGS="-fPIC"
-+ ;;
- linux*)
+ case "$target_os" in
+- linux*)
++ linux*|*bsd*)
SHFLAGS="-fPIC"
;;
-@@ -1498,7 +1501,7 @@
- AUDIODRIVER=oss
- AUDIODEFS=-DCST_AUDIO_LINUX
+ solaris*)
+@@ -3989,7 +3989,7 @@
+ AUDIODEFS=-DCST_AUDIO_ALSA
+ AUDIOLIBS=-lasound
;;
- *bsd)
+ *bsd*)
AUDIODRIVER=oss
AUDIODEFS=-DCST_AUDIO_FREEBSD
;;
+
+
diff --git a/audio/flite/files/patch-lang-cmulex-make_cmulex b/audio/flite/files/patch-lang-cmulex-make_cmulex
new file mode 100644
index 000000000000..2d70b4a35309
--- /dev/null
+++ b/audio/flite/files/patch-lang-cmulex-make_cmulex
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- lang/cmulex/make_cmulex.orig
++++ lang/cmulex/make_cmulex
+@@ -36,7 +36,7 @@
+ ## ##
+ ###########################################################################
+
+-if [ "x$FLITEDIR" == "x" ]
++if [ "x$FLITEDIR" = "x" ]
+ then
+ FLITEDIR=`pwd`/../..
+ fi
diff --git a/audio/flite/files/patch-lib::Makefile b/audio/flite/files/patch-lib::Makefile
deleted file mode 100644
index 149ef4faf0fb..000000000000
--- a/audio/flite/files/patch-lib::Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
-
-$FreeBSD$
-
---- lib/Makefile
-+++ lib/Makefile
-@@ -44,8 +44,7 @@
- STATICLIBS= $(LIBNAMES:%=lib%.a)
- SHAREDARLIBS= $(LIBNAMES:%=lib%.shared.a)
- SHAREDLIBS = $(LIBNAMES:%=lib%.so)
--VERSIONSHAREDLIBS = $(SHAREDLIBS:%=%.${PROJECT_VERSION}) \
-- $(SHAREDLIBS:%=%.${PROJECT_SHLIB_VERSION})
-+VERSIONSHAREDLIBS = $(SHAREDLIBS:%=%.${PROJECT_SHLIB_VERSION})
- ALL_LIBS = $(STATICLIBS) $(SHAREDLIBS) $(VERSIONSHAREDLIBS)
-
- ALL = shared_libs
diff --git a/audio/flite/files/patch-src-audio-au_sun.c b/audio/flite/files/patch-src-audio-au_sun.c
new file mode 100644
index 000000000000..845361dda658
--- /dev/null
+++ b/audio/flite/files/patch-src-audio-au_sun.c
@@ -0,0 +1,25 @@
+
+$FreeBSD$
+
+--- src/audio/au_sun.c.orig
++++ src/audio/au_sun.c
+@@ -45,6 +45,7 @@
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #include <errno.h>
++#include <sys/ioctl.h>
+ #include <sys/filio.h>
+ #include <sys/audioio.h>
+ #include "cst_string.h"
+@@ -76,7 +77,11 @@ cst_audiodev *audio_open_sun(int sps, in
+ cst_error();
+ }
+ }
++#ifdef __OpenBSD__
++ AUDIO_INITINFO(&ainfo);
++#else
+ ioctl(fd,AUDIO_GETINFO,&ainfo);
++#endif
+
+ switch (fmt)
+ {
diff --git a/audio/flite/files/patch-tools-funds_sts_main.c b/audio/flite/files/patch-tools-funds_sts_main.c
new file mode 100644
index 000000000000..f63f7db99629
--- /dev/null
+++ b/audio/flite/files/patch-tools-funds_sts_main.c
@@ -0,0 +1,19 @@
+
+$FreeBSD$
+
+Tags: for-upstream
+
+The standard headers must be included before the behavior gets undefined
+by the following macro definition.
+
+--- tools/find_sts_main.c.orig 2005-01-01 15:04:43.000000000 +0100
++++ tools/find_sts_main.c 2007-01-21 04:36:17.750982588 +0100
+@@ -40,6 +40,8 @@
+ #include <stdio.h>
+ #include <math.h>
+ #include <string.h>
++#include <stdlib.h>
++#include <unistd.h>
+
+ /* To allow some normally const fields to manipulated during building */
+ #define const
diff --git a/audio/flite/files/patch-tools-huff_table b/audio/flite/files/patch-tools-huff_table
new file mode 100644
index 000000000000..78a4cebdf711
--- /dev/null
+++ b/audio/flite/files/patch-tools-huff_table
@@ -0,0 +1,59 @@
+
+$FreeBSD$
+
+--- tools/huff_table.orig
++++ tools/huff_table
+@@ -62,7 +62,7 @@ export LANG
+ ## 0 is reserved, 1 is reserved too
+ ALPHABET_SIZE=254
+
+-if [ $1 == "entries" ]
++if [ $1 = "entries" ]
+ then
+ infile=$2
+ outfile=$3
+@@ -74,7 +74,7 @@ then
+ printf("\n");}' >huff.tmp.corpus
+ fi
+
+-if [ $1 == "phones" ]
++if [ $1 = "phones" ]
+ then
+ infile=$2
+ outfile=$3
+@@ -83,7 +83,7 @@ then
+ sed 's/\\/ /g' >huff.tmp.corpus
+ fi
+
+-if [ $1 == "residual" ]
++if [ $1 = "residual" ]
+ then
+ # This really doesn't work: just some tests to see what's worthwhile
+ infile=$2
+@@ -110,7 +110,7 @@ then
+ sed 's/,//g;s/};//' >huff.tmp.corpus
+ fi
+
+-if [ $1 == "other" ]
++if [ $1 = "other" ]
+ then
+ infile=$2
+ outfile=$3
+@@ -242,7 +242,7 @@ awk 'BEGIN {'"$maptable"'}
+ printf("\n");
+ }' > huff.tmp.corpus.uncompressed
+
+-if [ $1 == "phones" ]
++if [ $1 = "phones" ]
+ then
+ cat huff.tmp.corpus.best |
+ sed 's/+/\\/g' |
+@@ -259,7 +259,7 @@ then
+ mv huff.tmp.corpus.compressed huff.phones.compressed
+ fi
+
+-if [ $1 == "entries" ]
++if [ $1 = "entries" ]
+ then
+ cat huff.tmp.corpus.best |
+ sed 's/+//g' |
diff --git a/audio/flite/pkg-plist b/audio/flite/pkg-plist
index 6f2ee8f5cbfe..1413ed2b8d74 100644
--- a/audio/flite/pkg-plist
+++ b/audio/flite/pkg-plist
@@ -15,6 +15,7 @@ include/flite/cst_item.h
include/flite/cst_lexicon.h
include/flite/cst_lts.h
include/flite/cst_lts_rewrites.h
+include/flite/cst_math.h
include/flite/cst_phoneset.h
include/flite/cst_regex.h
include/flite/cst_relation.h
@@ -38,21 +39,17 @@ include/flite/cst_wave.h
include/flite/flite.h
include/flite/flite_version.h
lib/libflite.a
-lib/libflite.so
-lib/libflite.so.1
+lib/libflite.shared.a
lib/libflite_cmu_time_awb.a
-lib/libflite_cmu_time_awb.so
-lib/libflite_cmu_time_awb.so.1
+lib/libflite_cmu_time_awb.shared.a
lib/libflite_cmu_us_kal.a
-lib/libflite_cmu_us_kal.so
-lib/libflite_cmu_us_kal.so.1
+lib/libflite_cmu_us_kal.shared.a
lib/libflite_cmu_us_kal16.a
-lib/libflite_cmu_us_kal16.so
-lib/libflite_cmu_us_kal16.so.1
+lib/libflite_cmu_us_kal16.shared.a
lib/libflite_cmulex.a
-lib/libflite_cmulex.so
-lib/libflite_cmulex.so.1
+lib/libflite_cmulex.shared.a
lib/libflite_usenglish.a
-lib/libflite_usenglish.so
-lib/libflite_usenglish.so.1
+lib/libflite_usenglish.shared.a
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/flite