aboutsummaryrefslogtreecommitdiff
path: root/audio/fluidsynth
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-11-18 20:08:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-11-18 20:08:25 +0000
commit312ef6a405a9623c8e041aa71e69f4f52401c1cc (patch)
tree0ddc166dfac49ba8a703692bb6ea53487d2ff8f7 /audio/fluidsynth
parent151664cac43b64d05fd9f315669d4b4bf2e67503 (diff)
downloadports-312ef6a405a9623c8e041aa71e69f4f52401c1cc.tar.gz
ports-312ef6a405a9623c8e041aa71e69f4f52401c1cc.zip
- Add missing patches
Feature safe: yes
Notes
Notes: svn path=/head/; revision=286024
Diffstat (limited to 'audio/fluidsynth')
-rw-r--r--audio/fluidsynth/files/patch-src__CMakeLists.txt59
-rw-r--r--audio/fluidsynth/files/patch-src__bindings__fluid_rtkit.c39
2 files changed, 98 insertions, 0 deletions
diff --git a/audio/fluidsynth/files/patch-src__CMakeLists.txt b/audio/fluidsynth/files/patch-src__CMakeLists.txt
new file mode 100644
index 000000000000..9798836a1da0
--- /dev/null
+++ b/audio/fluidsynth/files/patch-src__CMakeLists.txt
@@ -0,0 +1,59 @@
+--- src/CMakeLists.txt.orig 2011-09-04 16:38:58.000000000 +0900
++++ src/CMakeLists.txt 2011-09-05 16:30:18.000000000 +0900
+@@ -42,6 +42,11 @@
+ include_directories ( ${READLINE_INCLUDE_DIR} )
+ endif ( READLINE_SUPPORT )
+
++if ( PORTAUDIO_SUPPORT )
++ set ( fluid_portaudio_SOURCES drivers/fluid_portaudio.c )
++ include_directories ( ${PORTAUDIO_INCLUDEDIR} ${PORTAUDIO_INCLUDE_DIRS} )
++endif ( PORTAUDIO_SUPPORT )
++
+ if ( PULSE_SUPPORT )
+ set ( fluid_pulse_SOURCES drivers/fluid_pulse.c )
+ include_directories ( ${PULSE_INCLUDEDIR} ${PULSE_INCLUDE_DIRS} )
+@@ -70,11 +75,6 @@
+ include_directories ( ${JACK_INCLUDEDIR} ${JACK_INCLUDE_DIRS} )
+ endif ( JACK_SUPPORT )
+
+-if ( PORTAUDIO_SUPPORT )
+- set ( fluid_portaudio_SOURCES drivers/fluid_portaudio.c )
+- include_directories ( ${PORTAUDIO_INCLUDEDIR} ${PORTAUDIO_INCLUDE_DIRS} )
+-endif ( PORTAUDIO_SUPPORT )
+-
+ if ( WINDOWS_SUPPORT )
+ set ( fluid_windows_SOURCES fluid_dll.c drivers/fluid_dsound.c drivers/fluid_winmidi.c )
+ endif ( WINDOWS_SUPPORT )
+@@ -207,6 +207,8 @@
+ )
+
+ link_directories (
++ ${PORTAUDIO_LIBDIR}
++ ${PORTAUDIO_LIBRARY_DIRS}
+ ${GLIB_LIBDIR}
+ ${GLIB_LIBRARY_DIRS}
+ ${LASH_LIBDIR}
+@@ -219,8 +221,6 @@
+ ${ALSA_LIBRARY_DIRS}
+ ${PULSE_LIBDIR}
+ ${PULSE_LIBRARY_DIRS}
+- ${PORTAUDIO_LIBDIR}
+- ${PORTAUDIO_LIBRARY_DIRS}
+ ${LIBSNDFILE_LIBDIR}
+ ${LIBSNDFILE_LIBRARY_DIRS}
+ ${DBUS_LIBDIR}
+@@ -280,13 +280,13 @@
+ endif ( LIBFLUID_CPPFLAGS )
+
+ target_link_libraries ( libfluidsynth
++ ${PORTAUDIO_LIBRARIES}
+ ${GLIB_LIBRARIES}
+ ${LASH_LIBRARIES}
+ ${LADCCA_LIBRARIES}
+ ${JACK_LIBRARIES}
+ ${ALSA_LIBRARIES}
+ ${PULSE_LIBRARIES}
+- ${PORTAUDIO_LIBRARIES}
+ ${LIBSNDFILE_LIBRARIES}
+ ${DBUS_LIBRARIES}
+ ${READLINE_LIBS}
diff --git a/audio/fluidsynth/files/patch-src__bindings__fluid_rtkit.c b/audio/fluidsynth/files/patch-src__bindings__fluid_rtkit.c
new file mode 100644
index 000000000000..47478bd79733
--- /dev/null
+++ b/audio/fluidsynth/files/patch-src__bindings__fluid_rtkit.c
@@ -0,0 +1,39 @@
+--- src/bindings/fluid_rtkit.c.orig 2011-09-04 16:38:58.000000000 +0900
++++ src/bindings/fluid_rtkit.c 2011-09-05 17:07:06.000000000 +0900
+@@ -34,7 +34,7 @@
+ #include "fluid_rtkit.h"
+
+
+-#if defined(__linux__) || defined(__APPLE__)
++#if defined(__linux__) || defined(__APPLE__) || defined(__FreeBSD__)
+
+ #ifndef _GNU_SOURCE
+ #define _GNU_SOURCE
+@@ -44,12 +44,27 @@
+ #include <string.h>
+ #include <unistd.h>
+ #include <sys/types.h>
++#include <sys/time.h>
+ #include <sys/syscall.h>
+ #include <sys/resource.h>
++#include <sys/param.h>
+
++#if defined(__FreeBSD__)
++#include <pthread_np.h>
++#endif
+
+ static pid_t _gettid(void) {
++#if defined(__FreeBSD__)
++#if __FreeBSD__version > 900030
++ return pthread_getthreadid_np();
++#else
++ long tid;
++ syscall(SYS_thr_self, &tid);
++ return tid;
++#endif
++#else
+ return (pid_t) syscall(SYS_gettid);
++#endif
+ }
+
+ static int translate_error(const char *name) {