aboutsummaryrefslogtreecommitdiff
path: root/audio/fpc-modplug/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2010-08-16 18:22:32 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2010-08-16 18:22:32 +0000
commit204087889ae59ae3baece849f2db57d117307199 (patch)
tree92e39626ded8e1eb9fd0811bdb201717643dd70f /audio/fpc-modplug/Makefile
parent836e353a2c4d0be80df96d6be7f842d44abd716d (diff)
Notes
Diffstat (limited to 'audio/fpc-modplug/Makefile')
-rw-r--r--audio/fpc-modplug/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/audio/fpc-modplug/Makefile b/audio/fpc-modplug/Makefile
new file mode 100644
index 000000000000..198e6988dc35
--- /dev/null
+++ b/audio/fpc-modplug/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: fpc-modplug
+# Date created: 2010-04-22
+# Whom: Christopher Key <cjk32@cam.ac.uk>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= audio lang
+PKGNAMESUFFIX= -modplug
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Free Pascal interface to modplug library
+
+USE_FPC= yes
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR}
+
+OPTIONS= LIBMODPLUG "Install modplug library" on
+
+.include "${MASTERDIR}/Makefile"