aboutsummaryrefslogtreecommitdiff
path: root/audio/freebirth/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-12-29 06:39:55 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-12-29 06:39:55 +0000
commitb907d4a817d9647674d246e40dcf625feb052e6e (patch)
treed9e3468434770b0333f65aa18f19ca257a360fdb /audio/freebirth/Makefile
parent66cf3707e514b04a367cb39dcb25db4388adce87 (diff)
downloadports-b907d4a817d9647674d246e40dcf625feb052e6e.tar.gz
ports-b907d4a817d9647674d246e40dcf625feb052e6e.zip
Notes
Diffstat (limited to 'audio/freebirth/Makefile')
-rw-r--r--audio/freebirth/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/audio/freebirth/Makefile b/audio/freebirth/Makefile
new file mode 100644
index 000000000000..25cceeed088e
--- /dev/null
+++ b/audio/freebirth/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: freebirth
+# Date created: 27 Dec 2001
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= freebirth
+PORTVERSION= 0.3.2
+CATEGORIES= audio
+MASTER_SITES= http://www.bitmechanic.com/projects/freebirth/
+
+MAINTAINER= dyeske@yahoo.com
+
+USE_GMAKE= yes
+USE_GTK= yes
+USE_X_PREFIX= yes
+
+pre-build:
+ @${PERL} -pi -e 's@-g -O6@${CFLAGS}@g; s@CC=gcc@CC=${CC}@g; \
+ s@^all: freebirth@all: Makefile.deps freebirth @g; \
+ s@gtk-config@${GTK_CONFIG}@g; \
+ s@^LDFLAGS=@LDFLAGS=\$${LOADLIBES}@g' \
+ ${WRKSRC}/Makefile
+ @${PERL} -pi -e 's@^#define FB_SAMPLES "."@#define FB_SAMPLES "${PREFIX}/share/freebirth"@g;' \
+ ${WRKSRC}/raw_wave.h
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/freebirth ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/fusebirth ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/freebirth/raw
+ ${INSTALL_DATA} ${WRKSRC}/raw/*.raw ${PREFIX}/share/freebirth/raw
+ ${STRIP_CMD} ${PREFIX}/bin/freebirth
+ ${STRIP_CMD} ${PREFIX}/bin/fusebirth
+
+.include <bsd.port.mk>