aboutsummaryrefslogtreecommitdiff
path: root/audio/gbemol
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-03-13 14:51:35 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-03-13 14:51:35 +0000
commit22653073d7da570c4ae797a261bae28ec3837c95 (patch)
tree6e8d9af370653d9e71ff36368ca79e7525b35752 /audio/gbemol
parent2a51f06664f4cc07bf064be2f5ed7455abe4d7c2 (diff)
downloadports-22653073d7da570c4ae797a261bae28ec3837c95.tar.gz
ports-22653073d7da570c4ae797a261bae28ec3837c95.zip
gbemol is a graphical frontend for the Music Player Daemon (MPD) it is
written in C and uses the GTK+ toolkit for it's interface. WWW: http://gbemol.sourceforge.net/ PR: ports/120960 Submitted by: Thomas M. Hermann <tmh.public@gmail.com>
Notes
Notes: svn path=/head/; revision=208954
Diffstat (limited to 'audio/gbemol')
-rw-r--r--audio/gbemol/Makefile29
-rw-r--r--audio/gbemol/distinfo3
-rw-r--r--audio/gbemol/pkg-descr4
-rw-r--r--audio/gbemol/pkg-plist4
4 files changed, 40 insertions, 0 deletions
diff --git a/audio/gbemol/Makefile b/audio/gbemol/Makefile
new file mode 100644
index 000000000000..86ddd7b559f8
--- /dev/null
+++ b/audio/gbemol/Makefile
@@ -0,0 +1,29 @@
+# New ports collection Makefile for: gbemol
+# Date created: 2008-02-21
+# Whom: Thomas M. Hermann <tmh.public@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gbemol
+PORTVERSION= 0.3.1
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= tmh.public@gmail.com
+COMMENT= Graphical frontend for the Music Player Daemon
+
+LIB_DEPENDS= mpd:${PORTSDIR}/audio/libmpd \
+ curl.4:${PORTSDIR}/ftp/curl \
+ xml2.5:${PORTSDIR}/textproc/libxml2
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
+
+post-patch:
+ @${CHMOD} a+x ${WRKSRC}/install-sh
+ @${REINPLACE_CMD} -e 's,$$(DATADIRNAME)/locale,share/locale,' ${WRKSRC}/po/Makefile.in.in
+
+.include <bsd.port.mk>
diff --git a/audio/gbemol/distinfo b/audio/gbemol/distinfo
new file mode 100644
index 000000000000..351d58c40315
--- /dev/null
+++ b/audio/gbemol/distinfo
@@ -0,0 +1,3 @@
+MD5 (gbemol-0.3.1.tar.gz) = 640e26c7455f9201807ca658ef28885f
+SHA256 (gbemol-0.3.1.tar.gz) = d11cddd1564cc2cf855e88cbaee15d4c702b1dced580033d7f8262fe5ff009e0
+SIZE (gbemol-0.3.1.tar.gz) = 438656
diff --git a/audio/gbemol/pkg-descr b/audio/gbemol/pkg-descr
new file mode 100644
index 000000000000..4774a44b861a
--- /dev/null
+++ b/audio/gbemol/pkg-descr
@@ -0,0 +1,4 @@
+gbemol is a graphical frontend for the Music Player Daemon (MPD) it is
+written in C and uses the GTK+ toolkit for it's interface.
+
+WWW: http://gbemol.sourceforge.net/
diff --git a/audio/gbemol/pkg-plist b/audio/gbemol/pkg-plist
new file mode 100644
index 000000000000..b2ab696356c0
--- /dev/null
+++ b/audio/gbemol/pkg-plist
@@ -0,0 +1,4 @@
+bin/gbemol
+share/pixmaps/gbemol.png
+share/applications/gbemol.desktop
+@dirrmtry share/applications