aboutsummaryrefslogtreecommitdiff
path: root/audio/gmpc-libnotify
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
commitfe61bf1eb4f2758636a3c065686a833eb412df25 (patch)
tree1474457ea487adcafec2ab29e99ab61897a3e479 /audio/gmpc-libnotify
parent5732783897145621b6af3ab08fba8d9af40f338b (diff)
Notes
Diffstat (limited to 'audio/gmpc-libnotify')
-rw-r--r--audio/gmpc-libnotify/Makefile3
-rw-r--r--audio/gmpc-libnotify/files/patch-src_plugin.c20
2 files changed, 22 insertions, 1 deletions
diff --git a/audio/gmpc-libnotify/Makefile b/audio/gmpc-libnotify/Makefile
index 76f9ef312cfa..3cf49e201c88 100644
--- a/audio/gmpc-libnotify/Makefile
+++ b/audio/gmpc-libnotify/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gmpc-libnotify
PORTVERSION= 0.20.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://download.sarine.nl/Programs/gmpc/${PORTVERSION}/ \
http://freebsd.unixfreunde.de/sources/
@@ -15,7 +16,7 @@ MAINTAINER= miwi@FreeBSD.org
COMMENT= A libnotify for gmpc
LIB_DEPENDS= mpd.3:${PORTSDIR}/audio/libmpd \
- notify.1:${PORTSDIR}/devel/libnotify
+ notify.4:${PORTSDIR}/devel/libnotify
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gmpc.pc:${PORTSDIR}/audio/gmpc
RUN_DEPENDS= gmpc:${PORTSDIR}/audio/gmpc
diff --git a/audio/gmpc-libnotify/files/patch-src_plugin.c b/audio/gmpc-libnotify/files/patch-src_plugin.c
new file mode 100644
index 000000000000..3e4a485aad56
--- /dev/null
+++ b/audio/gmpc-libnotify/files/patch-src_plugin.c
@@ -0,0 +1,20 @@
+--- src/plugin.c.orig 2011-08-15 20:17:11.000000000 +0200
++++ src/plugin.c 2011-08-15 20:18:35.000000000 +0200
+@@ -149,16 +149,13 @@ static void libnotify_song_changed(MpdOb
+ if(not == NULL)
+ {
+ // notify_notification_close(not, NULL);
+- not = notify_notification_new(summary, buffer,NULL, NULL);
++ not = notify_notification_new(summary, buffer,NULL);
+ }
+ else{
+ notify_notification_update(not, summary, buffer, NULL);
+ }
+ notify_notification_set_urgency(not, NOTIFY_URGENCY_LOW);
+
+- if(cfg_get_single_value_as_int_with_default(config, "libnotify-plugin", "attach-to-tray", TRUE))
+- notify_notification_attach_to_status_icon(not, tray_icon2_gsi);
+-
+ g_free(summary);
+ /* Add the song to the widget */
+ g_object_set_data_full(G_OBJECT(not), "mpd-song", mpd_songDup(song), (GDestroyNotify)mpd_freeSong);