aboutsummaryrefslogtreecommitdiff
path: root/audio/gmsynth-lv2
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-10 23:22:45 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-10 23:22:45 +0000
commit80c704a4f6523926f3d3cfeae558c38d2c70a5b2 (patch)
tree743d107cc7c378fb7eb3ac395310d67a80a9b1dd /audio/gmsynth-lv2
parent458bc1943dccb536f96f563eb04c2043f4645def (diff)
downloadports-80c704a4f6523926f3d3cfeae558c38d2c70a5b2.tar.gz
ports-80c704a4f6523926f3d3cfeae558c38d2c70a5b2.zip
Notes
Diffstat (limited to 'audio/gmsynth-lv2')
-rw-r--r--audio/gmsynth-lv2/Makefile29
-rw-r--r--audio/gmsynth-lv2/distinfo3
-rw-r--r--audio/gmsynth-lv2/files/patch-Makefile19
-rw-r--r--audio/gmsynth-lv2/pkg-descr3
4 files changed, 54 insertions, 0 deletions
diff --git a/audio/gmsynth-lv2/Makefile b/audio/gmsynth-lv2/Makefile
new file mode 100644
index 000000000000..100038574599
--- /dev/null
+++ b/audio/gmsynth-lv2/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= gmsynth
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.3.0
+CATEGORIES= audio
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= General MIDI LV2 Synth
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth
+
+USES= gmake pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= x42
+GH_PROJECT= ${PORTNAME}.lv2
+USE_GNOME= glib20
+
+PLIST_FILES= lib/lv2/${PORTNAME}.lv2/GeneralUser_LV2.sf2 \
+ lib/lv2/${PORTNAME}.lv2/${PORTNAME}.so \
+ lib/lv2/${PORTNAME}.lv2/${PORTNAME}.ttl \
+ lib/lv2/${PORTNAME}.lv2/manifest.ttl
+
+.include <bsd.port.mk>
diff --git a/audio/gmsynth-lv2/distinfo b/audio/gmsynth-lv2/distinfo
new file mode 100644
index 000000000000..4849d41e89f9
--- /dev/null
+++ b/audio/gmsynth-lv2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520723141
+SHA256 (x42-gmsynth.lv2-v0.3.0_GH0.tar.gz) = 0f18c56ef55307bbf5894d013a5b0c232c920b13e27d6998cc19e80948efb2ba
+SIZE (x42-gmsynth.lv2-v0.3.0_GH0.tar.gz) = 28563480
diff --git a/audio/gmsynth-lv2/files/patch-Makefile b/audio/gmsynth-lv2/files/patch-Makefile
new file mode 100644
index 000000000000..7145657988b0
--- /dev/null
+++ b/audio/gmsynth-lv2/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile.orig 2018-03-10 23:08:50 UTC
++++ Makefile
+@@ -136,13 +136,13 @@ FLUID_SRC = \
+ fluidsynth/src/fluid_settings.c \
+ fluidsynth/src/fluid_sys.c
+
+-CPPFLAGS += -Ifluidsynth -I fluidsynth/fluidsynth -DHAVE_CONFIG_H -D DEFAULT_SOUNDFONT=\"\"
+-DSP_SRC = src/$(LV2NAME).c $(FLUID_SRC)
++FS_CFLAGS = `pkg-config --cflags --libs fluidsynth` -DHAVE_CONFIG_H -D DEFAULT_SOUNDFONT=\"\"
++DSP_SRC = src/$(LV2NAME).c # $(FLUID_SRC)
+ DSP_DEPS = $(DSP_SRC)
+
+ $(BUILDDIR)$(LV2NAME)$(LIB_EXT): $(DSP_DEPS) Makefile
+ @mkdir -p $(BUILDDIR)
+- $(CC) $(CPPFLAGS) $(CFLAGS) -std=c99 \
++ $(CC) $(FS_CFLAGS) $(CFLAGS) -std=c99 \
+ -o $(BUILDDIR)$(LV2NAME)$(LIB_EXT) $(DSP_SRC) \
+ -shared $(LV2LDFLAGS) $(LDFLAGS) $(LOADLIBES)
+ $(STRIP) $(STRIPFLAGS) $(BUILDDIR)$(LV2NAME)$(LIB_EXT)
diff --git a/audio/gmsynth-lv2/pkg-descr b/audio/gmsynth-lv2/pkg-descr
new file mode 100644
index 000000000000..642b60d90ccb
--- /dev/null
+++ b/audio/gmsynth-lv2/pkg-descr
@@ -0,0 +1,3 @@
+Midi to sound LV2 converter.
+
+WWW: https://x42-plugins.com/x42/x42-gmsynth